Autodesk 参照管理器

参照管理器指南
Autodesk 参照管理器 >
Autodesk 参照管理器
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

AutoCAD® 图形可以参照多种类型的外部文件，包括图形、文字字体、图像和打印配置。这些参照文件的路径保存在每个 AutoCAD 图形中。有时可能需要将图形文件或它们参照的文件移动到其他文件夹或其他光盘驱动器中，这时就需要更新保存的参照路径。打开每个图形文件然后手动更新保存的每个参照路径是一个冗长乏味的过程。

Autodesk 参照管理器提供了多种工具，可以列出选定图形中的参照文件，可以修改保存的参照路径而不必打开 AutoCAD 中的图形文件。利用参照管理器，可以轻松地标识并修复包含未融入参照的图形。

参照管理器是单机应用程序，可以从“开始”菜单 (Windows)-“程序”下的 Autodesk 程序组中访问。

请将您关于此页内容的评论发送给我们


参照管理器指南

Autodesk 参照管理器
概述
Autodesk 参照管理器 >
参照管理器指南
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

《参照管理器指南》解释参照管理器的概念，提供详细的操作步骤并附有解释相关术语的词汇表。

本节内容

  • 概述
  • 选择和列出图形参照
  • 更改已保存的参照路径
  • 创建报告和日志文件


概述

参照管理器指南
参照管理器指南
选择和列出图形参照
Autodesk 参照管理器 > 参照管理器指南 >
概述
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

重新定位 AutoCAD 图形文件或其参照的外部文件时，请使用参照管理器修改图形中保存的参照文件路径。

参照管理器应用程序窗口的结构

“参照管理器”窗口包括两个窗格。左侧窗格显示选定图形及其参照的外部文件的树状图。

树状图有助于用户在右侧窗格中查找和加载内容，右侧窗格称为“参照”列表。“参照”列表显示参照的列表，用户可以在其中选择和编辑保存的参照路径信息。

更改已保存参照路径的步骤概要

要更改已保存的参照路径，请执行以下步骤：

  1. 确保要处理的所有图形均已关闭，且未将其 Windows“属性”特性设置为“只读”。参照管理器不会更改任何处于打开状态或只读状态的图形中保存的参照路径。
  2. 向树状图中添加图形和图形文件夹。（可以在此列表中编辑图形所参照的文件路径。）
  3. 从树状图窗格中选择图形或参照。参照将显示在“参照”列表窗格中。
  4. 从“参照”列表中选择一个或多个参照文件。
  5. 修改选定参照的已保存的参照路径。
  6. 单击“应用”可以将路径更改保存到图形文件中。更新的图形文件以当前 AutoCAD 文件格式保存，并将随之更新其 BAK 文件。
  7. 查看“详细信息”报告以确认更改生效。用户也可以查看日志文件，对已保存参照路径的所有更改都将附加到日志文件中。

限制

参照管理器当前并非对图形所参照的所有文件都提供支持。不受支持的参照包括与文字样式无关联的文字字体、OLE 链接、超级链接、数据库文件链接、PMP 文件以及 Web 上的 URL 的外部参照。如果参照管理器遇到 URL 的外部参照，它会将参照报告为“未找到”。

注意不保存已编辑的 TrueType 字体路径。AutoCAD 将始终在 Windows“Fonts”文件夹中搜索 TrueType 字体。


选择和列出图形参照

概述
参照管理器指南
选择图形文件和文件夹
Autodesk 参照管理器 > 参照管理器指南 >
选择和列出图形参照
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

更改 AutoCAD 图形文件中已保存的参照路径之前，可以选择要进行操作的图形，然后检查每个图形中的参照列表。

本节内容

  • 选择图形文件和文件夹
  • 列表参照和显示信息


选择图形文件和文件夹

选择和列出图形参照
选择和列出图形参照
列表参照和显示信息
Autodesk 参照管理器 > 参照管理器指南 > 选择和列出图形参照 >
选择图形文件和文件夹
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用对话框或将图形文件和文件夹拖至树状图中，选择要添加至树状图列表中的图形文件。将图形添加至树状图列表后，可以编辑这些图形中参照的任何文件的路径。

使用“添加图形”对话框，用户可以像在 Windows 资源管理器中一样，单独选择图形文件或通过使用 SHIFT 键和 CTRL 键来进行选择。也可以将图形从桌面、工程文件夹和 Windows 资源管理器拖至树状图列表。可以从树状图列表中删除单个图形或所有图形。

如果树状图中列出了两个同名的图形，则表示这两个图形位于不同的文件夹或具有不同的保存路径。

注意如果用户要添加的图形已被添加到树状图，则该图形将不会被重载到参照管理器中。如果需要更新树状图，请在再次添加图形之前将其删除。

包含外部参照的图形

如果要添加的图形包含外部参照，参照管理器可以自动将所有参照的图形作为选项添加至树状图列表。在“添加图形”操作期间，参照管理器将显示一个对话框，使用户可以添加外部参照；用户也可以在参照管理器的“选项”对话框中设置选项。

宿主图形未添加到树状图时，嵌套的外部参照的图标将灰显。要添加宿主图形，请双击灰显的图标以显示“添加图形”对话框。

处于打开或只读状态的图形

即使图形文件处于打开状态或设置为“只读”，也可以将图形添加到树状图列表中。但是，在这种情况下，将不会对图形应用任何路径更改，并且“详细信息”对话框和参照管理器日志文件将确认未对图形文件进行任何修改。由于将图形添加到参照管理器后仍然可以更改其状态，因此在尝试添加只读图形时将不显示警告信息。因此，在开始参照管理器进程之前，请确保所有图形文件都可以编辑。

注意当参照管理器正在添加用户选择的图形时，单击“停止”将在添加了当前图形之后取消操作。

操作步骤

将图形添加到树状图的步骤
  1. 依次单击“文件”菜单 [image] “添加图形”。
  2. 在“添加图形”对话框中，选择一个或多个图形文件。可以单独选择图形文件，也可以在选择时使用 SHIFT 或 CTRL 键选择多个图形文件。然后单击“确定”。
    提示此外，可以在 Windows 资源管理器中选择一个或多个图形文件，并将它们拖至树状图。
将图形文件夹添加到树状图的步骤
  • 在 Windows 资源管理器中，选择一个或多个文件夹并将其拖至树状图。
从树状图中删除图形的步骤
  1. 在“视图”菜单中，确保选择了“按图形列表”。
  2. 在树状图中，选择要从列表中删除的图形。
  3. 依次单击“文件”菜单 [image] “删除图形”。
从树状图中删除所有图形的步骤
  1. 在树状图中，单击顶层节点“所有图形”或“按参照”。
  2. 依次单击“文件”菜单 [image] “删除图形”。


列表参照和显示信息

选择图形文件和文件夹
选择和列出图形参照
树状图的操作
Autodesk 参照管理器 > 参照管理器指南 > 选择和列出图形参照 >
列表参照和显示信息
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要有效地使用参照管理器，请使用树状图和“参照”列表中的显示选项。

本节内容

  • 树状图的操作
  • 参照列表的操作


树状图的操作

列表参照和显示信息
列表参照和显示信息
参照列表的操作
Autodesk 参照管理器 > 参照管理器指南 > 选择和列出图形参照 > 列表参照和显示信息 >
树状图的操作
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

参照管理器左侧窗格中的树状图提供了用户添加到树状图列表中的图形中参照的层次列表。用户可以控制树状图的显示样式，并且可以单击加号 (+) 或减号 (-) 以展开或收拢树状图中称为节点的项目。

树状图有两种组织类型：“按图形列表”和“按参照类型列表”。“按图形列表”显示按图形文件组织的节点的层次列表。“按参照类型列表”显示根据各种类型的参照组织的节点的层次列表。

注意即使只显示图形名，图形文件也会根据其完整路径名的字母顺序排序。

可以展开和折叠树状图中的节点，以列出其中包含的参照。从树状图中选择的内容决定“参照”列表中显示的内容：

  • 如果选择顶层节点，将显示所有参照。
  • 如果选择图形，只显示该图形中的参照。
  • 如果在“按参照类型列表”模式中选择参照类型，将显示树状图中当前所有图形中该类型的所有参照。
  • 如果选择参照，将显示所有嵌套的参照。
  • 如果选择了参照层次结构中最低层次的项目，“参照”列表中将显示该参照。
注意如果选择“按参照类型列表”，每个参照只显示一次，无论有多少图形使用该参照。

用户可以从树状图列表中选择并删除任何图形，包括样板图形 (.dwt) 和标准图形 (.dws) 以及常规 AutoCAD 图形 (.dwg)。

包含外部参照的图形

对于带有嵌套外部参照的图形而言，树状图还具备其他几个功能。

使用参照管理器的树状图中的图标，用户可以查找包含无法定位其路径的外部参照的图形。在某些复杂的情况中，路径不正确的外部参照可能不在“参照”列表中列出，但可能在树状图中列出。

参照管理器提供了一个选项，可以在将图形添加至树状图时自动添加所有图形的嵌套外部参照。如果需要编辑嵌套外部参照的路径，使用此选项可以节省时间。

当图形中嵌套外部参照覆盖时，参照管理器可以模拟 AutoCAD 的显示行为。外部参照覆盖中嵌套的任何外部参照的列出方式与 AutoCAD 显示它们的方式相同。如果外部参照覆盖在 AutoCAD 图形中的嵌套深度超过一层，附着到外部参照覆盖的任何外部参照将不会在参照管理器树状图中列出。

注意建议不要使用 AutoCAD 编辑嵌套比当前图形文件更多层路径的外部参照路径。要在这些图形中恢复外部参照路径信息，可以使用参照管理器这个方便的工具。

操作步骤

按图形名列出参照的步骤
  • 依次单击“视图”菜单 [image] “按图形列表”。
按参照类型列出参照的步骤
  • 依次单击“视图”菜单 [image] “按参照类型列表”。


参照列表的操作

树状图的操作
列表参照和显示信息
更改已保存的参照路径
Autodesk 参照管理器 > 参照管理器指南 > 选择和列出图形参照 > 列表参照和显示信息 >
参照列表的操作
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

参照管理器右侧窗格中的“参照”列表提供当前在树状图中选定的项目中的参照列表。可以控制“参照”列表中列的显示。

选择树状图中的项目时，与项目相关联的参照将显示在“参照”列表中。可以从“参照”列表中选择参照，以更改其保存的参照路径。

每个参照的数据将以列的形式显示在“参照”列表中。可以使用鼠标右键单击列标题，对该列中的项目进行排序，或者控制是否显示该列。也可以向左或向右拖动列以更改其次序。

使用“参照管理器选项”对话框，可以完全控制“参照”列表。

注意由于驱动器号映射已指定给驱动器，因此位于网络硬盘驱动器上的参照将在“参照”列表中显示为“在不同位置找到”。例如，一台计算机上的驱动器号 C: 的已保存参照路径在另一台计算机上可能指向网络驱动器 H:。

操作步骤

对“参照”列表列排序的步骤
  • 单击列标题按该列对所有参照排序。再次单击列标题反转排列次序。
隐藏“参照”列表列的步骤
  • 在列标题上单击鼠标右键。单击“隐藏列”。
显示隐藏的“参照”列表列的步骤
  1. 依次单击“视图”菜单 [image] “选项”。
  2. 在“选项”对话框中的“要显示的列”下，单击要显示的列名。
  3. 单击“确定”。
更改“参照”列表列的位置的步骤
  • 将列标题向左或向右拖动至新位置。


更改已保存的参照路径

参照列表的操作
参照管理器指南
已保存参照路径的类型
Autodesk 参照管理器 > 参照管理器指南 >
更改已保存的参照路径
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以从“参照”列表中选择一个或多个参照，以更改已保存的参照路径信息。

选择参照后，可以使用以下对话框之一：

  • 编辑选定的路径。将所有选定参照的已保存路径更改为用户输入的新路径名称。
  • 查找并替换选定路径。从用户选择的所有参照中定位所有使用指定的已保存路径的参照，然后使用新路径将其替换，而不替换其他参照。处理需要在其中过滤已保存的参照路径的大型图形集时，此操作尤其有用。

    也可以在“参照”列表的项目上单击鼠标右键，以显示可用操作（包括对文件特性的访问）的快捷菜单。

本节内容

  • 已保存参照路径的类型


已保存参照路径的类型

更改已保存的参照路径
更改已保存的参照路径
创建报告和日志文件
Autodesk 参照管理器 > 参照管理器指南 > 更改已保存的参照路径 >
已保存参照路径的类型
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用参照管理器，可以将已保存的参照路径更改为绝对（完全指定的）路径或相对（部分指定的）路径。也可以通过将参照路径保存为空字段来清除所有已保存路径的信息。在这种情况下，AutoCAD 将使用当前配置或工程名中保存的支持文件的搜索路径或信息融入参照。

如果附着的外部参照没有保存的路径信息，搜索将按以下顺序进行：

  • 宿主图形的当前文件夹
  • 在“选项”对话框的“文件”选项卡以及 PROJECTNAME 系统变量中定义的工程搜索路径
  • 在“选项”对话框的“文件”选项卡上定义的支持搜索路径
  • 在 Windows 应用程序快捷方式中指定的起始文件夹

参照管理器将使用 AutoCAD 当前版本中的搜索路径规则。

指定相对文件夹路径的约定如下：

\ | 查看宿主图形驱动器的根文件夹
路径 | 从根文件夹中，按照指定的路径
.\路径 | 从宿主图形的文件夹中，按照指定的路径
..\路径 | 从宿主图形的文件夹中，向上移动一层文件夹并按照指定的路径
..\..\路径 | 从宿主图形的文件夹中，向上移动两层文件夹并按照指定的路径
注意如果包含参照文件的图形被移动或保存到另一个路径、另一个本地硬盘驱动器或另一个网络服务器，则必须编辑所有相对路径，使其适应宿主图形的新位置，或者必须重新定位参照文件。

查找和更正未融入的参照

要查找所有未融入的参照，请将一组图形添加至树状图列表，然后扫描树状图中是否存在已破坏的图形图标。检查“参照”列表中每个已破坏的图形，以查找哪些参照未融入。在以下插图中，图形 1_abc.dwg 已被破坏。它参照了未融入的外部参照 1_q.dwg。

在树状图中，只有外部参照显示“未找到”图标（插图中以叹号显示）。其他所有未融入的参照必须在“参照”列表中标识。包含从其他位置（不是保存的参照路径指定的位置）找到的外部参照的图形不会显示为已被破坏。

应用路径更改

更改一个或多个已保存的参照路径后，请使用“应用”将更改保存到图形文件中。单击“应用”，只会影响“参照”列表的“状态”列中带有铅笔图标的参照。

单击“应用”后，更新的图形文件将以当前的图形文件格式保存。同时将创建或更新备份图形文件 (.bak)。

应用路径更改后，会显示一个对话框，报告已成功更改的数量。可以单击“详细信息”查看所做更改的完整列表。

路径更改失败

单击“应用”后，“详细信息”对话框（可以通过“概要”对话框访问）将报告所有的失败。导致失败的原因可能有以下几种：

  • 如果在将图形添加至参照管理器中的树状图之后，但在应用任何路径更改之前在 AutoCAD 中打开图形文件，图形文件将被 AutoCAD 锁定，并且在参照管理器中指定的任何路径更改将不能保存到该图形文件中。
  • 如果在将图形添加至参照管理器中的树状图之后，但在应用任何路径更改之前将图形文件移至其他文件夹，参照管理器将无法在其新位置找到该图形文件，并且指定的任何路径更改将不能保存到该文件中。
  • 如果图形文件设置为“只读”，参照管理器中指定的任何路径更改都不能保存到该图形文件中。

如果“详细信息”对话框报告任何失败，在解决图形文件的问题后请再次单击“应用”。

操作步骤

更改保存的参照路径的步骤
  1. 在树状图中，单击图形或参照。
  2. 在“参照”列表中，选择一个或多个参照，以更改其保存的路径。选择时按住 CTRL 或 SHIFT 键，可以从“参照”列表中选择多个参照。
  3. 依次单击“编辑”菜单 [image] “编辑选定的路径”。
  4. 在“编辑选定的路径”对话框的“新保存的路径”中，输入新的路径名。可以单击“浏览文件夹”查找文件夹的位置。
  5. 单击“确定”。

对于选定的参照，所有路径名将更改为用户在“新保存的路径”中输入的路径。

替换已保存参照路径的所有实例的步骤
  1. 在树状图中，单击图形或参照。
  2. 在“参照”列表中，选择一个或多个参照，以替换其已保存的路径。选择时按住 CTRL 或 SHIFT 键，可以从“参照”列表中选择多个参照。
  3. 依次单击“编辑”菜单 [image] “查找和替换”。
  4. 在“查找和替换选定的路径”对话框的“查找保存的路径”中，在所有选定的参照中输入要更改的现有路径名。可以单击“浏览文件夹”查找文件夹的位置。
  5. 在“替换为”中，输入新的路径名。可以单击“浏览文件夹”查找文件夹的位置。
  6. 单击“全部替换”。

对于选定的参照，所有与您在“查找搜索路径”中输入的路径匹配的路径名都会替换为在“替换为”中输入的路径。

将所有参照路径更改保存到图形文件的步骤
  1. 依次单击“文件”菜单 [image] “应用更改”。
  2. 单击“确定”或单击“详细信息”，查看所有已保存路径更改的报告。


创建报告和日志文件

已保存参照路径的类型
参照管理器指南
Autodesk 参照管理器 (AdRefMan)
Autodesk 参照管理器 > 参照管理器指南 >
创建报告和日志文件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以输出当前在参照管理器中添加的图形文件中的参照的报告。也可以为保存的参照路径更改保留日志。

创建报告

可以使用以下三种格式之一从所有列（显示的列或未显示的列）输出参照数据的报告：

  • 可扩展标记语言 (.xml)
  • 逗号分隔值 (.csv)
  • Microsoft Excel 工作簿 (.xls)

将更改记录到日志文件

保留日志文件的目的是自动将每一个更改都记录到参照管理器生成的已保存参照路径中，即使是遇到多进程的情况也一样。如果应用对已保存参照路径的更改，此更改将被添加到日志文件“log.txt”中。默认情况下，此日志文件位于用户的“我的文档”文件夹中。

可以在“参照管理器选项”对话框中关闭日志文件。

操作步骤

输出参照管理器报告的步骤
  1. 依次单击“文件”菜单 [image] “输出报告”。
  2. 在“输出报告”对话框中的“文件名”下，输入报告的名称。在“文件类型”下，选择报告的文件格式。
  3. 单击“保存”。默认情况下，报告被保存到用户的“我的文档”文件夹的“log.txt”文件中。
打开或关闭日志文件的步骤
  1. 依次单击“视图”菜单 [image] “选项”。
  2. 在“选项”对话框中，选择或清除“写入日志文件”。
  3. 单击“确定”。


Autodesk 参照管理器 (AdRefMan)

创建报告和日志文件
Autodesk“参照管理器”窗口
Autodesk 参照管理器 >
Autodesk 参照管理器 (AdRefMan)
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

修改保存在 AutoCAD 图形中的参照路径

将显示Autodesk“参照管理器”窗口。

本节内容

  • Autodesk“参照管理器”窗口
  • Autodesk 参照管理器菜单
  • “添加图形”对话框
  • “编辑选定路径”对话框
  • “查找和替换选定的路径”对话框
  • “输出报告”对话框
  • “选项”对话框
  • “概要”对话框
  • “详细信息”对话框


Autodesk“参照管理器”窗口

Autodesk 参照管理器 (AdRefMan)
Autodesk 参照管理器 (AdRefMan)
Autodesk 参照管理器菜单
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
Autodesk“参照管理器”窗口
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
菜单:“开始”菜单 (Windows) [image] “程序” [image] “Autodesk” [image] “AutoCAD” [image] “参照管理器”

提供了两个窗格，用于列出选定图形中的参照文件以及修改已保存的参照路径（无需在 AutoCAD 中打开图形）。

树状图

在左侧显示一个窗格，其中包含一个由图形以及图形中保存的文件参照构成的树状图。在树状图中添加图形文件后，即可编辑保存在其中的文件参照路径。可以以两种样式列出树状图中的信息：“按图形列表”或“按参照类型列表”。

所有图形

显示树状图中添加的图形的列表。每个图形节点都可以展开，显示多种文件参照类型。每种文件参照类型也可以展开，显示此类型的参照。带有外部参照的图形可能包含若干嵌套的参照级别。如果无法定位图形中的一个或多个参照，那么图形图标将沿对角线方向断开。如果丢失的参照是外部参照，则该外部参照的图标中将显示一个红色的感叹号 (!)。

按参照

显示添加到树状图中的图形中保存的参照类型列表。每种参照类型都可以展开，显示该类型的文件列表。

“参照”列表

在右侧显示一个窗格，其中显示树状图中选定项目中的文件参照。如果选中了树状图中的“所有图形”或“按参照”，那么“参照”列表中将显示所有参照。每个参照的信息将显示在若干列下。

类型

标识参照文件的类型。支持的参照类型包括外部参照附着、外部参照覆盖、文字字体、打印样式、打印配置、标准、图像和形。

状态

标识找到的参照是否使用保存在图形中的路径（融入）、使用与保存在图形中的路径不同的路径（在不同位置找到），或者找不到参照（未找到）。

文件名

显示参照文件的名称和扩展名，例如“txt.shx”。

参照名

显示图形中的参照使用的名称。例如，Standard 是指定给“txt.shx” 的默认名称。

保存路径

当前保存在图形中的参照的路径。如果“保存路径”为空，则说明未保存参照路径，这时 AutoCAD 将使用指定的搜索路径搜索保存路径。

找到路径

AutoCAD 将在其中找到参照文件的路径。

宿主图形

包含参照的图形文件。

宿主版本

包含参照的 AutoCAD 图形的数据库版本。可能有多个 AutoCAD 版本使用相同的数据库版本。


Autodesk 参照管理器菜单

Autodesk“参照管理器”窗口
Autodesk 参照管理器 (AdRefMan)
“添加图形”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
Autodesk 参照管理器菜单
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

为所有参照管理器操作提供工具。其他工具（例如，“复制到剪贴板”）可以从树状图中的快捷菜单和“参照”列表中访问。

“文件”菜单

控制与文件相关的操作。

添加图形

显示“添加图形”对话框，用户可在其中指定要添加到树状图列表的图形文件。

删除图形

指定要从树状图列表中删除的图形文件。如果单击了树状图中的顶层节点，将删除所有图形。

输出报告

显示“输出报告”对话框，用户可在其中通过当前已在参照管理器中添加的图形文件中的参照来创建文件。

应用更改

将指定的更改保存到图形文件的参照路径中。

退出

关闭 Autodesk 参照管理器。

“编辑”菜单

控制参照选择和路径编辑操作。

全部选择

选择“参照”列表中显示的所有参照。

取消全选

清除“参照”列表中的所有选择。

反向选择

反转“参照”列表中参照的选择状态。

编辑选定的路径

显示“编辑选定的路径”对话框，用户可在其中将所有选定参照的已保存路径更改为用户输入的新路径名称。

查找和替换选定的路径

显示“查找和替换选定的路径”对话框，用户可在其中从用户选择的所有参照中定位所有使用指定的已保存路径的参照，然后使用新路径将其替换，而不替换其他参照。

“视图”菜单

控制显示选项。

按图形列表

显示按图形文件组织的节点的层次结构列表。

按参照类型列表

显示按照不同参照类型组织的节点的层次结构列表。

选项

显示“选项”对话框，用户可在其中控制参照管理器的显示和操作。

“帮助”菜单

提供对参照管理器帮助系统的访问。

帮助

显示帮助。

关于

显示关于 Autodesk 参照管理器的信息，包括版本和版权。


“添加图形”对话框

Autodesk 参照管理器菜单
Autodesk 参照管理器 (AdRefMan)
“编辑选定路径”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“添加图形”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
工具栏:“工具栏”
菜单:“文件” [image] “添加图形”

向树状图中添加图形和图形文件夹。可以编辑此列表中的图形参照的文件的路径。

“位置”列表

提供对预定义文件位置的快速访问。单击“搜索”箭头查看各图标的路径。用户可以将“位置”列表中的图标拖至新位置，重新排列图标。要向“位置”列表中添加新图标，请将文件夹从文件列表中拖至“位置”列表；或者在现有图标上单击右键，然后在快捷菜单中单击“添加”或“添加当前文件夹”。此快捷菜单还提供删除和修改图标的选项，还可以恢复已删除的默认图标。对“位置”列表的修改将影响所有标准文件选择对话框。

  • 历史记录。显示最近通过对话框访问的文件的快捷方式。建议定期从“历史记录”列表中删除不需要的快捷方式。选择“历史记录”，然后从“文件”列表中选择不需要的快捷方式并单击“删除”。要按日期排列快捷方式，请单击“查看” [image] “详细信息”，然后单击“文件”列表中的“修改时间”列。
  • “个人”/“我的文档”。显示当前用户配置的“个人”或“我的文档”文件夹的内容。此位置的名称（“personal”或“My Document”）取决于操作系统的版本。
  • 收藏夹。显示当前用户配置的“收藏夹”文件夹的内容。此文件夹由文件或文件夹的快捷方式组成，这些文件或文件夹是使用对话框中的“工具” [image] “添加至收藏夹”选项添加至“收藏夹”中的。
  • 桌面。显示桌面的内容。
搜索

显示当前文件夹或驱动器。单击箭头以查看文件夹路径的层次结构并浏览路径树、其他驱动器或网络连接。

返回

返回到上一个文件位置。

上一级

回到当前路径树的上一级。

搜索 Web

参照管理器不支持此功能。

删除

删除选定的文件或文件夹。

创建新文件夹

用指定的名称在当前路径中创建一个新文件夹。

视图

控制“文件”列表的外观。

  • 列表。以多列格式显示“文件”列表的内容。
  • 详细信息。以单列格式显示“文件”列表的内容，同时显示文件详细信息。
工具

提供下列用于选择文件的工具：

  • 查找。显示“查找”对话框，用户可在其中使用名称、位置和修改日期过滤器来搜索文件。
  • 定位。在参照管理器中不可用。
  • 将当前文件夹添加到“位置”列表中。将选定文件夹的图标添加到“位置”列表中，从而可以从所有标准文件选择对话框中快速访问该文件夹。要删除图标，请在该图标上单击右键并单击“删除”。
  • 添加到收藏夹。创建当前“搜索”位置或选定的文件或文件夹的快捷方式。快捷方式将被放置在当前用户配置的“收藏夹”文件夹中，用户可以通过单击“位置”列表中的“收藏夹”对其进行访问。
“文件”列表

显示位于当前路径并属于选定文件类型的文件和文件夹。使用对话框中的“查看”菜单可以在“列表”视图和“详细信息”视图之间切换。

文件名

显示在“文件”列表中选择的文件的名称。如果选择了多个文件，“文件名”将每个选定文件显示在引号 ("") 中。如果在“文件名”框中输入文件名，参照管理器将清除任何选择。输入多个文件名时必须使用引号 ("")。使用空格或逗号分隔多个文件名。可以使用通配符过滤“文件”列表中显示的文件。

文件类型

按文件类型过滤文件列表。

打开

将选定文件添加到参照管理器树状图中。


“编辑选定路径”对话框

“添加图形”对话框
Autodesk 参照管理器 (AdRefMan)
“查找和替换选定的路径”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“编辑选定路径”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
工具栏:“工具栏”
菜单:“编辑” [image] “编辑选定的路径”

更改所有选定参照的保存路径。

新保存的路径

使用您输入的新路径名更改所有选定参照的保存路径。

浏览

在“浏览文件夹”对话框中显示树状视图，从中可以指定新路径。


“查找和替换选定的路径”对话框

“编辑选定路径”对话框
Autodesk 参照管理器 (AdRefMan)
“输出报告”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“查找和替换选定的路径”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
工具栏:“工具栏”
菜单:“编辑” [image] “查找和替换选定的路径”

查找和替换

从选定的所有参照中找出使用指定路径的所有参照，并将此路径的所有匹配项替换为指定的新路径。

查找保存的路径

查找并选择路径名与指定的保存参照路径相匹配的参照。仅搜索选定的参照。此操作过滤当前选定参照的保存的参照路径。

浏览

在“浏览文件夹”对话框中显示树状图，从中可以指定现有路径。

替换为

使用您输入的新路径更改找到的参照的保存参照路径。

浏览

在“浏览文件夹”对话框中显示树状图，从中可以指定新的保存路径。

全部替换

执行查找和替换操作。关闭对话框并保留所做的任何修改。


“输出报告”对话框

“查找和替换选定的路径”对话框
Autodesk 参照管理器 (AdRefMan)
“选项”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“输出报告”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
菜单:“工具栏”
菜单:“文件” [image] “输出报告”

输出当前添加到参照管理器的图形文件中的参照的报告。

“位置”列表

提供对预定义文件位置的快速访问。单击“搜索”箭头查看各图标的路径。用户可以将“位置”列表中的图标拖至新位置，重新排列图标。要向“位置”列表中添加新图标，请将文件夹从文件列表中拖至“位置”列表；或者在现有图标上单击右键，然后在快捷菜单中单击“添加”或“添加当前文件夹”。此快捷菜单还提供删除和修改图标的选项，还可以恢复已删除的默认图标。对“位置”列表的修改将影响所有标准文件选择对话框。

  • 历史记录。显示最近通过对话框访问的文件的快捷方式。建议定期从“历史记录”列表中删除不需要的快捷方式。选择“历史记录”，然后从“文件”列表中选择不需要的快捷方式并单击“删除”。要按日期排列快捷方式，请单击“查看” [image] “详细信息”，然后单击“文件”列表中的“修改时间”列。
  • “个人”/“我的文档”。显示当前用户配置的“个人”或“我的文档”文件夹的内容。此位置的名称（“personal”或“My Document”）取决于操作系统的版本。
  • 收藏夹。显示当前用户配置的“收藏夹”文件夹的内容。此文件夹由文件或文件夹的快捷方式组成，这些文件或文件夹是使用对话框中的“工具” [image] “添加至收藏夹”选项添加至“收藏夹”中的。
  • 桌面。显示桌面的内容。
搜索

显示当前文件夹或驱动器。单击箭头以查看文件夹路径的层次结构并浏览路径树、其他驱动器或网络连接。

返回

返回到上一个文件位置。

上一级

回到当前路径树的上一级。

搜索 Web

显示“浏览 Web”对话框，通过此对话框可以在 Internet 上存储报告文件。

删除

删除选定的文件或文件夹。

创建新文件夹

用指定的名称在当前路径中创建一个新文件夹。

视图

控制“文件”列表的外观。

  • 列表。以多列格式显示“文件”列表的内容。
  • 详细信息。以单列格式显示“文件”列表的内容，同时显示文件详细信息。
工具

提供下列用于选择文件的工具：

  • 查找。显示“查找”对话框，用户可在其中使用名称、位置和修改日期过滤器来搜索文件。
  • 定位。在参照管理器中不可用。
  • 将当前文件夹添加到“位置”列表中。将选定文件夹的图标添加到“位置”列表中，从而可以从所有标准文件选择对话框中快速访问该文件夹。要删除图标，请在该图标上单击右键并单击“删除”。
  • 添加到收藏夹。创建当前“搜索”位置或选定的文件或文件夹的快捷方式。快捷方式将被放置在当前用户配置的“收藏夹”文件夹中，用户可以通过单击“位置”列表中的“收藏夹”对其进行访问。
“文件”列表

显示位于当前路径并属于选定文件类型的文件和文件夹。使用对话框中的“查看”菜单可以在“列表”视图和“详细信息”视图之间切换。

文件名

显示在“文件”列表中选择的文件的名称。如果在“文件名”框中输入文件名，参照管理器将清除任何选择。可以使用通配符过滤“文件”列表中显示的文件。

文件类型

按文件类型过滤文件列表。

保存

以指定的文件名、文件类型及位置保存文件。


“选项”对话框

“输出报告”对话框
Autodesk 参照管理器 (AdRefMan)
“概要”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“选项”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
菜单:“视图” [image] “选项”

控制参照管理器的显示和操作。

显示选项

控制若干显示选项。

在树状图中显示完整路径

如果选中，将在树状图中显示路径名和文件名；如果清除，树状图中将只显示文件名。

显示工具栏按钮文字

如果选中，将显示工具栏按钮的标签文字和图标；如果清除，将只显示工具栏图标。

要显示的列

控制“参照”列表中每一列的显示次序和可见性。

向上移动箭头

当显示在“参照”列表中时，当前选定的列标题在此选择列表中向上移动，并向左移动一列。

向下移动箭头

当显示在“参照”列表中时，当前选中的列标题在此选择列表中向下移动，并向右移动一列。

日志文件

控制文本文件的操作，此文本文件记录了使用参照管理器所做的所有路径更改。

写入日志文件

控制是否激活日志文件。如果选中，将记录使用参照管理器所做的路径更改，并附加到日志文件中。如果从未使用日志文件或已丢失，将创建一个日志文件。

日志文件名

指定日志文件的文件名。必须输入文件扩展名 .txt默认情况下，此日志文件保存在“我的文档”文件夹中。

浏览

在“浏览文件夹”对话框中显示树状图，从中可以指定日志文件的路径。

设置

控制参照管理器操作的若干设置。

用于融入参照的配置

指定定位参照时使用的 AutoCAD 配置的名称。AutoCAD 配置在系统注册表中保存若干 AutoCAD 图形环境设置，包括搜索路径。

添加图形时添加外部参照

如果选中此选项，则在将图形添加到树状图中时，参照管理器会将该图形的所有嵌套外部参照添加到树状图中。如果清除此选项，则只将指定图形添加到树状图中，图形中所有嵌套的外部参照必须另行添加。

恢复默认的消息和警告框

显示包含“不再显示此消息”选项的所有对话框。各个对话框原来的设置均被忽略，显示所有带有警告选项的对话框。


“概要”对话框

“选项”对话框
Autodesk 参照管理器 (AdRefMan)
“详细信息”对话框
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“概要”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
工具栏:“工具栏”
菜单:“文件” [image] “应用更改”

报告已成功更新的图形和参照的数目。

详细信息

显示带有已应用的参照路径更改的“详细信息”对话框。还列出失败的参照路径编辑。


“详细信息”对话框

“概要”对话框
Autodesk 参照管理器 (AdRefMan)
词汇表
Autodesk 参照管理器 > Autodesk 参照管理器 (AdRefMan) >
“详细信息”对话框
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
菜单:“文件” [image] “应用更改”；单击“详细信息”
文件名

显示参照文件的名称和扩展名，例如“txt.shx”。

参照名

显示图形中的参照使用的名称。例如，Standard 是指定给“txt.shx” 的默认名称。

编辑状态

报告是否将已应用的更改成功保存到图形中。如果更改不成功，将显示原因。

旧路径

显示保存在参照文件宿主图形中的以前的路径名。

新路径

显示保存在参照文件宿主图形中的新路径名。

宿主图形

显示包含参照的图形文件的名称。

已更新图形格式

报告图形文件是否更新为当前的 AutoCAD 图形文件格式。

显示已应用的参照路径更改的列表和相关信息。


词汇表

“详细信息”对话框
词汇表
Autodesk 参照管理器 >
词汇表
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节内容

  • 词汇表


词汇表
词汇表
Autodesk 参照管理器 > 词汇表 >
词汇表
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
绝对路径

文件的完整指定路径名称，例如，“C:\Data\Projects\Floorplan.dwg”。请参见相对路径。

当前工作文件夹

在其中执行应用程序的文件夹。

找到路径

参照管理器查找参照文件的文件夹层次结构。请参见已保存路径。

宿主图形

包含对其他文件的参照的图形。

宿主版本

宿主图形的 AutoCAD 数据库版本。

参照文件

被 AutoCAD 图形文件参照的文件。

“参照”列表

参照管理器窗口的右窗格，其中列出了在参照管理器树状图中选定的图形中的参照。请参见树状图。

相对路径

部分指定的路径名称，需要根据当前工作文件夹来提供文件的完整路径信息，例如，“\Projects\Floorplan.dwg”。请参见绝对路径。

保存的参照路径

保存在图形文件中的文件参照的文件夹层次结构。保存的参照路径也称为已保存路径。请参见找到路径。

树状图

参照管理器窗口的左窗格，其中列出了选定的图形及其参照的文件。请参见“参照”列表。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！