AutoCAD 2010 Developer Help

欢迎使用 AutoCAD 2010 Developer Help

《AutoCAD Developer Help》提供了有关自定义和扩展 AutoCAD 的完整信息。请单击右侧的链接或使用“目录”选项卡浏览帮助主题。

概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX/VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX
网上资源


AutoCAD 2010

自定义手册

《自定义手册》向有经验的用户介绍如何自定义 AutoCAD。要浏览《自定义手册》，请使用“帮助”窗口左侧的“目录”选项卡。

  • 基本自定义
  • 自定义线型
  • 自定义填充图案
  • 自定义用户界面
  • DIESEL
  • 幻灯片和命令脚本
  • 编程接口简介
  • 形和形字体
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX/VBA 开发人员手册


AutoLISP 参考

《AutoLISP 参考》提供了有关 AutoLISP® 的全面参考，AutoLISP 是一种功能全面的解释性编程语言，可用于调用 AutoCAD 命令、系统变量和对话框。《AutoLISP 参考》包括以下主题：

  • AutoLISP 函数：运算符、A、B、C、D、E、F、G、H、I、J、K、L、M、N、O、P、Q、R、S、T、U、V、W、X、Y、Z。
  • 外部定义命令
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


AutoLISP Developer's Guide

《AutoLISP Developer's Guide》提供了有关使用 Visual LISP® 交互式开发环境开发以及测试 AutoLISP® 程序的信息。同时还描述了如何使用 Visual LISP 提供的扩展来创建 ActiveX® Automation。《AutoLISP Developer's Guide》中包括以下主题：

  • 简介
  • 使用 Visual LISP 环境
  • 使用 AutoLISP 语言
  • 使用可编程对话框
  • 附录
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


AutoLISP 教程

《AutoLISP 教程》提供了逐步说明如何使用 Visual LISP™ 开发 AutoLISP® 应用程序的课程。《AutoLISP 教程》包括以下主题：

  • 简介
  • 设计和开始编程
  • 使用 Visual LISP 调试工具
  • 绘制小路边界
  • 创建工程和添加界面
  • 绘制砖
  • 使用反应器
  • 程序集成
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


DXF 参考手册

《DXF 参考手册》提供了关于 DXF™ 文件格式的全面参考。《DXF 参考手册》包括以下主题：

  • DXF 格式
  • HEADER 段
  • CLASSES 段
  • TABLES 段
  • BLOCKS 段
  • ENTITIES 段
  • OBJECTS 段
  • THUMBNAILIMAGE 段
  • 图形交换文件格式
  • 高级 DXF 问题
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


ActiveX/VBA 开发人员手册

《ActiveX/VBA 开发人员手册》说明了如何使用 ActiveX 和 VBA 开发应用程序来自定义 AutoCAD。本手册还包括样例代码和逐步说明的操作步骤。《ActiveX/VBA 开发人员手册》包括以下主题：

  • 简介
  • VBA 快速入门
  • ActiveX Automation 基础知识
  • 控制 AutoCAD 环境
  • 创建和编辑 AutoCAD 图元
  • 标注和公差
  • 自定义工具栏和菜单
  • 使用事件
  • 在三维空间中工作
  • 定义布局并打印
  • 高级绘图与组织技术
  • 使用 VBA 开发应用程序
  • 与其他应用程序和 Windows API 交互
  • ActiveX/VBA 教程：设计花园小径
  • Visual LISP 与 ActiveX/VBA 的比较
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


ActiveX and VBA Reference

《ActiveX and VBA Reference》提供了关于 ActiveX 对象模型及其关联接口组件的参考。《ActiveX and VBA Reference》包含以下主题：

  • 对象模型
  • 事件
  • 方法
  • 特性
  • 对象
  • 代码样例
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


Sheet Set Objects Reference

《Sheet Set Objects Reference 》提供了有关图纸集管理器对象的参考。《Sheet Set Objects Reference 》包括以下主题：

  • 图纸集管理器对象概述
  • 对象
  • 方法
  • 特性
  • 枚举
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


Connectivity Automation Reference

《Connectivity Automation Reference》提供了关于 Connectivity Automation 对象模型及其关联接口组件的参考。《Connectivity Automation Reference》包括以下主题：

  • Connectivity Automation 对象
  • 对象模型
  • 对象
  • 方法
  • 特性
  • 事件
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


ObjectARX

ObjectARX®（即 AutoCAD® Runtime Extension 编程环境）包括可构造块的 C++ 库，这些构造块可用于开发 AutoCAD 应用程序、扩展 AutoCAD 类和协议，以及创建操作方式与 AutoCAD 内置命令相同的新命令。

如果此帮助项目在“目录”选项卡中显示为页面图标 ( [image])，则 ObjectARX 文档在“帮助”系统中将不可用。

AutoCAD ObjectARX 文档可以从 Autodesk 网站的开发人员中心专区下载。要将 ObjectARX 文档和 AutoCAD 文档整合，请将 ObjectARX 帮助文件复制到“AutoCAD \HELP\”文件夹中。
概述

帮助文件

自定义手册

AutoLISP 参考

AutoLISP Developer's Guide

AutoLISP 教程


设置“我的帮助”

如果要设置“我的帮助”，用户必须以 HTML 格式创建帮助主题，然后使用 Microsoft HTML Help Workshop 对其进行编译，以创建一个名为 myhelp.chm 的编译帮助文件。将此文件复制到“AutoCAD\Help”文件夹。

在“我的帮助”的主要主题中显示带超链接的主题标题的步骤

  • 在 CHM 文件中包含一个文件，该文件列出了这些主题标题。将此包含的文件命名为 myhelp_toc.html 。

在“目录”选项卡中显示主题标题的步骤

  • 在 CHM 文件中包含一个文件，在该文件中列出这些主题标题的 HHC（帮助目录）。

显示用户添加到帮助主题的所有索引条目的步骤

  • 在 CHM 文件中包含一个 HHK（帮助索引）文件。

即使未包含 myhelp_toc.html 文件、HHC 文件或 HHK 文件，CHM 文件中的内容也可以从“搜索”选项卡中找到。