网络管理和展开快速入门

展开准备
网络管理和展开快速入门
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

网络管理和展开需要进行仔细地规划和执行。本节提供了有关如何进行展开准备工作、设置许可服务器以及设置和分发程序的信息。

如果不熟悉网络管理和展开，则应首先熟悉以下主题，然后再尝试在网络中展开和管理程序。

本节内容

  • 展开准备
  • 设置网络工具和许可服务器
  • 分发程序
请将您关于此页内容的评论发送给我们


展开准备

网络管理和展开快速入门
网络管理和展开快速入门
系统需求
网络管理和展开快速入门 >
展开准备
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

进行展开前的准备工作时，应花时间查看以下要求和选项。

本节内容

  • 系统需求
  • 选择安装类型
  • 选择许可服务器模式


系统需求

展开准备
展开准备
选择安装类型
网络管理和展开快速入门 > 展开准备 >
系统需求
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节介绍对所创建的管理映像的位置、网络许可服务器和客户端工作站的系统需求。

在网络上开始安装程序之前，请确保服务器和客户端工作站满足展开所需的最低硬件和软件需求。

安装 AutoCAD 的过程中，程序会自动检测 Windows 操作系统是 32 位还是 64 位版本。将安装适当的 AutoCAD 版本。不能在 64 位版本的 Windows 上安装 32 位版本的 AutoCAD，反之亦然。

关于管理映像、许可服务器和客户端工作站系统需求的信息，请参见以下各表。

硬件和软件要求 - 管理映像位置

硬盘

2 GB 或更大（建议）

创建管理映像的位置必须是一个共享位置，这样用户才能访问该管理映像。

硬件和软件要求 - 网络许可服务器
操作系统 | Windows Vista® 32 位 SP1 Windows Vista 64 位 SP1 Windows® XP 32 位 SP3 Windows XP 64 位 SP2 Windows 2003 R2 Server Edition Windows 2000 Server Edition Linux 64-bit Red Hat Enterprise Linux 5.0 WS (U4) Apple® Mac® OS 32 位、Intel 10.4.9 及更高版本 | Network License Manager 仅支持以太网网络配置。
计算机/处理器 | Pentium® III 或更高 450 MHz（最低），Intel、Mac |
网络接口卡 | 与现有的以太网网络基础构造兼容 | Network License Manager 支持多块网络适配卡，但必须至少有一块是以太网卡。
通信协议 | TCP/IP | Network License Manager 使用 TCP 包类型。

32 位硬件和软件要求

操作系统

Windows® XP Home 和 Professional SP2 或更高版本

Microsoft® Windows Vista® SP1 或更高版本，包括：

  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Ultimate
  • Windows Vista Home Premium
有关 Windows Vista 版本的详细信息，请参见 http://www.microsoft.com/windowsvista/versions/
浏览器 | Internet Explorer® 7.0 或更高版本
CPU 类型

Windows XP - Intel® Pentium® 4 或 AMD Athlon™ Dual Core 处理器，1.6 GHz 或更高，采用 SSE2 技术

Windows Vista - Intel Pentium 4 或 AMD Athlon Dual Core 处理器，3.0 GHz 或更高，采用 SSE2 技术
内存

Windows XP - 2 GB RAM

Windows Vista - 2 GB RAM
显示分辨率 | 1024 x 768 真彩色
硬盘 | 安装 1 GB | 不能在 64 位 Windows 操作系统上安装 32 位 AutoCAD，反之亦然。
定点设备 | MS-Mouse 兼容
3D 建模其他要求
  • Intel Pentium 4 或 AMD Athlon 处理器，3.0 GHz 或更高；或者 Intel 或 AMD Dual Core 处理器，2.0 GHz 或更高
  • 2 GB RAM 或更大
  • 2 GB 可用硬盘空间（不包括安装）
  • 1280 x 1024 32 位彩色视频显示适配器（真彩色），具有 128 MB 或更大显存，且支持 Direct3D ®的工作站级图形卡

64 位硬件和软件要求

操作系统

Windows® XP Professional x64 Edition SP2 或更高版本

Microsoft® Windows Vista® SP1 或更高版本，包括：

  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Ultimate
  • Windows Vista Home Premium
有关 Windows Vista 版本的详细信息，请参见 http://www.microsoft.com/windowsvista/versions/
浏览器 | Internet Explorer 7.0 或更高版本
CPU 类型

AMD Athlon 64，采用 SSE2 技术

AMD Opteron™，采用 SSE 技术

Intel Xeon，具有 Intel EM64T 支持并采用 SSE2 技术

Intel Pentium 4，具有 Intel EM 64T 支持并采用 SSE2 技术
内存

Windows XP - 2 GB RAM

Windows Vista - 2 GB RAM
显示分辨率 | 1024 x 768 真彩色
硬盘 | 安装 1.5 GB | 不能在 32 位 Windows 操作系统上安装 64 位 AutoCAD，反之亦然。
定点设备 | MS-Mouse 兼容
3D 建模其他要求
  • Intel Pentium 4 或 AMD Athlon 处理器，3.0 GHz 或更高；或者 Intel 或 AMD Dual Core 处理器，2.0 GHz 或更高
  • 2 GB RAM 或更大
  • 2 GB 可用硬盘空间（不包括安装）
  • 1280 x 1024 32 位彩色视频显示适配器（真彩色），具有 128 MB 或更大显存，且支持 Direct3D ®的工作站级图形卡


选择安装类型

系统需求
展开准备
选择许可服务器模式
网络管理和展开快速入门 > 展开准备 >
选择安装类型
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

设置展开时，需要选择所要展开的安装类型。在 AutoCAD 展开向导中，指定下列某个安装类型：

网络许可安装

通过此安装类型，可以将程序安装到工作站上，包括程序用来与 Network License Manager 进行通信的文件和注册表项。也可以定义 Network License Manager 的配置，以便可以访问许可。运行基于网络安装的程序的工作站不需要单独激活。至少有一台许可服务器管理本程序的许可。

主要优点是可以在多于所购买的许可数量的系统上安装 AutoCAD（例如，购买了 25 个许可，但能在 40 个工作站上安装）。在任何情况下，AutoCAD 都可以在许可所允许的最大数量的系统上同时运行。这意味着拥有了真正的浮动许可。

多套单机安装（“单机”选项）

请为单机安装（使用单个序列号和产品密钥在多台计算机上进行安装）选择此安装类型。多套单机安装不使用 Network License Manager 管理产品许可；但用户仍可使用 AutoCAD 展开向导创建管理映像和展开。多套单机安装的注册和激活将更加自动化。使用多套单机序列号和产品密钥首次激活后，基于此展开的所有工作站都将自动激活（只要系统连接到 Internet）。

单机安装（“单机”选项）

请为单机安装（使用单个序列号和产品密钥在单台计算机上进行安装）选择此安装类型。如同多套单机安装一样，用户不能使用 Network License Manager 管理产品许可，但可以在每个工作站进行安装、注册和激活。

如果选择单击安装类型的一种，可以转至分发程序一节。


选择许可服务器模式

选择安装类型
展开准备
设置网络工具和许可服务器
网络管理和展开快速入门 > 展开准备 >
选择许可服务器模式
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果选择“网络许可”选项，则需确定使用哪种许可服务器模式来分发产品许可。

提示如果展开单机安装或多套单机安装类型，则不要使用许可服务器模式。继续执行 分发程序。

对于网络安装，请使用下列某个许可服务器模式：

  • 单一许可服务器模式。因为 Network License Manager 安装在单一服务器上，所以许可管理和活动仅限于在此服务器上进行。单一许可文件表示服务器上可用许可的总数。
  • 分布式许可服务器模式。许可分布在多台服务器上。每台服务器都要求具有唯一的许可文件。要创建分布式许可服务器，必须在分布式服务器池中的每台服务器上运行 Network License Manager。
  • 冗余许可服务器模式。使用三台服务器验证单一许可文件。一台服务器作为主服务器，另外两台服务器在主服务器无法工作时提供备份。使用此配置，只要有两台服务器正常工作，即可继续监视和分发许可。三台服务器上的许可文件是同一文件。每台服务器上都必须安装 Network License Manager。

每种许可服务器模式在《网络许可手册》中均有详细说明。强烈建议在展开程序之前阅读该手册。可以通过单击展开向导左下角“文档”链接的“阅读文档”选项找到《网络许可手册》，或在帮助系统中找到该手册。


设置网络工具和许可服务器

选择许可服务器模式
网络管理和展开快速入门
安装 Network License Manager
网络管理和展开快速入门 >
设置网络工具和许可服务器
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果计划让用户使用网络许可运行程序，则需使用 Network License Manager 和网络许可证激活实用程序。使用 Network License Manager 可以配置和管理许可服务器。网络许可证激活实用程序有助于用户在 Internet 上获取和注册许可。

本节内容

  • 安装 Network License Manager
  • 安装和使用网络许可证激活实用程序
  • 配置许可服务器


安装 Network License Manager

设置网络工具和许可服务器
设置网络工具和许可服务器
安装和使用网络许可证激活实用程序
网络管理和展开快速入门 > 设置网络工具和许可服务器 >
安装 Network License Manager
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Network License Manager 用于配置和管理许可服务器。

安装 Network License Manager 的步骤

  1. 在 AutoCAD 安装向导中，单击“安装工具和实用程序”。
  2. 在“选择要安装的产品”页面中，选择“Autodesk Network License Manager”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面中，查看产品选择和当前设置。如果不希望进行任何更改，请单击“安装”。如果要更改安装类型或安装路径，请单击“配置”。
  5. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新文件夹。单击“下一步”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，用户必须提供一个本地驱动器的路径。用户必须指定驱动器号；不支持通用命名约定 (UNC)。
  6. 在“配置完成”页面上，单击“配置完成”以返回到确认页面。
  7. 在“查看 - 配置 - 安装”页面上，单击“安装”。
  8. 显示“安装完成”页面时，单击“完成”。


安装和使用网络许可证激活实用程序

安装 Network License Manager
设置网络工具和许可服务器
配置许可服务器
网络管理和展开快速入门 > 设置网络工具和许可服务器 >
安装和使用网络许可证激活实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用网络许可证激活实用程序可以在 Internet 上获取许可，这样可以节省设置程序的网络许可版本所花费的时间和精力。此外，如果无法通过 Internet 获得许可，还可以通过电子邮件注册产品、获取自动支持，然后可以自动保存和移植许可文件。

安装网络许可证激活实用程序的步骤

  1. 在 AutoCAD 安装向导中，单击“安装工具和实用程序”。
  2. 在“选择要安装的产品”页面上，选择“网络许可证激活实用程序”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面中，查看产品选择和当前设置。如果不希望进行任何更改，请单击“安装”。如果要更改安装类型或安装路径，请单击“配置”。
  5. 在“选择安装类型”页面上，选择“典型”或“自定义”，然后接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新文件夹。单击“下一步”。
  6. 在“配置完成”页面上，单击“配置完成”以返回到确认页面。
  7. 在“查看 - 配置 - 安装”页面上，单击“安装”。
  8. 显示“安装完成”页面时，单击“完成”。

使用网络许可证激活实用程序的步骤

  1. 执行以下操作之一：
    • （Windows XP 或 Windows Vista）依次单击“开始”菜单 [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “[AutoCAD]”“网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，查看该实用程序的工作方式及其使用要求，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入产品序列号。
    注意如果是在修改现有许可文件或是获取现有产品的新许可，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
  4. 在“许可服务器模式”部分，单击一种许可服务器模式。有关每种许可服务器模式的详细信息，请单击“?”按钮。
  5. 在“服务器主机名”框中，输入服务器主机名以查找计划使用的每台服务器的名称。
  6. 在“主机 ID”框中，针对上一步骤中输入的服务器主机名，单击“查找”让实用程序自动查找相应的服务器主机 ID 或手动输入该主机 ID。
    注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
  7. 如果在步骤 4 中选择“分布式服务器”，还将显示“套数”框。在“套数”框中，输入每个许可服务器的套数，然后单击“下一步”。
  8. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  9. 如果显示“注册并激活 Autodesk 产品”页面，请执行以下所有操作，然后单击“下一步”。
    • 在“本产品将注册给”选项中，选择“公司”或“个人”。
    • 在“选择国家/地区”部分，选择您所居住的国家/地区。
    • 在“是否是升级版”部分，选择“是”或“否”。
  10. 如果显示“注册信息”页面，请输入注册信息，然后单击“下一步”。
  11. 如果显示“确认信息”页面，请检查注册信息，然后单击“下一步”。
  12. 如果显示“正在连接”页面，请单击“下一步”连接到 Internet 以获取网络许可。
  13. 在“已收到许可”页面的“保存 [计算机名] 的许可文件”对话框中，输入希望保存许可文件的位置，或单击“浏览”以浏览至相应的位置。
    注意建议将许可文件保存在安装 Network License Manager 的位置。
  14. 如果拥有其他 Autodesk 产品的现有许可文件，请选择下列选项之一：
    • 将新的许可信息插入到其中。新的许可信息将添加到现有许可文件中。
    • 覆盖现有的许可文件。现有许可文件的全部内容将替换为新的许可信息。仅当不再需要现有许可文件中的任何内容时，才能选择此选项。
  15. 单击“下一步”。
  16. 在“许可证激活成功”页面上，单击“打印”以保存许可信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。


配置许可服务器

安装和使用网络许可证激活实用程序
设置网络工具和许可服务器
分发程序
网络管理和展开快速入门 > 设置网络工具和许可服务器 >
配置许可服务器
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要管理运行网络许可证激活实用程序时收到的 AutoCAD 许可，需要配置许可服务器。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始”菜单 [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 Lmtools 程序中的“Service/License File ”选项卡上，确保“Configure Using Services”选项处于激活状态。
  3. 单击“Config Services”选项卡。
  4. 在“Service Name”列表中，选择要用来管理许可证的服务名。

    默认情况下，服务名为“FLEXnet Service 1”。如果 FLEXnet® 还用于管理计算机上除 Autodesk 外的其他软件，可更改服务名以避免混淆，例如，可将“FLEXnet Service 1”重命名为“Autodesk Server1”。

    注意如果有多个软件供应商使用 FLEXnet 进行许可管理，则“Service Name”列表将包含多个选项。确保仅列出一个 Autodesk 服务。
  5. 在“Path to Lmgrd.exe File”字段中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此守护程序安装在“C:\Program Files\Autodesk Network License Manager”文件夹。

  6. 在“Path to the license file”框中，输入指向许可文件的路径，或单击“Browse”以定位文件。

    这是通过网络许可证激活实用程序获得的许可文件的路径，或脱机获得的许可文件的放置位置。

  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。

    建议将它保存至“\Program Files\Autodesk Network License Manager”文件夹。日志文件必须具有“.log”文件扩展名。对于新的日志文件，用户必须手动输入“.log”扩展名。

  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。如果要将设置保存到服务，则在提示时单击“是”。
  11. 单击“Start/Stop/Reread”选项卡，然后执行下列操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”，使用对许可文件或选项文件所做的所有更改来刷新 Network License Manager。

    许可服务器开始运行，并准备响应客户端请求。

  12. 关闭 lmtools.exe。


分发程序

配置许可服务器
网络管理和展开快速入门
创建网络共享
网络管理和展开快速入门 >
分发程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

完全准备好创建展开后，即可通过使用展开向导并选择展开方式来设置和分发 AutoCAD。

本节内容

  • 创建网络共享
  • 将安装失败的几率降到最低
  • 分发 AutoCAD 产品


创建网络共享

分发程序
分发程序
将安装失败的几率降到最低
网络管理和展开快速入门 > 分发程序 >
创建网络共享
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

网络共享是向网络上的用户的计算机提供的安装文件夹。您可以将用户指向此位置，来安装程序。创建网络共享，以供 AutoCAD 展开向导在创建客户端展开过程中使用。

共享文件夹需要具有网络许可并使用多套单机安装的安装方法。位于网络共享文件夹内的所有子文件夹都将自动共享。

注意在创建展开图像时，用户必须对共享文件夹具有“完全控制”权限。要访问网络共享，读取权限是必需的，而且还需要对展开程序的工作站具有管理权限。

创建网络共享文件夹的步骤

  1. 在网络服务器的桌面上，创建名为 Deployments 的文件夹。
  2. 在“Deployments”文件夹上单击鼠标右键，然后单击“共享和安全”（或“共享”）。
  3. 在“<文件夹名称> 特性”对话框中的“共享”选项卡下，选择“共享该文件夹”。
  4. 如果需要，可以指定一个共享名称，例如 Deployments。
  5. 单击“权限”按钮。请确保在“权限”对话框中已激活“完全控制”。单击“确定”。

    在 Vista 中，在“Deployments”文件夹上单击鼠标右键，然后单击“共享”。在“特性”对话框中，选择“共享”，然后选择“高级共享”以共享该文件夹。单击“权限”按钮以确保激活“完全控制”。单击“确定”。

    创建展开映像时，这些步骤非常重要。

  6. 单击“确定”或“关闭”以关闭“特性”对话框。
  7. 在“Deployments”文件夹中，为计划安装的每个产品创建一个子文件夹。以相关产品名称命名每个文件夹。


将安装失败的几率降到最低

创建网络共享
分发程序
分发 AutoCAD 产品
网络管理和展开快速入门 > 分发程序 >
将安装失败的几率降到最低
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果创建展开时，某些应用程序（例如 Microsoft Outlook 或病毒检查程序）正在运行，则 AutoCAD 安装过程可能会停止。关闭所有正在运行的应用程序并暂时禁用病毒检查实用程序。


分发 AutoCAD 产品

将安装失败的几率降到最低
分发程序
设置展开
网络管理和展开快速入门 > 分发程序 >
分发 AutoCAD 产品
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以从多种分发 Autodesk 程序的方法中进行选择。默认方法是网络共享。

  • 网络共享。用户使用通过展开向导创建的快捷图标来启动程序。程序将安装在用户的本地计算机上，产品图标将显示在桌面上。
    注意用户必须具有访问网络共享的读取权限和对安装本程序的工作站的管理权限。
  • 编写脚本。请参见创建用于安装程序的脚本。
  • 组策略对象 (GPO)。请参见通过组策略分发展开。
  • Microsoft SystemCenter Configuration Manager (SCCM)。请参见使用 SCCM 展开 Autodesk 软件需要完成的任务。
  • 映像软件。请参见使用主映像将网络许可产品分发至多个系统。


设置展开

分发 AutoCAD 产品
网络展开前的准备工作
设置展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

展开过程提供了多个可用于创建和自定义展开的选项，因此，要一气呵成地完成这个过程，需要留出足够的时间。为成功完成展开过程，建议用户在开始展开之前，先查看以下核对表和信息。展开过程从展开向导开始。创建展开后，用户即可访问展开，从而将产品安装到计算机中。

本节内容

  • 网络展开前的准备工作
  • “配置”按钮
  • 配置选项
  • 选择语言
  • 创建默认展开
  • 创建配置展开或自定义展开
  • 最终查看和完成安装
  • 修改展开（可选）
  • 将用户指向管理映像
  • 卸载 Autodesk 产品


网络展开前的准备工作

设置展开
设置展开
“配置”按钮
设置展开 >
网络展开前的准备工作
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

此展开核对表提供了用户在开始展开之前应熟悉的信息类型的简要总结。完成这些任务后，即可开始创建展开。

展开核对表
 | 用户已查看系统需求。请务必确保网络、服务器和客户端工作站符合系统需求。
 | 了解已购买的许可的类型。如果计划进行网络许可展开，则用户还应该熟悉要使用的许可服务器模式的类型和许可服务器的名称。
 | 已安装并激活所有支持工具和实用程序。
 | 已找到产品序列号和产品密钥。序列号和产品密钥位于产品包装盒外部，或者位于用户收到的电子邮件中（如果已下载产品）。
 | 了解如何在注册过程中个性化程序。使用一致的注册数据十分重要。
 | 已为计划展开的每个程序指明展开要驻留的位置（例如共享文件夹）。
 | 已关闭所有其他程序并禁用防病毒软件。
 | 已确定管理映像中要包括的语言，以及展开软件包要使用的语言。
 | 已确定展开计划是否使用映像软件来将程序分发到客户端工作站。
 | 已指定是否要创建包含展开和安装数据的日志文件、是否运行静默模式以及是否参加客户参与计划。
 | 了解将执行的安装的类型 - 典型或自定义。
 | 已选取安装文件夹选项以及支持文件内容的位置。
 | 用户可能希望设置自定义文件的搜索路径，或者可能已在该版本软件中发生了更改的文件位置。
 | 已确定是否要将其他文件包括在展开中，例如图形文件、AutoLISP 程序或脚本文件。
 | 已查看可能适用于产品的 Service Pack。
 | 已配置对通讯中心的访问。使用实时更新通知，用户可以了解发布产品更新的时间，而通过配置通讯中心，用户则可以获取技术信息。
 | 已对客户参与计划和客户错误报告等功能中的访问和参与选项进行了设置。


“配置”按钮

网络展开前的准备工作
设置展开
配置选项
设置展开 >
“配置”按钮
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

展开过程中，用户可以创建使用默认设置的展开，也可以创建自定义展开。要进行自定义，首先要打开“查看 - 配置 - 创建展开”对话框。从下拉列表中选择相应的产品，然后单击“配置”按钮。

单击“配置”按钮后将显示以下选项。有关展开选项的详细信息，请参见配置选项。

  • 选择许可类型 -“单机许可”或“网络许可”
  • 选择安装类型 -“典型”或“自定义”
  • 为支持内容选择安装文件夹
  • 定义搜索路径和文件位置
  • 安装其他文件
  • 指定用户系统配置
  • 包括 Service Pack
  • 配置信息中心通讯中心
  • 配置对联机资源的访问

完成自定义选项选择后，单击“配置完成”按钮。将再次显示“查看 - 配置 - 创建展开”对话框，用户可以查看所做的选择。确认所做的选择后，单击“创建展开”。

注意要获取设置的副本，请选择“复制到剪贴板”按钮。

如果不希望在“查看 - 配置 - 创建展开”页面中对配置进行任何更改，请单击“创建展开”。然后单击“是”，以使用默认配置继续创建展开。


配置选项

“配置”按钮
设置展开
输入产品和用户信息
设置展开 >
配置选项
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

创建展开时，要在创建过程中进行多种选择，以创建各种客户端展开映像和展开类型。以下几节详细概述了用户所做的选择。

本节内容

  • 输入产品和用户信息
  • 指定日志文件的位置
  • 什么是静默模式？
  • 客户参与计划 (CIP)
  • 选择许可类型（可选）
  • 选择安装类型（可选）
  • 为支持内容选择安装文件夹
  • 定义搜索路径和文件位置（可选）
  • 安装其他文件（可选）
  • 指定用户系统配置（可选）
  • 包含 Service Pack（可选）
  • 配置信息中心通讯中心（可选）
  • 允许用户访问联机资源（可选）


输入产品和用户信息

配置选项
配置选项
指定日志文件的位置
设置展开 > 配置选项 >
输入产品和用户信息
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

“产品和用户信息”页面用于为用户所在的环境个性化程序。所输入的信息将与产品一起永久保留，并显示在所有工作站的“帮助”菜单中。由于以后将无法更改此信息（除非卸载该产品），因此输入信息时请仔细小心。

要运行产品，还必须输入产品序列号和产品密钥。产品序列号和产品密钥位于产品包装盒上，或位于电子履行信息中。序列号必须包含三位数前缀，后跟八位数字。产品密钥由五位数字组成。

客户可以在以后查看此产品信息，方法是在信息中心工具栏上单击“帮助”按钮（问号图标）旁边的下拉箭头。然后单击“关于”。


指定日志文件的位置

输入产品和用户信息
配置选项
什么是静默模式？
设置展开 > 配置选项 >
指定日志文件的位置
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

程序有两种类型的日志文件，可用于监视有关展开和安装的信息。

  • 网络日志。网络日志文件记录运行展开的所有工作站。在展开过程的“常规展开设置”页面中，选择是否创建网络日志文件。该日志列出了用户名、工作站名称和安装的状态。关于状态信息以及用户在安装过程中所遇问题（例如磁盘空间不足或缺少权限）的详细信息，请参见此文件。

    网络日志的名称与用户为展开所选的名称相同。通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径，可以指定创建日志文件的位置，例如 \\MyComputer\Autodesk\<Autodesk 产品>。用户应使用其实际的计算机名来代替 MyComputer。

    注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
  • 客户端日志。客户端日志包含每个工作站的详细安装信息。这些信息可能有助于诊断安装问题。客户端日志位于每个客户端工作站的 %Temp% 目录下。

指定日志文件位置的步骤

  1. 创建展开时，在“常规展开设置”页面上选中“创建网络日志”框旁边的复选框。输入要存放网络日志的文件夹的名称。
  2. 要创建客户端日志，请选择“创建客户端日志”选项。
  3. 单击“下一步”。


什么是静默模式？

指定日志文件的位置
配置选项
客户参与计划 (CIP)
设置展开 > 配置选项 >
什么是静默模式？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果用户在静默模式处于激活状态时开始展开，则安装将在无需任何用户专门输入的情况下进行。用户不能更改任何安装设置。不显示要求用户进行交互操作的对话框。


客户参与计划 (CIP)

什么是静默模式？
配置选项
选择许可类型（可选）
设置展开 > 配置选项 >
客户参与计划 (CIP)
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果选择请客户参加客户参与计划，则有关用户如何使用 AutoCAD 的具体信息将发送至 Autodesk。这些信息包括用户最常使用的功能、遇到的问题以及有助于产品未来发展方向的其他信息。

注意也可以通过 CAD 管理员控制实用程序启用或禁用客户参与计划。


选择许可类型（可选）

客户参与计划 (CIP)
配置选项
选择安装类型（可选）
设置展开 > 配置选项 >
选择许可类型（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

设置展开时，根据所购买的软件许可类型（单机许可或网络许可）来选择要展开的安装的类型。还可以选择要用于分发产品许可的网络许可服务器模式。

重要信息根据在配置页面上选择的选项类型（网络许可或单机许可），请注意，用户必须为展开任务中所有这些产品使用同一安装类型。如果选择了不支持购买的许可类型的产品，则将无法激活这些产品。

指定展开过程中要使用的许可类型

单机许可（单个序列号用于单台计算机）

对于单机许可，需要在每个工作站上安装、注册和激活程序。

网络许可

通过此安装类型，可以将程序安装到工作站上，包括程序用来与 Network License Manager 进行通信的文件和注册表项。也可以定义 Network License Manager 的配置，以便可以访问许可。运行基于网络安装的程序的工作站不需要单独激活。至少有一台许可服务器管理本程序的许可。

展开单机许可的步骤

  1. 创建展开时，在“选择许可类型”页面中选择“单机许可”。

  2. 单击“下一步”。

在展开过程中指定许可服务器模式

如果选择“网络许可”选项，则需要确定用于分发产品许可的许可服务器模式：单一许可服务器模式、分布式许可服务器模式或冗余许可服务器模式。有关许可服务器模式的详细信息，请参见选择许可服务器模式。

如果展开单机安装或多套单机安装类型，则不要使用许可服务器模式。

使用单一许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“单一许可服务器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

  3. 输入将运行 Network License Manager 的服务器的名称，或单击“浏览”按钮查找该服务器。单击“下一步”。

有关许可服务器模式和设置许可服务器的详细信息，请参见选择许可服务器模式或配置许可服务器。

使用分布式许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“分布式许可服务器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

  3. 输入将运行 Network License Manager 的一台服务器的名称，或单击“浏览”按钮查找该服务器。单击“添加”可以将服务器添加到服务器池。将所有服务器添加到“服务器池”列表中后，使用“上移”和“下移”按钮，按照用户希望工作站搜索到服务器的先后顺序排列服务器。至少必须输入两台服务器。单击“下一步”。

有关许可服务器模式和设置许可服务器的详细信息，请参见选择许可服务器模式或配置许可服务器。

使用冗余许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“冗余许可服务器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

  3. 在“第一台服务器名称”字段中，输入将运行 Network License Manager 的一台服务器的名称，或单击“浏览”按钮查找该服务器。输入其余两台要在冗余服务器池中使用的服务器的名称。单击“下一步”。

有关许可服务器模式和设置许可服务器的详细信息，请参见选择许可服务器模式或配置许可服务器。


选择安装类型（可选）

选择许可类型（可选）
配置选项
为支持内容选择安装文件夹
设置展开 > 配置选项 >
选择安装类型（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

作为完整展开过程的一部分，用户需要选择安装程序时所接受的安装类型、选择要包含的可选工具或功能，并指定产品在每个工作站上的安装位置。

在“产品安装路径”中选择在客户端工作站上安装程序文件的位置。为帮助用户确定产品安装的位置，将提供驱动器和磁盘空间的图表。

要展开典型安装，请选择可选工具并指定产品位置

  1. 在展开过程中，在“选择安装类型”页面上选择“典型”作为要使用的安装类型。
  2. 输入客户端工作站上安装程序的路径，例如 C:\Program Files\<Autodesk 产品>。

    可以通过“磁盘空间要求”图表查看可用的驱动器和磁盘空间。

  3. 单击“下一步”。

要展开自定义安装，请选择可选工具并指定产品位置

  1. 展开过程中，在“选择安装类型”页面上选择“自定义”选项作为要使用的安装类型。
  2. 从“选择要安装的功能”列表中选择要安装的功能。

    如果在对功能进行了更改之后确定要使用最初的选择，则请单击“选择安装类型”页面上的“恢复默认”按钮。

  3. 输入客户端工作站上安装程序的路径，例如 C:\Program Files\<Autodesk 产品>。

    可以通过“磁盘空间要求”图表查看可用的驱动器和磁盘空间。

  4. 单击“下一步”。


为支持内容选择安装文件夹

选择安装类型（可选）
配置选项
定义搜索路径和文件位置（可选）
设置展开 > 配置选项 >
为支持内容选择安装文件夹
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在“选择‘支持内容’的安装文件夹”页面上，通过指定一个文件夹（在早期版本中使用的默认用户配置文件夹除外）来选择安装支持内容的位置。作为网络管理员，这些选项使用户可以在安装或展开过程中更好地控制支持内容的放置位置。

支持文件包括五种主要类型：

  • 支持 - 包括默认字体、自定义（.cui 文件）、菜单源、填充图案和线型文件。
  • 绘图仪 - 包括打印样式（.ctb 文件）和打印配置文件（.pc3 和 .pmp 文件）。
  • 数据链接 - 包含数据链接文件。
  • 样板 - 图形和图纸集样板以及网上发布样板。
  • 渲染 - 纹理和凹凸贴图、光域灯光文件。

现在可以从四个可用选项中选择一个共享位置（本地位置或网络位置），可将所有支持内容安装在该位置。下面的插图和表概述了其他可用选项。

有四个支持内容文件夹选项：

选项 注解
本地用户配置文件夹
  • 纹理贴图安装到 %ALLUSERSPROFILE%
  • 所有其他内容安装到 %USERPROFILE%\Roaming AppData
  • %USERPROFILE%\Local AppData 中未存储任何内容
程序安装文件夹
  • 所有内容均安装到各个用户工作站上的 AutoCAD 安装文件夹中
  • 用户可能需要具有高级用户权限才能安装 AutoCAD
  • 用户可能需要具有高级用户权限，才能在支持内容已安装到 OS Program Files 文件夹的系统中运行 AutoCAD
单个共享文件夹
  • 允许为所有内容类型指定唯一的网络路径
  • 内容类型的子文件夹安装在此位置中
  • 将展开发布到各个工作站后，只能在创建展开后将内容复制到网络位置一次
自定义文件夹
  • 允许为不同的内容类型指定唯一的网络路径
  • 支持本地文件夹和 UNC 或映射的网络路径

选中“单个共享文件夹”或“自定义文件夹”选项后，可以使用“覆盖共享网络文件夹中的现有文件”复选框。如果选中该框，则将覆盖选中文件夹中的现有文件。系统将不提供任何其他警告。如果未选中该框，则将显示警告消息。


定义搜索路径和文件位置（可选）

为支持内容选择安装文件夹
配置选项
安装其他文件（可选）
设置展开 > 配置选项 >
定义搜索路径和文件位置（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在“定义搜索路径和文件位置”页面上，可以修改默认搜索路径和某些程序文件的位置。用户可能会因为以下原因而希望修改默认设置：

  • 如果用户所在的环境使用的文件（例如自定义文件或插件）不是随程序一同安装的默认文件，则可以立即指向该文件，这样就不必在每个工作站上添加该文件了。
  • 在这一版本的程序中，某些默认文件位置可能已经有所变化。如果已安装了程序的早期版本，并且要将这些文件移动到与早期版本相同的文件位置，则可以使用此页面。

使用搜索路径和文件位置的默认程序设置的步骤

  • 创建展开时，在“定义搜索路径和文件位置”页面上单击“下一步”。

修改搜索路径和文件位置的默认程序设置的步骤

  1. 创建展开时，在“定义搜索路径和文件位置”页面上的“定义搜索路径、文件名和文件位置”列表中，单击搜索路径或文件位置左侧的加号 (+) 以选择并展开该搜索路径或文件位置。

  2. 在列表中选择项目，并执行下列操作之一：
    • 要浏览文件位置，单击“浏览”。
    • 要向当前选中的搜索路径或文件位置添加新条目，单击“添加”。
    • 要从当前选中的搜索路径或文件位置删除条目，单击“删除”。
    • 要在列表中上下移动选择的内容，单击“上移”或“下移”。
    注意这些按钮是否可用取决于上一步骤中选定的项目。
  3. 完成指定搜索路径或文件位置后，单击“下一步”。


安装其他文件（可选）

定义搜索路径和文件位置（可选）
配置选项
指定用户系统配置（可选）
设置展开 > 配置选项 >
安装其他文件（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在“安装其他文件”页面上单击“浏览”，可以指定要包含在展开中的其他文件。默认情况下，运行展开时，这些文件安装在客户端工作站上的程序的安装目录中。如果需要，可以将文件安装到多个目录中。

可以执行下列操作：

  • 指定要包含在展开中的其他文件（例如，图形文件、AutoLISP® 程序或脚本文件）。
  • 安装所有格式的用户文件，并将它们置于客户端工作站上的任意目录中。
  • 在安装文件夹下添加子文件夹（例如，添加名为 LSP 的文件夹以存放自定义 AutoLISP 程序）。
  • 将文件添加到程序文件所在的位置（例如，添加工程样例图形）。
  • 向安装根目录添加文件。
注意建议将这些文件安装到程序目录结构中的某个位置。不能使用与安装的程序文件相同的文件名安装这些文件。例如，不能添加名为 acad.cui 的文件。

安装其他文件

  1. 创建展开时，在“安装其他文件”页面上设置安装文件的位置。

  2. 执行下列操作之一：
    • 单击“浏览”按钮打开“添加文件”对话框，从中可以选择要添加到安装目录的文件。
    • 单击“添加文件夹”在安装目录中创建新文件夹。
    • 单击“添加驱动器”将驱动器名称添加到文件位置结构。驱动器名称必须由有效的驱动器号和冒号组成，例如 C: 或 F:。不支持通用命名约定 (UNC) 路径。
    • 单击“删除”从安装目录中删除文件、文件夹或驱动器。
  3. 单击“下一步”。


指定用户系统配置（可选）

安装其他文件（可选）
配置选项
包含 Service Pack（可选）
设置展开 > 配置选项 >
指定用户系统配置（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在“指定用户系统配置”页面上，可以指定如果未安装 Microsoft Internet Explorer，是否可以继续执行基于此展开的安装、指定默认配置名称、选择在桌面上显示产品快捷方式图标或创建自定义桌面快捷方式。

指定用户系统配置设置的步骤

  1. 创建展开时，如果在安装 AutoCAD 之前不需要安装 Microsoft Internet Explorer，则请在“指定用户系统配置”页面上清除“Internet Explorer”选项的复选框，然后选择默认发布格式。

  2. 在“默认配置名称”框中，指定默认配置名称，该名称将作为运行该展开的所有用户的当前配置名称。
  3. 如果不希望在用户的桌面上显示产品快捷方式图标，请清除“创建 Autodesk 桌面快捷方式”复选框。
  4. 如果要创建自定义桌面快捷方式，请指定快捷方式名称和所有参数（例如调用配置、启动脚本的开关等）。

  5. 单击“下一步”。


包含 Service Pack（可选）

指定用户系统配置（可选）
配置选项
配置信息中心通讯中心（可选）
设置展开 > 配置选项 >
包含 Service Pack（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

用户可以选择将产品 Service Pack 包括在内。可以从 autodesk.com 选择以下载并应用 Service Pack，或选择使用本地存储的（本地硬盘驱动器或本地网络）Service Pack。在上述任意一种情况下，只有在完成主产品安装后，方可应用 Service Pack。

如果从 autodesk.com 中选择“安装 Service Pack”按钮，则 Service Pack 将自动下载，用户无需提取 MSP 文件。

如果选择包括本地驱动器或网络驱动器中的 Service Pack，则需要通过以下两个选项安排如何处理 Service Pack。还需要完成以下步骤。

注意如果主产品的展开过程被取消或失败，则 Service Pack 安装将自动取消。

  • 将 Service Pack 附加至展开。附加 Service Pack 时，Service Pack 将仅应用于当前展开。可以将多个 Service Pack 附加到同一个展开。Service Pack 文件将包括在展开中并在产品展开后应用。
  • 将 Service Pack 合并到管理映像 MSI 文件。合并 Service Pack 时，Service Pack 将合并到管理映像中。合并后，可能无法从管理映像中删除 Service Pack。一个管理映像中可以包含多个 Service Pack。

从 Service Pack 提取 Microsoft Installer 修补程序 (MSP) 文件的步骤

  1. 从 AutoCAD 支持站点下载 Service Pack。
  2. 有关修补程序的信息，请查看 Service Pack 自述文件。
  3. 打开 Windows 命令提示并输入修补程序文件名，后跟 /e 切换符号和目标文件名，例如：

    ProductSP1.exe /e ./ProductSP1.msp

    其中，<ProductSP1.exe> 是已下载的修补程序的名称，而 <ProductSP1.msp> 是已提取的文件的名称。在提取文件的名称前使用“./”，可以将提取的文件与原始可执行文件放置在同一文件夹中。“e”命令行开关可从可执行文件中提取 MSP 文件。

将 Service Pack 包含在展开中的步骤

要将 Service Pack 包含在展开中，必须从已下载的 Service Pack 可执行文件中提取 MSP 文件。

  1. 在“包含 Service Pack”页面中，单击“浏览”按钮。
  2. 在“打开”对话框中，找到要包含在展开中的 Service Pack。
  3. 选择 MSP 文件并单击“打开”。
  4. 指定是要将 Service Pack 附加至展开，还是要将 Service Pack 合并到管理映像中。
  5. 单击“下一步”。


配置信息中心通讯中心（可选）

包含 Service Pack（可选）
配置选项
允许用户访问联机资源（可选）
设置展开 > 配置选项 >
配置信息中心通讯中心（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

通讯中心可以通过信息中心访问。实时更新使用“通讯中心”将修补程序下载到产品中，从而对产品进行更新。除实时更新外，其他的信息频道和提要也可以通过通讯中心显示。

可对通讯中心进行以下设置：

  • 启用实时更新。建立 Web 连接后，用户可以使用实时更新检查更新。如果产品修补程序可用，程序的状态栏上将收到可用通知，可以直接从 Autodesk 服务器上下载修补程序，也可以在将修补程序复制到用户工作站之前对其进行修改。如果不希望用户收到更新或通告，可以关闭“实时更新”。
    注意也可以在 CAD 管理员控制实用程序中打开或关闭“实时更新”选项。
  • 启用信息频道。信息频道处于激活状态时，将告知用户多种信息（例如产品支持信息）。
  • 启用 CAD 管理员频道。控制 CAD 管理员频道在信息中心中的显示。除能够切换 CAD 管理员频道外，还可以定义 CAD 管理员提要位置并为 CAD 管理员频道设置显示名称。
  • 启用 RSS 提要。用户可以订阅任意数量的 RSS 提要。各个提要分别包含在独立的信息中心类别中。此外，还可以指定用户是否可以添加 RSS 提要。

配置通讯中心的步骤

  1. 创建展开时，在“配置信息中心通讯中心”页面上，进行以下实时更新设置：
    • 启用实时更新。用户可以从 Autodesk 服务器接收产品更新或支持通告。
    • 接收 Autodesk 实时更新。用户可以使用实时更新从 Autodesk 服务器接收产品更新和支持通告。
    • 从本地服务器接收实时更新。可以在本地服务器上维护修补程序列表。修补程序列表是 XML 文件，用于指定可以安装在用户计算机上的修补程序列表。

      如果选中此选项，“本地修补程序列表位置”框将可用。使用“浏览”按钮查找指向存放修补程序列表的服务器位置的路径。通过安装 Autodesk CAD Manager Tools 4.0，运行 CAD 管理员控制实用程序，然后在“CAD 管理员控制实用程序”窗口中单击“帮助”，可获取有关如何使用本地修补程序列表的详细信息。

      注意可以命名一个文件以用于修补程序信息。通过目前使用 .npl 扩展名命名文件，用户将创建占位符文件，而非创建文件本身。必须在“本地修补程序列表位置”框所指定的位置处创建一个名称与此处指定的名称相同的文本文件。
  2. 指定是否启用信息频道。
  3. 指定是否启用 CAD 管理员频道。处于激活状态时，可以进行下列设置：
    • 提要位置。定义 CAD 管理员频道 RSS 提要的位置。RSS 提要采用 XML 格式。
    • 显示名称。设置 CAD 管理员频道的显示名称。
  4. 指定是否启用 RSS 提要以及是否允许用户添加提要。
  5. 单击“下一步”。


允许用户访问联机资源（可选）

配置信息中心通讯中心（可选）
配置选项
选择语言
设置展开 > 配置选项 >
允许用户访问联机资源（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在“配置对联机资源的访问”页面中，可以指定用户是否能够访问联机资源，例如，接收 Autodesk 实时更新、启用信息频道或 CAD 管理员频道或订阅 RSS 提要。还可以允许访问设计中心以及指定客户错误报告和信息中心设置。

设计中心

使用 DesignCenter 中的“网上设计中心”选项卡可以访问预绘制的内容（例如块、符号库、制造商内容和联机目录）。可以在一般的设计应用程序中使用这些内容，以帮助用户创建图形。

注意默认情况下不选择联机设计中心。如果选择安装时不启用联机设计中心，则过后可以从 CAD 管理员控制实用程序启用。其他信息请参见是否可以以后修改“联机资源”设置？。

客户错误报告 (CER)

如果 Autodesk 产品意外关闭，用户可以直接向 Autodesk 发送错误报告，这将帮助 Autodesk 确定并解决错误。用户可以确定报告的错误已解决时，是否将从 Autodesk 接收通知。

注意也可以在 CAD 管理员控制实用程序中打开或关闭“客户错误报告”通知选项。

配置信息中心搜索设置

可以配置信息中心的“搜索结果”选项卡，以显示各种来源（例如产品帮助系统、CAD 管理员频道或 Internet）的内容。

可以指定从展开进行安装的用户是否可以自定义对其信息中心搜索位置的访问。

配置访问联机资源的步骤

  1. 创建展开时，在“配置对联机资源的访问”页面上，执行以下操作以配置联机设计中心：
    • 要启用联机设计中心，请选中“启用网上设计中心”旁边的复选框。
  2. 如果用户希望接收问题解决的通知，请执行下列操作：
    • 选中“允许用户接收解决通知”旁边的复选框，以便使用户可以了解问题的解决方法并下载 Autodesk 提供的合适的更新。默认情况下，此选项已启用。
      注意用户必须有管理权限才能安装 Autodesk 提供的更新。
    • 选中“包括计算机名称”旁边的复选框，以在错误报告中包括用户的计算机名称。计算机名称将包括在发送给用户的通知以及速博应用管理员可以查看的报告中。默认情况下，此选项已禁用。
  3. 指定用户是否可以选择自定义其信息中心搜索位置。默认情况下，此选项已启用。
  4. 单击“配置完成”。


选择语言

允许用户访问联机资源（可选）
设置展开
创建默认展开
设置展开 >
选择语言
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以为展开说明选择一种语言，并为同一展开过程中的产品安装选择另一种语言。

例如，如果除用户自己使用的语言外，还需要向用户提供另外一种或几种语言版本的 AutoCAD，则可以下载安装程序的语言包，该语言包使用户可以根据需要支持的语言展开产品。

注意仅可在创建展开的过程中而非修改过程中将语言包包括在管理映像中。

展开过程开始后，展开向导会自动确定操作系统语言。如果检测到支持的语言，则展开页面将以该语言显示。如果要更改该语言，可以从展开向导首页上的安装程序语言列表中选择其他语言。

也可以为单个产品选择语言，方法是单击“选择要安装的产品”页面上的“为单个产品选择语言”复选框，然后从下拉列表中选择一种语言。

注意某些产品在发布时可能未提供多种语言版本。以后可能会向速博应用客户提供其他语言包。有关其他语言包的可用性，请查看 http://autodesk.com/servicesandsupport。


创建默认展开

选择语言
设置展开
创建配置展开或自定义展开
设置展开 >
创建默认展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果不打算自定义展开，则可以创建默认展开。

以下步骤说明了如何使用展开向导快速设置默认展开。该过程详细介绍了单一服务器的网络展开，其类型为“典型”客户端安装并且无自定义设置。有关设置配置展开或自定义展开的信息，请参见创建配置展开或自定义展开。

创建默认展开的步骤

  1. 在 AutoCAD 的初始安装页面上，单击“创建展开”。
  2. 在“开始展开”页面上，需要指定以下信息：管理映像位置和展开名称，以及目标系统是 32 位还是 64 位。
    • 在管理映像区域中，输入现有共享网络位置的路径，或使用“浏览”按钮浏览至该位置。此区域是创建和存储管理映像的位置。用户将从此位置安装程序。
      注意如果不了解如何创建网络共享，请参见创建网络共享。
    • 在“展开名称”字段中，输入新展开的名称。此处输入的名称是快捷方式的名称，用户将通过访问该快捷方式来安装产品。
    • 在“此为:”下，选择 32 位或 64 位操作系统作为目标操作系统。此选择不是用于指定在其中创建展开的系统，而是用于指定目标系统。

    单击“下一步”。

  3. 在“选择要包括在展开中的产品”页面上，选择要包括的产品、要包括在管理映像中的语言以及展开的语言。完成选择后，单击“下一步”。
    注意默认情况下，安装 AutoCAD 时不安装 Autodesk Design Review 2010。如果需要查看 DWF 或 DWFx 文件，则建议安装 Design Review。有关 Design Review 的详细信息，请参见 Installing Design Review。
  4. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。必须接受此协议才能继续执行展开过程。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  5. 在“产品和用户信息”页面上，输入序列号、产品密钥和用户信息。查看“隐私保护政策”，然后单击“下一步”。
    注意此处输入的信息是永久性的，并将显示在计算机上的“帮助”菜单中。由于以后将无法更改此信息（除非卸载该产品），因此请确保仔细输入信息。
  6. 在“常规展开设置”页面中，选择是否希望展开创建网络日志和/或客户端日志、是否希望以静默模式运行客户端安装以及是否希望用户参加客户参与计划。
    • 选择创建网络日志文件时，还必须通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径指定创建日志文件的位置。网络日志文件可选。
      注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
    • 选择是否要创建客户端日志文件。
    • 如果要防止用户在安装时更改安装设置，请选择“静默”模式。
    • 如果选择参加客户参与计划，则 Autodesk 将发送有关产品的帮助信息。

    有关日志文件的详细信息，请参见指定日志文件的位置。

    单击“下一步”。

  7. 在“查看 - 配置 - 创建展开”页面上，单击“创建展开”，然后选择“是”，以继续使用默认配置创建展开。

    单击“创建展开”后，将使用“当前设置”字段中列出的展开选项，在共享文件夹中创建管理映像。如果希望获得展开设置概要，请单击“复制到剪贴板”按钮。

  8. 在“展开完成”页面上，单击“完成”。


创建配置展开或自定义展开

创建默认展开
设置展开
最终查看和完成安装
设置展开 >
创建配置展开或自定义展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果打算通过删除功能或限制对联机资源的访问来改变展开，则可以创建配置展开或自定义展开。

创建配置展开或自定义展开的步骤

  1. 在 AutoCAD 展开向导中，单击“创建展开”。
  2. 在“开始展开”页面上，指定以下信息：管理映像位置和展开名称，以及目标系统是 32 位还是 64 位。
    • 在管理映像区域，输入现有共享网络位置的路径，或使用“浏览”按钮浏览至该位置。此区域是创建和存储管理映像的位置。用户将从此位置安装程序。
      注意如果不了解如何创建网络共享，请参见创建网络共享。
    • 在“展开名称”字段中，输入新展开的名称。此处输入的名称是快捷方式的名称，用户将通过访问该快捷方式来安装产品。
    • 在“此为:”下，选择 32 位或 64 位操作系统作为目标操作系统。此选择不是用于指定在其中创建展开的系统，而是用于指定目标系统。

    单击“下一步”。

  3. 在“选择要包括在展开中的产品”页面上，选择要包括的产品、要包括在管理映像中的语言以及展开的语言。完成选择后，单击“下一步”。
    注意默认情况下，安装 AutoCAD 时不安装 Autodesk Design Review 2010。如果需要查看 DWF 或 DWFx 文件，则建议安装 Design Review。有关 Design Review 的详细信息，请参见 Installing Design Review。
  4. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  5. 在“产品和用户信息”页面，输入序列号、产品密钥和用户信息。查看“隐私保护政策”，然后单击“下一步”。
    注意此处输入的信息是永久性的，并将显示在计算机上的“帮助”菜单中。由于以后将无法更改此信息（除非卸载该产品），因此请确保仔细输入信息。
  6. 在“常规展开设置”页面中，选择是否希望展开创建网络日志和/或客户端日志、是否希望以静默模式运行客户端安装以及是否希望用户参加客户参与计划。
    • 选择创建网络日志文件时，还必须通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径指定创建日志文件的位置。网络日志文件可选。
      注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
    • 选择是否要创建客户端日志文件。
    • 如果要防止用户在安装时更改安装设置，请选择“静默”模式。
    • 如果选择参加客户参与计划，则 Autodesk 将发送有关产品的帮助信息。

    有关日志文件的详细信息，请参见指定日志文件的位置。

    单击“下一步”。

  7. 在“查看 - 配置 - 创建展开”页面上，单击“配置”按钮以对管理映像进行更改。
  8. 在“选择许可类型”页面上，选择“单机许可”或“网络许可”安装，然后单击“下一步”。
  9. 在“选择安装类型”页面上，可以选择进行以下配置更改：
    • 典型 - 安装最常用的应用程序功能。
    • 自定义 - 仅安装用户从“选择要安装的功能”列表中选择的应用程序功能
      CAD 标准 | 包含用于查看设计文件与标准的兼容性的工具。
      数据库 | 包含数据库访问工具。
      词典 | 包含多语言词典。
      图形加密 | 允许用户通过“安全选项”对话框使用密码保护图形。
      Express Tools | 包含 AutoCAD 支持工具和实用程序（Autodesk 不提供支持）。
      字体 | 包含 AutoCAD 字体和 TrueType 字体。
      Autodesk Impression 工具栏 | 可以使用 Impression 工具栏将任意视图快速输出到 Autodesk Impression 中，以获得高级线条效果。
      Autodesk Seek Autodesk Seek。
      注意Seek 将仅安装在英文版 AutoCAD 中。
      材质库 | 材质库包含 300 多种专业打造的材质，均可应用于模型。
      新功能专题研习 | 包含动画演示、练习和样例文件，以帮助用户了解新功能。
      许可证转移实用程序 使用户可以在计算机之间传输 Autodesk 产品许可。
      注意此实用程序将不安装在 AutoCAD 的已解锁版本中。
      移植自定义设置 | 将早期版本产品中的自定义设置和文件移植到此版本的产品中。
      初始设置 | 允许用户基于单位系统、行业和常用的基于任务的工具设置 AutoCAD 的初始配置（联机内容、工作空间）。
      参照管理器 | 使用户可以查看和编辑与图形关联的外部参照文件的路径。
      样例 | 包含各种功能的样例文件。
      教程 | 包含教程。
      VBA 支持 | 包含 Microsoft Visual Basic for Applications 支持文件。
    • 产品安装路径 - 指定要将 Autodesk 产品安装到的驱动器和位置。

    单击“下一步”继续配置过程。

  10. 在“为支持内容选择安装文件夹”页面上，选择支持内容要驻留的位置。有关支持文件位置和选项的详细信息，请参见为支持内容选择安装文件夹。单击“下一步”。
  11. 在“定义搜索路径和文件位置”页面上定义搜索路径、文件名和文件位置，然后单击“下一步”。
    警告请勿删除 DRV 路径并始终将其他路径添加为次路径。
  12. 要在展开中包括其他文件，请选择文件要安装到的位置，然后选择在“安装其他文件”页面上要包括的文件名。完成选择后，单击“下一步”。
  13. 在“指定用户系统配置”页面上，确定是否需要 Internet Explorer 浏览器，设置默认发布格式和默认配置名称，并确定是否需要桌面快捷方式。单击“下一步”。
  14. 在“包括 Service Pack”页面上，如果有适用于产品的 Service Pack，则可以选择包括它们。

    安装程序将自动检查 autodesk.com.cn/adsk/servlet/home?siteID=1170359&id=1810417 以获得可用更新。如果有可用更新，将显示一个链接。如果没有可用更新，将不显示链接。

  15. 在“配置信息中心通讯中心”页面上，通过启用 Autodesk 实时更新、信息频道、CAD 管理员频道以及 RSS 提要，可以允许用户访问最新信息和产品讨论。完成选择后，单击“下一步”。
  16. 在“配置对联机资源的访问”页面上，可以设置用户对联机工具（例如设计中心、客户错误报告和信息中心搜索）的访问权限。完成选择后，单击“下一步”。
  17. 在“配置完成”页面上，可以选择某个产品选项卡以配置另一个产品，或单击“配置完成”以查看所做的选择。
  18. 在“查看 - 配置 - 创建展开”页面上，单击“创建展开”。如果希望获得展开设置概要，请单击“复制到剪贴板”按钮。
  19. 在“展开完成”页面上，单击“完成”。


最终查看和完成安装

创建配置展开或自定义展开
设置展开
修改展开（可选）
设置展开 >
最终查看和完成安装
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要完成展开安装，请确认已选的设置。

  1. 在“查看 - 配置 - 创建展开”页面上，滚动当前设置的列表并验证安装选项。
  2. 如果需要更改任意选项，则请单击“配置”按钮。
  3. 如果需要一份安装信息，请单击“复制到剪贴板”按钮。
  4. 单击“创建展开”。
  5. 在“展开完成”页面上，单击“完成”。

Autodesk 产品展开已创建完毕，该展开中具有特定于用户组的精确选项。此时可以使用此展开来安装程序。


修改展开（可选）

最终查看和完成安装
设置展开
将用户指向管理映像
设置展开 >
修改展开（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

创建展开后，可能需要修改某些客户端工作站的展开。用户可以应用修补程序或选择基础管理映像以外的各种自定义文件。也可以进行修改，例如将安装目录从驱动器 C 改到驱动器 D。

修改展开的步骤

  1. 打开用户初始选择的放置产品展开的共享网络文件夹。
  2. 在“Tools”文件夹中，双击“创建和修改展开”快捷方式。

    此操作将重新打开展开向导。

  3. 单击各个展开页面并进行所需更改。
  4. 完成所有修改后，单击“创建展开”。


将用户指向管理映像

修改展开（可选）
设置展开
卸载 Autodesk 产品
设置展开 >
将用户指向管理映像
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

完成展开过程后，即可安装新创建或新修改的展开。需要将在管理映像中创建的快捷方式告知给用户。快捷方式名称与在创建默认展开中选择的名称相同。

将用户指向管理映像

  • 告知用户如何安装展开的最简单的方法就是向用户发送电子邮件，告诉他们如何使用快捷方式。说明中至少应包括展开的位置以及如何双击展开的快捷方式。


卸载 Autodesk 产品

将用户指向管理映像
设置展开
使用脚本展开程序
设置展开 >
卸载 Autodesk 产品
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

卸载 Autodesk 产品时，系统将删除所有组件。这意味着即使以前添加或删除了组件，或者已重新安装或修复了 Autodesk 产品，卸载程序也将从系统中删除所有 Autodesk 产品安装文件。

卸载 Autodesk 产品的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始”菜单 [image] “设置” [image] “控制面板” [image] “添加或删除程序”。
    • (Windows Vista) 依次单击“开始”菜单 [image] “控制面板” [image] “程序和功能” [image] “卸载或更改程序”。
  2. 在“添加或删除程序”或“卸载或更改程序”窗口中，选择“AutoCAD”，然后单击“更改/删除”或“卸载/更改”。
  3. 单击“卸载”。
  4. 在“卸载 <Autodesk 产品>”页面上，单击“下一步”以从系统中卸载 AutoCAD。
  5. 系统通知用户已成功卸载产品时，单击“完成”。
注意即使已将 AutoCAD 从系统中删除，软件许可仍将保留。如果将来重新安装 AutoCAD，用户无需注册和重新激活程序。


使用脚本展开程序

卸载 Autodesk 产品
创建用于安装程序的脚本
使用脚本展开程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

脚本用于执行一条命令或一组命令。脚本与批处理文件类似，但比批处理文件灵活。安装脚本对于在与网络相连接的计算机上进行单机版程序安装时最为有用。此外，在网络上安装 Service Pack、扩展程序和 Object Enabler 时，脚本也很有用。

为了使 AutoCAD 正常运行，必须在要安装本程序的计算机上安装下列软件并且满足下列必要条件：

  • Microsoft .NET 3.5 SP1（可从产品磁盘上获取）
  • Microsoft Internet Explorer 6.0 Service Pack 1 或更高版本（可以从 Microsoft 网站 www.microsoft.com 下载 Microsoft Internet Explorer）。
  • Microsoft Installer Package (MSI) 4.5
  • Microsoft Windows Media Format 9.5（64 位系统的必备软件）
  • Macromedia Flash Player 9.0 或更高版本（默认情况下不安装）
  • Autodesk Design Review 2010（默认情况下不安装）
  • 适用于 x86 操作系统的 VC++ 2008 SP1 和 VC++2005 SP1 运行时组件；适用于 64 位操作系统 x64 的 VC++2008 SP1 和 VC++2005 SP1 运行时组件（可从产品磁盘上获取）
  • Microsoft National Language Support Downlevel API（可从产品磁盘上获取）

本节内容

  • 创建用于安装程序的脚本
  • 安装脚本样例
  • 在脚本中使用开关和标志
  • 运行脚本


创建用于安装程序的脚本

使用脚本展开程序
使用脚本展开程序
安装脚本样例
使用脚本展开程序 >
创建用于安装程序的脚本
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用文本编辑器（例如记事本）创建脚本，然后以 ASCII 格式将其保存在扩展名为 .vbs 的文件中。脚本由一条或多条命令、指定选项的命令开关以及修改选项的标志组成。安装脚本还包含路径名。

安装脚本指向产品的 setup.exe 文件的位置。必须指向产品磁盘上的 setup.exe 文件。例如：

Autodesk 产品 CDROM1\setup.exe


安装脚本样例

创建用于安装程序的脚本
使用脚本展开程序
在脚本中使用开关和标志
使用脚本展开程序 >
安装脚本样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节中的样例脚本将在典型配置中安装程序。为了便于复制此样例脚本以及替换用户信息，所有变量项目使用相同的名称。日志文件名以所安装的产品为依据。可以在脚本中使用日志文件名，也可以将其更改为其他内容。

序列号前缀：123

序列号：12345678

姓氏：我的姓氏

名字：我的名字

组织：组织

本程序静默安装的样例脚本使用本节所示的语法。

适用于 AutoCAD 的脚本安装

' 适用于 AutoCAD 2010 的脚本安装 - 英文版
option explicit
'
' 创建变量
dim shell
dim productType
dim strADSKFirstName
dim strADSKLastName
dim strADSKOrganization
dim strADSKSNPrefix
dim strADSKSNNumber
dim strADSKProdKey
dim strLocale
dim strACADStandaloneNetworkType
dim strADSKLicenseServerType
dim strADSKLicenseType
dim strADSKServerName
dim strADSKServerPath
dim strADSKServerHostID
dim strADSKPath
dim strSourcePath
'
' 脚本安装
Set shell = CreateObject("WScript.Shell")
productType = "ACAD"
'
' 名称和组织信息
strADSKFirstName = "My First Name"
strADSKLastName = "My Last Name"
strADSKOrganization = "Organization"
'
' 序列号信息
strADSKSNPrefix = "123"
strADSKSNNumber = "12345678"
strADSKProdKey="ABCDE"
'本地信息，例如 en-US = US English、de-DE = Deutchland German、ja-JP = Japan Japanese
strLocale="" ' en-US, de-DE, ja-JP
'
' 安装源（例如，假设 D: 为安装介质）
strSourcePath = "D:\"
'
' 安装目标
strADSKPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%") + "\" + "AutoCAD 2010"
If strLocale <> "" Then strADSKPath = strADSKPath + " " + strLocale
strADSKPath = strADSKPath + "\"
'''''' 取消注释安装的相关版本 - 默认为单机
' 对于单机
RunStandaloneInstall()
'
' 对于单一许可服务器
' RunSingleLicenseServerInstall()
'
' 脚本结束
Wscript.quit()
'
Function RunStandaloneInstall
shell.run DefaultCommand(),2,1
end function
'
Function RunSingleLicenseServerInstall
' 使用正确信息更新许可服务器
 strACADStandaloneNetworkType = "3"
 strADSKLicenseServerType = "Single Server License"
 strADSKLicenseType = "Network License"
 strADSKServerPath = "myFlexNetServer"
' HOSTID 或 MAC 地址
 strADSKServerHOSTID = "000000000000"
'
' 合并两个值
 strADSKServerPath = strADSKServerPath & " " & strADSKServerHOSTID
 shell.run MakeCommand(),2,1
end function
'
Function DefaultCommand
 dim retString
' /qb 表示静默安装 ' /c [关键字] 是关键字的替代参数
' /w 等到安装完成之后再运行脚本
' /o 安装完成后重新启动
retString = """" & strSourcePath & "\setup.exe" & """" & " /t /qb "
If strLocale <> "" then
        retString = retString & "/Language " & strLocale
End if
retString = retString & " /c " & productType & ": "
retString = retString & "INSTALLDIR=" & """" & strADSKPath & """" & " "
retString = retString & "ACADSERIALPREFIX=" & strADSKSNPrefix & " "
retString = retString & "ACADSERIALNUMBER=" & strADSKSNNumber & " "
retString = retString & "ADLM_PRODKEY=" & strADSKProdKey & " "
retString = retString & "ACADFIRSTNAME=" & """" & strADSKFirstName & """" & " "
retString = retString & "ACADLASTNAME=" & """" & strADSKLastName & """" & " "
retString = retString & "ACADORGANIZATION=" & """" & strADSKOrganization & """" & " "
retString = retString & "InstallLevel=5 "
DefaultCommand = retString & " "
end function
'
Function MakeCommand
dim retString
retString = DefaultCommand() & " "
retString = retString & "ACADSTANDALONENETWORKTYPE=" & """" & strACADStandaloneNetworkType & """" & " "
retString = retString & "ACADLICENSESERVERTYPE=" & """" & strADSKLicenseServerType & """" & " "
retString = retString & "ACADLICENSETYPE=" & """" & strADSKLicenseType & """" & " "
retString = retString & "ACADSERVERPATH=" & """" & strADSKServerPath & """" & " "
MakeCommand = retString
end function


在脚本中使用开关和标志

安装脚本样例
使用脚本展开程序
运行脚本
使用脚本展开程序 >
在脚本中使用开关和标志
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

下表列出了与安装相关的所有开关和标志。

注意 必须将安装开关设置为 INSTALLDIR=，否则将不安装在 AutoCAD 之外运行的程序（例如许可证转移实用程序）。
安装脚本中的开关
开关 | 说明
INSTALLDIR= | 指定安装产品的位置。
ACADSERIALPREFIX= | 指定序列号中连字符前面的数字。
ACADSERIALNUMBER= | 指定序列号。
INSTALLLEVEL= | 指定安装类型：3=典型
ACADFIRSTNAME= | 指定用户的姓氏。
ACADLASTNAME= | 指定用户的名字。
ACADORGANIZATION= | 指定公司名称。
ADLM_PRODKEY= | 指定产品密钥（与序列号位于同一个标签上）。
用户界面标志
标志 | 说明
q | 指定安装在静默模式下进行。


运行脚本

在脚本中使用开关和标志
使用脚本展开程序
使用组策略安装展开
使用脚本展开程序 >
运行脚本
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

创建脚本后，可以将其移至服务器或者使用映射驱动器号或 UNC（通用命名约定）路径。如果将其置于服务器上供用户运行，则可以在服务器上创建共享，然后将用户添加至共享中，使其具有所需的权限。由于用户只需运行脚本，因此应提供对共享目录的只读访问权限。

然后在同一台服务器或另一台服务器上，为要安装的每个产品创建一个目录。为该目录选择一个固定位置，以便在脚本中指向 MSI 文件。将产品磁盘中的内容复制到该目录中。此外，还可以为 Service Pack、扩展程序和自定义工具创建目录。

可以使用以下任何一种方法运行安装脚本：

  • 在每个单独的工作站上手动运行脚本。要运行安装程序，请将脚本粘贴到“运行”对话框中，或者从 Windows 命令提示符下运行脚本。
  • 向每个要运行脚本的用户发送带有 UNC 路径的电子邮件。要运行该脚本，请按照说明操作。
  • 将脚本连同使用说明通过电子邮件发送给每个用户。
  • 对脚本进行设置，以便它在登录时运行。


使用组策略安装展开

运行脚本
简介
使用组策略安装展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用组策略，可以通过向计算机指定展开来公布本程序。

  • Microsoft .NET 3.5 SP1（可从产品磁盘上获取）
  • Microsoft Internet Explorer 6.0 Service Pack 1 或更高版本（可以从 Microsoft 网站 www.microsoft.com 下载 Microsoft Internet Explorer）。
  • Microsoft Installer Package (MSI) 4.5
  • Microsoft Windows Media Format 9.5（64 位系统的必备软件）
  • Macromedia Flash Player 9.0 或更高版本（默认情况下不安装）
  • Autodesk Design Review 2010（默认情况下不安装）
  • 适用于 x86 操作系统的 VC++ 2008 SP1 和 VC++2005 SP1 运行时组件；适用于 64 位操作系统 x64 的 VC++2008 SP1 和 VC++2005 SP1 运行时组件（可从产品磁盘上获取）
  • Microsoft National Language Support Downlevel API（可从产品磁盘上获取）

本节内容

  • 简介
  • 通过组策略分发展开
  • 将展开指定给计算机
  • 确认展开的安装


简介

使用组策略安装展开
使用组策略安装展开
使用组策略指定展开
使用组策略安装展开 >
简介
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

通过组策略对象，可以将此程序公布到任何满足产品的最低要求的计算机，即部分 Windows 2000、Windows 2003 和 Windows 2008 Server Active Directory 环境。

本节内容

  • 使用组策略指定展开
  • 使用组策略的优缺点


使用组策略指定展开

简介
简介
使用组策略的优缺点
使用组策略安装展开 > 简介 >
使用组策略指定展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

通过展开向导，将在展开过程中创建的展开指定给计算机。将展开指定给计算机后，将在下次重新启动计算机时安装程序。

计算机的任何用户均可以使用指定给该计算机的展开。通常，如果使用某台计算机的用户较多，则应将程序指定给该计算机。

注意Autodesk 产品被设计为安装在计算机上，以便登录到此计算机的任何用户都可以运行。如果尝试将本程序指定给特定用户（而不是计算机），则在另一个指定用户尝试安装或卸载程序副本时，可能会出现问题。


使用组策略的优缺点

使用组策略指定展开
简介
通过组策略分发展开
使用组策略安装展开 > 简介 >
使用组策略的优缺点
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

下表概述了使用组策略的优缺点。

组策略的优缺点

优点

缺点

  • 与展开向导的展开功能配合得很好。
  • 无法向 MSI 可执行文件传递命令行参数。解决方法是使用脚本。
  • 易于通过展开向导的展开功能添加自定义文件。
  • 展开到工作站。
  • 只能自定义在使用展开向导创建展开时设置的应用程序设置。
  • 易于实现。


通过组策略分发展开

使用组策略的优缺点
使用组策略安装展开
将展开指定给计算机
使用组策略安装展开 >
通过组策略分发展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

通过组策略分发本程序包括三个主要步骤。

  1. 创建应用程序分发共享点。使用展开向导创建应用程序分发共享点。按照创建默认展开或创建配置展开或自定义展开中列出的步骤创建展开。
  2. 将程序指定给计算机。
  3. 确认安装。确保已正确安装程序。


将展开指定给计算机

通过组策略分发展开
使用组策略安装展开
确认展开的安装
使用组策略安装展开 >
将展开指定给计算机
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

将程序指定给计算机后，该计算机的所有用户都可以使用它。要将本程序指定给计算机，必须从能够访问 Windows 2003 Server、Windows XP 或 Windows 2000 Active Directory 的服务器中执行下列步骤。

注意本文档假定用户已安装组策略管理控制台。

将展开指定给计算机的步骤

  1. 启动组策略管理控制台 (gpmc.msc)。
  2. 在要从中创建组策略对象的组织单位上单击鼠标右键。然后选择“在此处创建并链接 GPO”…，并命名组策略。
  3. 在“组策略对象编辑器”窗口的“计算机配置”下，单击 Software Settings 文件夹旁的加号 (+) 展开此文件夹。
  4. 在“软件设置”下的“软件安装”上单击鼠标右键，然后单击“特性”。
  5. 在“软件安装特性”对话框的“常规”选项卡中，单击“浏览”。
  6. 在“浏览文件夹”对话框中，定位在展开向导中创建的应用程序分发共享位置，然后选择 AdminImage 文件夹。然后单击“确定”。

    “软件安装特性”对话框将显示（以 UNC 格式）默认的软件包位置、服务器名称、选定的共享文件夹和“AdminImage”。例如：

    \\server123\Deployment\AdminImage\x86 \acad（对于 x64 展开，为 \\server123\Deployment\AdminImage\x64\acad）

  7. 执行以下操作之一：
    • 对于 Windows 2003 Active Directory：在“常规”选项卡的“新建软件包”下，单击“高级”以指定创建新软件包时要使用的方法。使用此方法还可以选择通过展开向导创建的转换文件。
    • 对于 Windows 2000 Active Directory：在“常规”选项卡的“新建软件包”下，单击“高级发布或指定”以指定创建新软件包时要使用的方法。使用此方法还可以选择通过展开向导创建的转换文件。
  8. 单击“确定”关闭“软件安装特性”对话框。
  9. 执行以下操作之一：
    • 对于 Windows 2003 Active Directory：在“组策略对象编辑器”对话框的“软件设置”下，在“软件安装”上单击鼠标右键，然后依次单击“新建” [image] “软件包”。
    • 对于 Windows 2000 Active Directory：在“组策略”对话框的“软件设置”下，在“软件安装”上单击鼠标右键，然后依次单击“新建” [image] “软件包”。
  10. 在“打开”对话框中，确保已选择 Windows Installer 软件包文件 (acad-<展开名>-for-GPO.msi)，然后单击“打开”。

    如果在应用程序分发共享点之外的某个位置创建了管理映像，请找到该管理映像的位置，然后单击 acad-<展开名>-for-GPO.msi。用 <展开名> 替换用作此 GPO 软件包基础的展开的名称。

  11. 在“<产品名> 特性”对话框中，单击“展开”选项卡。在“展开类型”下，确认是否选择了“指定”。
  12. 在“修改”选项卡中，单击“添加”。
  13. 在“打开”对话框中，单击通过展开向导创建的转换软件包文件 (acad-<deployment name.mst)，然后单击“打开”。

    如果在应用程序分发共享位置之外的某个位置创建了管理映像，请找到该管理映像的位置，然后选择转换软件包文件 (acad-<deployment name.mst)。

  14. 在“<产品名> 特性”对话框的“修改”选项卡上，选定的转换软件包将添加到“修改”列表中。重复添加转换软件包的过程，但是这一次，仅将 gpo.mst 转换添加到 <展开位置>\Tools 文件夹中。单击“确定”。
    注意必须选择创建组策略对象时通过展开向导创建的转换软件包文件。创建组策略对象后，将无法添加或删除转换软件包文件。如果未选择转换软件包文件，程序将无法安装在客户端计算机上。

    必须为位于 \\server123\Deployment\AdminImage\x86\acad\en-US\AcadLP.msi 的语言包重复此过程。对于 x64 展开，该路径将为 \\server123\Deployment\AdminImage\x64\acad\en-US\AcadLP.msi。

    例如，如果美式英语 32 位产品的展开存储在 \\server123\Deployment 位置处，且展开名为 MyDeployment，则用户将创建具有以下信息的 GPO 软件包：

    用于 AutoCAD 2010 的第一个 .msi

    \\server123\Deployment\AdminImage\x86\acad\acad-MyDeployment-for-GPO.msi，且将以下转换添加到修改选项卡中：

    \\server123\Deployment\AdminImage\x86\acad\acad-MyDeployment.mst

    \\server123\Deployment\Tools\gpo.mst

    用于语言包的第二个 .msi

    \\server123\Deployment\AdminImage\x86\acad\en-us\AcadLP.msi，且将以下转换添加到修改选项卡中：

    \\server123\Deployment\AdminImage\x86\acad\acad-MyDeployment.mst

    \\server123\Deployment\Tools\gpo.mst

  15. 执行以下操作之一：
    • 对于 Windows 2003 Active Directory：在“组策略对象编辑器”窗口的“计算机配置”下，单击“软件安装”。新创建的程序软件包将显示在右侧窗格中。
    • 对于 Windows 2000 Active Directory：在“组策略”窗口的“计算机配置”下，单击“软件安装”。新创建的程序软件包将显示在右侧窗格中。
  16. 执行以下操作之一：
    • 对于 Windows 2003 Active Directory：关闭“组策略对象编辑器”窗口以及其他任何打开的 Active Directory 窗口。
    • 对于 Windows 2000 Active Directory：关闭“组策略”窗口以及其他任何打开的 Active Directory 窗口。

程序将指定给为其创建了组策略对象的组织单位中的所有计算机。下次重新启动组织单位中的计算机时，将安装程序，并且该计算机的所有用户都可以使用它。参见确认展开的安装以验证是否正确创建了组策略。


确认展开的安装

将展开指定给计算机
使用组策略安装展开
确认是否已将程序指定给计算机
使用组策略安装展开 >
确认展开的安装
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

重新启动计算机时，操作系统通常在“Windows 登录”对话框出现之前或之后显示有关组策略的信息。这些信息包括：

  • Windows 启动
  • 应用计算机设置
  • 安装管理软件<应用程序>
  • 应用软件安装设置
  • 加载用户的个人设置
  • 应用用户的个人设置

用户从 Windows XP 或 Windows 2000 工作站登录到为其创建了组策略的组织单位或计算机。

注意如果出现问题，将在系统的“事件查看器”中的“应用程序”下记录一个条目。

本节内容

  • 确认是否已将程序指定给计算机


确认是否已将程序指定给计算机

确认展开的安装
确认展开的安装
使用 Microsoft System Center Configuration Manager 安装展开
使用组策略安装展开 > 确认展开的安装 >
确认是否已将程序指定给计算机
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要确认是否已将本程序正确指定给计算机，请重新启动为其创建了组策略的组织单位中的计算机。将在显示登录提示之前安装程序。登录后，双击桌面上的程序图标。将开始第二次安装。安装完成后，程序将启动。


使用 Microsoft System Center Configuration Manager 安装展开

确认是否已将程序指定给计算机
简介
使用 Microsoft System Center Configuration Manager 安装展开
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下信息介绍了有关如何使用 Microsoft® System Center Configuration Manager (SCCM) 展开 Autodesk 软件的详细信息。用户可以使用 SCCM 通过远程进程来管理向选定的目标系统的软件分发。

本节内容

  • 简介
  • 使用 SCCM 展开 Autodesk 软件需要完成的任务
  • 使用展开向导设置源目录
  • 创建 SCCM 软件安装软件包


简介

使用 Microsoft System Center Configuration Manager 安装展开
使用 Microsoft System Center Configuration Manager 安装展开
使用 SCCM 展开 Autodesk 软件需要完成的任务
使用 Microsoft System Center Configuration Manager 安装展开 >
简介
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要展开 Autodesk 软件，用户应该熟悉 SCCM/SMS 软件分发过程。有关此主题的详细信息，请参考 Microsoft SCCM 文档和支持资源。


使用 SCCM 展开 Autodesk 软件需要完成的任务

简介
使用 Microsoft System Center Configuration Manager 安装展开
使用展开向导设置源目录
使用 Microsoft System Center Configuration Manager 安装展开 >
使用 SCCM 展开 Autodesk 软件需要完成的任务
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要使用 SCCM 展开 Autodesk 软件，建议完成以下操作：

  • 指定或创建要接收软件包的目标系统集合
  • 使用展开向导创建源目录
  • 创建要展开到目标系统的 SCCM 软件包
  • 提供源文件的路径
  • 将 SCCM 软件包分发到分发位置
  • 创建公布以向用户告知软件包的可用情况


使用展开向导设置源目录

使用 SCCM 展开 Autodesk 软件需要完成的任务
使用 Microsoft System Center Configuration Manager 安装展开
创建 SCCM 软件安装软件包
使用 Microsoft System Center Configuration Manager 安装展开 >
使用展开向导设置源目录
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用 SCCM 展开 Autodesk 软件时，可以使用展开向导设置源目录。

展开向导会创建管理映像，SCCM 将使用该映像将 Autodesk 软件分发到目标系统。执行管理安装的位置将成为软件包源目录的位置。

要了解有关展开和设置 Autodesk 软件源目录的详细信息，请参见《网络管理员手册》中的以下主题：

  • 展开准备
  • 网络展开前的准备工作
  • 创建默认展开
  • 创建配置展开或自定义展开
  • 修改展开（可选）
注意建议用户在尝试配置 SCCM 以展开程序之前，先测试通过展开向导创建的展开，以确保管理映像和展开没有问题。

测试展开向导展开的步骤

  1. 以具有管理权限的用户身份登录 Windows XP Professional 或 Vista 工作站。
  2. 浏览至在其中创建了展开的源目录。
  3. 双击通过展开向导创建的展开快捷方式。

    将安装程序，或将错误信息写入 %temp% 中的日志文件。


创建 SCCM 软件安装软件包

使用展开向导设置源目录
使用 Microsoft System Center Configuration Manager 安装展开
使用映像软件分发产品
使用 Microsoft System Center Configuration Manager 安装展开 >
创建 SCCM 软件安装软件包
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用展开向导创建源目录后，可以创建 SCCM 软件安装软件包。SCCM 软件包包含 SCCM 用于分发软件和公布该软件包的文件和说明。展开向导将创建这些文件和说明，但必须对 SCCM 进行配置才能使用这些文件。

使用 SCCM 创建软件安装软件包的步骤

  1. 执行以下操作之一：
    • （Windows XP 或 Windows Vista）依次单击“开始”菜单 [image] “所有程序” [image] “Microsoft System Center” [image] “Configuration Manager 2007” [image] “ConfigMgr Console”。
  2. 在“Configuration Manager 控制台”窗口中，展开“软件分发”。
  3. 在“软件包”上单击鼠标右键 [image] “分发” [image] “软件”。
  4. 在分发软件向导中，单击“下一步”。
  5. 在“软件包”对话框中，选择“新建不包含定义文件的软件包和程序”。单击“下一步”。
  6. 在“软件包标识”对话框中，输入有关名称、版本、发行商和语言的信息以及任何所需的注释。单击“下一步”。
  7. 在“源文件”对话框中，选择 SCCM 检索文件的位置以及管理文件的方式。单击“下一步”。
    注意在此过程中，已选择“始终从源目录中获取文件”。
  8. 在“源目录”对话框中，指定存储源文件的目录。单击“下一步”。
  9. 在“分发位置”对话框中，选择分发位置。将会从此位置将软件包展开到目标系统。单击“下一步”。
  10. 在“程序标识”对话框中，输入程序名称。此名称是在“控制面板”的“添加/删除程序”中显示的名称。在命令行区域中，输入 AdminImage\setup.exe/W/Q/I AdminImage\<展开名>.ini/Lang en-US。在此示例中，我们的展开名为 AutoCAD 2010，因此用户将输入 AdminImage\setup.exe /W /Q /I AdminImage\AutoCAD 2010.ini /Lang en-US。单击“下一步”。
    注意上述样例假定要安装的语言包为美式英语，/W 是 SMS 和 SCCM 的标志，/Q 是静默安装，/I 指明这是展开安装。
  11. 在“程序特性”对话框的“程序可以运行”下拉列表中，选择要采用的程序安装方式。可选择：
    • 仅在用户登录时运行
    • 无论用户是否登录均运行
    • 仅在无用户登录时运行
  12. 在“运行后”下拉列表中，选择在展开程序后要执行的操作。可选择
    • 不进行任何操作
    • 程序重新启动计算机
    • ConfigMgr 重新启动计算机
    • ConfigMgr 注销用户
    注意安装 AutoCAD 之后需要重新启动系统。
    单击“下一步”。
  13. 在“公布程序”对话框中，选择“是”以公布此程序。单击“下一步”。
  14. 在“选择要公布的程序”对话框中，选择要公布的软件包。单击“下一步”。
  15. 在“选择程序” [image] “公布目标”对话框中，选择要公布到其中的集合，或者创建一个新集合。
  16. 在“选择程序” [image] “公布名称”对话框中，输入或更改公布的名称。添加任何注释以进一步说明公布。单击“下一步”。
  17. 在“选择程序” [image] “公布子集”对话框中，选择以下选项之一：
    • 将此程序公布到现有的集合
    • 创建一个新集合并将此程序公布到其中
  18. 单击“下一步”。
  19. 如果需要，请在“选择程序” [image] “公布进度”对话框中，将选项设置为在特定日期和时间公布程序，或设置一个截止日期。单击“下一步”。
  20. 在“选择程序” [image] “指定程序”对话框中，选择以下选项之一：
    • 如果安装过程是必需的，请选择“是，指定程序”。
    • 如果安装过程是可选的，请选择“否，不指定程序”。
    单击“下一步”。
  21. 在“概要”对话框中，验证公布信息。使用后退按钮可以进行任何更改。要结束，请单击“下一步”。


使用映像软件分发产品

创建 SCCM 软件安装软件包
使用主映像将多套单机产品分发至多个系统
使用映像软件分发产品
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

为使用映像软件（例如 Norton Ghost）的用户提供了下列信息，用于创建主映像以分发 Autodesk 产品。一旦创建，主映像将通过设备复制到其他的计算机上。

请谨慎使用映像软件，因为其使用可能导致以下情况：

  • 与产品许可冲突
  • 不完全安装和激活问题

本节内容

  • 使用主映像将多套单机产品分发至多个系统
  • 使用主映像将网络许可产品分发至多个系统
  • 恢复主映像
  • 清理主系统并恢复操作系统


使用主映像将多套单机产品分发至多个系统

使用映像软件分发产品
使用映像软件分发产品
使用主映像将网络许可产品分发至多个系统
使用映像软件分发产品 >
使用主映像将多套单机产品分发至多个系统
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以使用多套单机版产品的主映像来分发产品。

注意使用 Norton Ghost 时，必须使用 -ib 开关以在主映像中包含引导扇区。有关使引导扇区作为一部分包含在主映像中的详细信息，请参见用户的映像软件。

如果之前已经在主机计算机上运行了 Autodesk 产品，则请勿创建主映像。可能需要清理系统。

使用主映像将多套单机版产品分发到多台计算机的步骤

  1. 创建多套单机版产品的网络展开。有关详细信息，请参见创建配置展开或自定义展开。
  2. 将展开中的 AutoCAD 安装到主机计算机上。
  3. 在主机计算机上执行以下操作之一：
    • 创建主映像（包括引导扇区）。分发产品前，请在一台计算机（非主机计算机）上测试该产品。在另一台计算机上启动产品，然后注册并激活该产品。用户在其计算机上注册并激活产品的宽限期为 30 天。
    • 启动产品并根据需要自定义产品。创建主映像并将其分发给用户。如果用户的计算机已连接到 Internet，则产品将被自动激活。其计算机未连接到 Internet 的用户拥有 7 天宽限期来注册并激活产品。
  4. 将主映像应用到目标计算机。


使用主映像将网络许可产品分发至多个系统

使用主映像将多套单机产品分发至多个系统
使用映像软件分发产品
恢复主映像
使用映像软件分发产品 >
使用主映像将网络许可产品分发至多个系统
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以使用网络许可产品的主映像来分发产品。

使用主映像将网络许可产品分发至多台计算机的步骤

  1. 创建网络许可产品的网络展开。有关详细信息，请参见创建配置展开或自定义展开。
  2. 将展开中的 AutoCAD 安装到主机计算机上。
    注意为了使产品获取许可，许可服务器必须正在运行，并且每台计算机必须连接到网络。
  3. 安装了 AutoCAD 后，请使用映像软件创建系统硬盘驱动器的主映像。
  4. 将主映像应用到目标计算机。


恢复主映像

使用主映像将网络许可产品分发至多个系统
使用映像软件分发产品
清理主系统并恢复操作系统
使用映像软件分发产品 >
恢复主映像
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下步骤假定重新格式化工作站之前，已将每个工作站的 AdLM 文件夹（和 Product Licenses 文件夹，如果有）的副本保存至其他工作站或磁盘。

使用主映像恢复产品的步骤

  1. 退出应用程序。在完成此过程之前不要再次运行应用程序。
  2. 在 Windows 资源管理器中，将 AdLM 文件夹从下面显示的相应路径复制到某个位置（要恢复的磁盘除外）。

    C:\Documents and Settings\All Users\Application Data\FLEXnet

  3. 重新格式化工作站并恢复主映像。
    注意请勿对硬盘驱动器执行低级格式化。
  4. 将在步骤 2 中创建的 AdLM 文件夹复制到其所在的原工作站及在工作站上所在的位置。
注意恢复磁盘映像后，更改过的所有文件都将恢复其原始状态，以供再次使用。许可文件被保留，无需重新激活产品。


清理主系统并恢复操作系统

恢复主映像
使用映像软件分发产品
安装疑难解答
使用映像软件分发产品 >
清理主系统并恢复操作系统
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果已经在主机计算机上运行了 AutoCAD，则首先应正确清理该主机计算机。

清理主机计算机并恢复操作系统的步骤

  1. 清理硬盘驱动器（包括引导扇区）。

    例如，如果使用的是 Norton 的 GDISK 实用工具，请使用以下命令：

    gdisk 1/diskwipe

    其中 1 代表正在擦除的硬盘。

    注意如果使用的是 Norton Ghost 之外的实用程序，请确保该实用程序可以清理引导扇区；否则将无法激活 Autodesk 产品。
  2. 创建新的分区并使用恢复磁盘或产品磁盘来安装操作系统。


安装疑难解答

清理主系统并恢复操作系统
基本安装问题
安装疑难解答
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节提供了安装问题的解决方案，以及对安装产品时可能出现的常见问题的解答。还可以从 http://autodesk.com/servicesandsupport 上获取其他疑难解答信息和支持。

本节内容

  • 基本安装问题
  • 展开问题
  • 许可问题
  • 联网问题
  • 卸载和维护问题


基本安装问题

安装疑难解答
安装疑难解答
如何检查图形卡驱动程序以查看是否需要更新？
安装疑难解答 >
基本安装问题
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节概述了在执行产品的基本安装时可能出现的常见问题及其解决方案。

本节内容

  • 如何检查图形卡驱动程序以查看是否需要更新？
  • 文字编辑器的用途是什么？
  • 如果执行典型安装，将安装哪些功能？
  • 为什么应该安装材质库？
  • 产品手册在何处？


如何检查图形卡驱动程序以查看是否需要更新？

基本安装问题
基本安装问题
文字编辑器的用途是什么？
安装疑难解答 > 基本安装问题 >
如何检查图形卡驱动程序以查看是否需要更新？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

建议确认并更新图形卡驱动程序以优化程序。使用以下操作步骤确定当前的图形卡驱动程序。

确定图形卡驱动程序的步骤

  1. 启动 AutoCAD。
  2. 在命令行中，输入 3dconfig。
  3. 在“自适应降级和性能调节”对话框中，单击“查看调节日志”。
  4. 有关系统的图形卡驱动程序和驱动程序版本的信息，请查看“三维设备”部分。
提示许多较新的图形卡都提供选项卡形式的页面，可以从中了解有关您的特定图形卡的更精确信息。如果存在特定选项卡页面，请访问这些页面，而不用访问“适配器”选项卡。


文字编辑器的用途是什么？

如何检查图形卡驱动程序以查看是否需要更新？
基本安装问题
如果执行典型安装，将安装哪些功能？
安装疑难解答 > 基本安装问题 >
文字编辑器的用途是什么？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装过程中指定的文字编辑器，用于在运行产品时编辑文本文件（例如 PGP 和 CUS 词典文件）。


如果执行典型安装，将安装哪些功能？

文字编辑器的用途是什么？
基本安装问题
为什么应该安装材质库？
安装疑难解答 > 基本安装问题 >
如果执行典型安装，将安装哪些功能？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

典型安装包括以下功能：

CAD 标准 | 包含用于查看设计文件与标准的兼容性的工具。
数据库 | 包含数据库访问工具。
词典 | 包含多语言词典。
图形加密 | 允许用户通过“安全选项”对话框使用密码保护图形。
Express Tools | 包含 AutoCAD 支持工具和实用程序（Autodesk 不提供支持）。
字体 | 包含 AutoCAD 字体和 TrueType 字体。
Autodesk Impression 工具栏 | 可以使用 Impression 工具栏将任意视图快速输出到 Autodesk Impression 中，以获得高级线条效果。
Autodesk Seek | Autodesk Seek。 注意Seek 将仅安装在英文版 AutoCAD 中。
新功能专题研习 | 包含动画演示、练习和样例文件，以帮助用户了解新功能。
许可证转移实用程序 | 使用户可以在计算机之间传输 Autodesk 产品许可。 注意此实用程序将不安装在 AutoCAD 的已解锁版本中。
移植自定义设置 | 将早期版本产品中的自定义设置和文件移植到此版本的产品中。
初始设置 | 允许用户基于单位系统、行业和常用的基于任务的工具设置 AutoCAD 的初始配置（联机内容、工作空间）。
参照管理器 | 使用户可以查看和编辑与图形关联的外部参照文件的路径。
样例 | 包含各种功能的样例文件。
VBA 支持 | 包含 Microsoft Visual Basic for Applications 支持文件。


为什么应该安装材质库？

如果执行典型安装，将安装哪些功能？
基本安装问题
产品手册在何处？
安装疑难解答 > 基本安装问题 >
为什么应该安装材质库？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

材质库包含 300 多种专业打造的材质，可直接将其应用于模型中的对象。也可以作为要创建的自定义材质的基础。

有关材质的详细信息，请参见《AutoCAD User’s Guide》中的“ Materials and Textures”。


产品手册在何处？

为什么应该安装材质库？
基本安装问题
展开问题
安装疑难解答 > 基本安装问题 >
产品手册在何处？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 产品文档以两种格式提供：PDF 文件和 CHM 文件。

  • PDF 文件在安装过程中可用；单击初始安装页面上的“阅读文档”按钮，或选择位于每个安装页面上的“文档”链接。需要使用 Adobe® Reader® 来查看 PDF。要下载免费的 Reader，请访问 www.adobe.com。
  • CHM 文件在安装产品后可以查阅；请在产品的帮助系统中访问该文件。

有关最新信息，请参见产品磁盘上的产品自述文件。也可以从“安装完成”页面上或通过帮助系统获取自述文件。


展开问题

产品手册在何处？
安装疑难解答
执行展开时是否有可以参考的核对表？
安装疑难解答 >
展开问题
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节概述了有关软件展开的常见问题及其解决方案。

本节内容

  • 执行展开时是否有可以参考的核对表？
  • 应将展开放置在何处？
  • 默认搜索路径和文件位置设置是什么？
  • 更改支持文件位置会对我的搜索路径产生何种影响？
  • 除了定义搜索路径和文件位置之外，能否添加文件？
  • 在何处可以检查软件的 Service Pack 是否可用？
  • 如何提取 MSP 文件？
  • 是否可以以后修改“联机资源”设置？
  • 从何处可以了解信息中心？
  • 什么是信息频道？
  • 启用 CAD 管理员频道的优点是什么？
  • 什么是 RSS 提要？它们对安装有哪些好处？
  • 从何处可以了解信息中心搜索位置？
  • 如何设置或自定义搜索位置？


执行展开时是否有可以参考的核对表？

展开问题
展开问题
应将展开放置在何处？
安装疑难解答 > 展开问题 >
执行展开时是否有可以参考的核对表？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

《网络管理员手册》包含完整的一节，介绍准备工作和整个展开过程。请参见网络展开前的准备工作。


应将展开放置在何处？

执行展开时是否有可以参考的核对表？
展开问题
默认搜索路径和文件位置设置是什么？
安装疑难解答 > 展开问题 >
应将展开放置在何处？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

网络许可和多套单机安装方法都需要使用共享文件夹。共享文件夹（网络共享）应在运行安装向导之前创建，并用于存储产品展开。

建议在要存储展开的系统桌面上将网络共享文件夹命名为“Deployments”。然后可以向共享的“Deployments”文件夹中添加子文件夹，这些子文件夹将清楚地显示要展开的产品的名称。例如，位于共享文件夹内的所有子文件都将自动共享。

提示在创建展开图像时，用户必须对共享文件夹具有“完全控制”权限。用户必须具有访问网络共享的读取权限和对展开程序的工作站的管理权限。


默认搜索路径和文件位置设置是什么？

应将展开放置在何处？
展开问题
更改支持文件位置会对我的搜索路径产生何种影响？
安装疑难解答 > 展开问题 >
默认搜索路径和文件位置设置是什么？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在展开向导的“为支持内容选择安装文件夹”页面上，可以通过指定一个文件夹（用户配置文件夹除外）来选择支持内容的安装位置。支持文件包括驱动程序、菜单和可选的用户定义设置（例如词典和自定义文件）。

指定了支持内容的安装路径后，它将填充到“定义搜索路径和文件位置”页面上的相应搜索路径中。

支持文件搜索路径 | 指定文件夹，当程序在当前文件夹中找不到文字字体、自定义文件、插件、要插入的图形、线型以及填充图案时，在该文件夹中进行查找。
自定义文件 | 指定各类文件的名称和位置。 主自定义文件： 指定主自定义文件 (acad.cui) 的默认位置。 企业自定义文件： 指定企业自定义文件的位置。 自定义图标位置： 指定自定义文件中使用的自定义图标的位置。
词典和字体文件 | 指定一些可选的设置。 自定义词典文件： 指定要使用的自定义词典（如果有的话）。 替换字体文件： 如果找不到原始字体且未在字体映射文件中指定替换字体，则指定要使用的字体文件的位置。 字体映射文件： 指定用于定义如何转换无法找到的字体的文件位置。
打印机支持文件路径 | 指定打印机支持文件的搜索路径设置。 打印机配置搜索路径： 指定打印机配置文件（PC3 文件）的路径。 打印机说明文件搜索路径： 为带有 .pmp 文件扩展名的文件或打印机说明文件指定路径。 打印样式表搜索路径： 为带有 .stb 或 .ctb 扩展名的文件或打印样式表文件（已命名打印样式表和颜色相关打印样式表）指定路径。
自动保存文件 | 指定选择“打开和保存”选项卡中的“自动保存”选项时创建的文件的路径。
配色系统位置 | 指定在“选择颜色”对话框中指定颜色时使用的配色系统文件的路径。可以为每个指定的路径定义多个文件夹。该选项与用户配置一起保存。
数据源位置 | 指定数据库源文件的路径。对此设置所做的修改在关闭并重新启动程序之后生效。
样板设置 | 指定图形样板设置。 图形样板文件位置： 指定“启动”向导和“新建”对话框所用的图形样板文件的路径。 图纸集样板文件位置： 指定路径，以便查找“创建图纸集”向导所使用的图纸集样板文件。 快速新建的默认样板文件名： 指定 QNEW 命令所使用的图形样板文件。 用于图纸创建和存储页面设置替代的默认样板： 指定用于创建新图纸和存储页面设置替代的默认样板文件，这些页面设置替代可以应用到图纸集管理器中的发布操作。
工具选项板文件位置 | 指定工具选项板支持文件的路径。
日志文件位置 | 指定选择“打开和保存”选项卡中的“维护日志文件”选项时创建的日志文件的路径。
打印和发布日志文件位置 | 指定日志文件的路径，如果在 OPTION 命令的“打印和发布”选项卡中选择“自动保存打印和发布日志”选项，则会创建此日志。
临时图形文件位置 | 指定存储临时文件的位置。本程序首先创建临时文件，然后在退出程序后将其删除。如果用户打算从写保护文件夹运行程序（例如，正在使用网络或打开磁盘上的文件），请为临时文件指定备用位置。所指定的文件夹必须是可读写的。
临时外部参照文件位置 | 指定外部参照文件的位置。当选择“打开和保存”选项卡的“按需加载外部参照文件”列表中的“使用副本”时，外部参照的副本将放在这个位置。
纹理贴图搜索路径 | 指定从中搜索渲染纹理贴图的文件夹。
i-drop 相关文件位置 | 指定与 i-drop 内容相关联的数据文件的位置。如果未指定位置，将使用当前图形文件的位置。


更改支持文件位置会对我的搜索路径产生何种影响？

默认搜索路径和文件位置设置是什么？
展开问题
除了定义搜索路径和文件位置之外，能否添加文件？
安装疑难解答 > 展开问题 >
更改支持文件位置会对我的搜索路径产生何种影响？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

为支持内容指定了其他安装路径后，它将填充到“定义搜索路径和文件位置”页面上的相应搜索路径中。如果未指定路径，则第一个搜索路径将替换安装路径。下表概述了会受到重置支持文件安装路径影响的特定搜索路径。

安装路径 搜索搜索路径和文件位置

支持

  • 支持文件搜索路径
  • 自定义文件 > 主自定义文件
  • 自定义词典文件
  • 字体映射文件
  • 配色系统位置
  • 工具选项板文件位置
  • 动作录制器设置。动作录制文件位置
  • DGN 映射设置位置

绘图仪

  • 打印机支持文件路径

打印机配置搜索路径

打印机说明文件搜索路径

打印样式表搜索路径

数据链接

  • 数据源位置

样板

  • 样板设置

图形样板文件位置

图纸集样板文件位置

用于图纸创建和页面设置替代的默认样板

渲染

  • 纹理贴图搜索路径（三个路径全都应替换为具有正确子文件夹的安装路径值）


除了定义搜索路径和文件位置之外，能否添加文件？

更改支持文件位置会对我的搜索路径产生何种影响？
展开问题
在何处可以检查软件的 Service Pack 是否可用？
安装疑难解答 > 展开问题 >
除了定义搜索路径和文件位置之外，能否添加文件？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用“添加”按钮，可以设置存储文件的文件夹的路径。不能添加特定文件。


在何处可以检查软件的 Service Pack 是否可用？

除了定义搜索路径和文件位置之外，能否添加文件？
展开问题
如何提取 MSP 文件？
安装疑难解答 > 展开问题 >
在何处可以检查软件的 Service Pack 是否可用？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要了解产品是否有可用的修补程序或 Service Pack，请访问 AutoCAD 支持页面 http://autodesk.com/servicesandsupport。


如何提取 MSP 文件？

在何处可以检查软件的 Service Pack 是否可用？
展开问题
是否可以以后修改“联机资源”设置？
安装疑难解答 > 展开问题 >
如何提取 MSP 文件？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Microsoft 修补程序 (MSP) 文件通常包含在从 AutoCAD 支持网站下载的 Service Pack 可执行文件中。要从可执行文件中提取 MSP 文件，请使用 /e 开关从 Windows 命令提示下运行该修补程序。

请特别注意提取文件的位置。有关使用修补程序文件的详细信息，请查看该修补程序的自述文件。


是否可以以后修改“联机资源”设置？

如何提取 MSP 文件？
展开问题
从何处可以了解信息中心？
安装疑难解答 > 展开问题 >
是否可以以后修改“联机资源”设置？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

是。如果要在安装产品后更改联机资源的状态，可以从 CAD 管理员控制实用程序中进行更改。CAD 管理员控制实用程序的安装独立于 AutoCAD。

从安装向导中，选择“安装工具和实用程序”，然后选择“CAD 管理员控制实用程序”。安装完成后，可以从“开始”菜单启动该实用程序。执行以下操作之一：

  • （Windows XP 或 Windows Vista）依次单击“所有程序” [image] “Autodesk” [image] “CAD Manager Tools” [image] “CAD 管理员控制实用程序”。


从何处可以了解信息中心？

是否可以以后修改“联机资源”设置？
展开问题
什么是信息频道？
安装疑难解答 > 展开问题 >
从何处可以了解信息中心？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以使用信息中心输入问题以获取帮助、显示“通讯中心”面板以获取产品更新和通告或显示“收藏夹”面板以访问保存的主题。有关详细信息，请参见配置信息中心通讯中心（可选）。


什么是信息频道？

从何处可以了解信息中心？
展开问题
启用 CAD 管理员频道的优点是什么？
安装疑难解答 > 展开问题 >
什么是信息频道？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用信息中心的通讯中心组件，用户可以接收来自各个信息频道的通告。通过信息频道，可以接收以下信息：

  • 产品支持信息，包括维护修补程序通知。
  • 如果您是 Autodesk 速博应用成员，则可以接收速博应用中心通告、速博应用 Program 新闻，以及指向 e-Learning 课程的链接。
  • Autodesk 网站上发布新文章和提示时的通知。


启用 CAD 管理员频道的优点是什么？

什么是信息频道？
展开问题
什么是 RSS 提要？它们对安装有哪些好处？
安装疑难解答 > 展开问题 >
启用 CAD 管理员频道的优点是什么？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

通过 CAD 管理员频道，可以访问指定提要位置中基于 Internet 的内容和信息提要。


什么是 RSS 提要？它们对安装有哪些好处？

启用 CAD 管理员频道的优点是什么？
展开问题
从何处可以了解信息中心搜索位置？
安装疑难解答 > 展开问题 >
什么是 RSS 提要？它们对安装有哪些好处？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

RSS 提要是通过订阅某网站而启动的活动链接。订阅以后，其主要优点是可以向用户的系统提供持续更新的内容流（以文章摘要、论坛线索、博客海报等形式）。RSS 表示丰富站点摘要（或真正简易聚合）。


从何处可以了解信息中心搜索位置？

什么是 RSS 提要？它们对安装有哪些好处？
展开问题
如何设置或自定义搜索位置？
安装疑难解答 > 展开问题 >
从何处可以了解信息中心搜索位置？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

用户可以使用信息中心一次搜索多个资源（例如帮助和指定的文件），或选择搜索单个文件或位置。

有关详细信息，请参见配置信息中心通讯中心（可选）。


如何设置或自定义搜索位置？

从何处可以了解信息中心搜索位置？
展开问题
许可问题
安装疑难解答 > 展开问题 >
如何设置或自定义搜索位置？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以在“信息中心设置”对话框或 CAD 管理员控制实用程序中设置“信息中心搜索”和“通讯中心”设置。用户必须使用 CAD 管理员控制实用程序指定“CAD 管理员频道”设置。

有关可以配置的设置的详细信息，请参见配置信息中心通讯中心（可选）。


许可问题

如何设置或自定义搜索位置？
安装疑难解答
单机许可和网络许可有何区别?
安装疑难解答 >
许可问题
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节概述了有关软件许可和产品许可的常见问题及其解决方案。

本节内容

  • 单机许可和网络许可有何区别?
  • 使用软件的网络许可版的优点是什么？
  • Internet Explorer 的用途是什么？


单机许可和网络许可有何区别?

许可问题
许可问题
使用软件的网络许可版的优点是什么？
安装疑难解答 > 许可问题 >
单机许可和网络许可有何区别?
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

单机许可产品是在单个工作站上注册和激活。尽管软件可以安装在设备的多个系统中，但许可仅允许运行一个系统。如果要运行更多系统，需要购买更多的单机许可产品，或考虑转换为网络许可。

网络许可产品依靠 Network License Manager 追踪软件许可。软件可以在多个系统中安装和运行，最多可达到所购买的许可数量。Network License Manager 会“检出”许可，直到所有的许可均在使用。只有“检入”许可后，系统才能运行程序。如果需要运行更多系统，可以购买更多许可，并由 Network License Manager 来维护这些许可。


使用软件的网络许可版的优点是什么？

单机许可和网络许可有何区别?
许可问题
Internet Explorer 的用途是什么？
安装疑难解答 > 许可问题 >
使用软件的网络许可版的优点是什么？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

建议将网络许可产品用于大型绘图/设计设备、教室和实验室环境。主要优点是，用户可以在多于所购买许可数量的系统上安装产品（例如，购买了 25 个许可，但是安装在 40 个工作站中）。在任何情况下，都可以在许可所允许的最大数量的系统上同时运行。这意味着拥有了真正的浮动许可。如果需要在更多系统上运行软件，可以购买更多许可。

只需注册和激活一次，许可即可保留在用户的网络许可服务器中。


Internet Explorer 的用途是什么？

使用软件的网络许可版的优点是什么？
许可问题
联网问题
安装疑难解答 > 许可问题 >
Internet Explorer 的用途是什么？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装产品后，可以在给定天数内在试用模式下运行产品。无论何时启动程序，系统都将提示用户激活软件。如果选择激活软件，通过 Internet Explorer 可以加快该过程。输入注册数据并将其提交到 Autodesk 后，将返回一个激活码，并且在启动过程中将不再提示用户。


联网问题

Internet Explorer 的用途是什么？
安装疑难解答
安装工具和实用程序时，哪些选项适用于多套单机版安装？
安装疑难解答 >
联网问题
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节概述了有关执行网络安装或配置网络许可服务器的常见问题及其解决方案。

本节内容

  • 安装工具和实用程序时，哪些选项适用于多套单机版安装？
  • 安装工具和实用程序时，哪些选择适用于单机版安装？
  • 从何处查找服务器名称？
  • 指定用户工作站设置时，系统将提供用于指定配置的选项。什么是配置？
  • 是否可以创建自定义桌面快捷方式？
  • 如果选择附加或合并 Service Pack，会出现什么情况？
  • 什么是管理映像 (MSI) 文件？
  • 选择所有产品对管理映像会产生什么影响？过后我可以添加产品吗？


安装工具和实用程序时，哪些选项适用于多套单机版安装？

联网问题
联网问题
安装工具和实用程序时，哪些选择适用于单机版安装？
安装疑难解答 > 联网问题 >
安装工具和实用程序时，哪些选项适用于多套单机版安装？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

由于多套单机许可产品不依靠许可服务器管理或激活许可，因此唯一有用的工具是 Autodesk CAD Manager Tools。

如果要更改 CAD 管理员频道，需要使用 CAD 管理员工具。


安装工具和实用程序时，哪些选择适用于单机版安装？

安装工具和实用程序时，哪些选项适用于多套单机版安装？
联网问题
从何处查找服务器名称？
安装疑难解答 > 联网问题 >
安装工具和实用程序时，哪些选择适用于单机版安装？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk CAD Manager Tools 是适用于单机许可产品的唯一工具。使用 CAD 管理员工具可以修改 CAD 管理员频道。


从何处查找服务器名称？

安装工具和实用程序时，哪些选择适用于单机版安装？
联网问题
指定用户工作站设置时，系统将提供用于指定配置的选项。什么是配置？
安装疑难解答 > 联网问题 >
从何处查找服务器名称？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装网络许可产品时，必须指定运行 Network License Manager 的服务器名称。如果不知道服务器名称，可以通过打开 Network License Manager 所在的系统上的 Windows 命令提示快速查找。在提示下输入 ipconfig /all，请留意“Host Name”条目。


指定用户工作站设置时，系统将提供用于指定配置的选项。什么是配置？

从何处查找服务器名称？
联网问题
是否可以创建自定义桌面快捷方式？
安装疑难解答 > 联网问题 >
指定用户工作站设置时，系统将提供用于指定配置的选项。什么是配置？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

配置创建于“选项”对话框的“配置”选项卡中。配置可以包含所有的配置设置，但基于图形的系统变量除外。例如，配置可以包含支持路径、夹点设置和打印设置等。

如果展开过程中在“指定用户系统配置”页面上指定了配置，可以确保以同样方式配置所有使用该展开安装产品的工作站。


是否可以创建自定义桌面快捷方式？

指定用户工作站设置时，系统将提供用于指定配置的选项。什么是配置？
联网问题
如果选择附加或合并 Service Pack，会出现什么情况？
安装疑难解答 > 联网问题 >
是否可以创建自定义桌面快捷方式？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以选择创建自定义桌面快捷方式。在启动程序时，该快捷方式可以使用命令行开关指定多个选项。例如，可以将命令行开关设置为在启动程序期间运行脚本、基于样板或原型图形创建图形或指定应在启动时恢复的工作空间。

有关详细信息，请参见《AutoCAD User’s Guide》中的“ Customize Startup”。


如果选择附加或合并 Service Pack，会出现什么情况？

是否可以创建自定义桌面快捷方式？
联网问题
什么是管理映像 (MSI) 文件？
安装疑难解答 > 联网问题 >
如果选择附加或合并 Service Pack，会出现什么情况？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

附加 Service Pack 时，Service Pack 将仅应用于当前展开。可以将多个 Service Pack 附加到同一个展开。Service Pack 文件将包括在展开中并在产品展开后应用。

合并 Service Pack 时，Service Pack 将合并到管理映像中。合并后，可能无法从管理映像中删除 Service Pack。一个管理映像中可以包含多个 Service Pack。

创建展开时，可以选择从“包括 Service Pack”页面中附加或合并 Service Pack。


什么是管理映像 (MSI) 文件？

如果选择附加或合并 Service Pack，会出现什么情况？
联网问题
选择所有产品对管理映像会产生什么影响？过后我可以添加产品吗？
安装疑难解答 > 联网问题 >
什么是管理映像 (MSI) 文件？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

管理映像是在展开过程中创建的共享文件资源的集合，展开将使用该映像将程序安装到网络工作站。创建展开时，可以将 Service Pack（修补程序）应用到管理映像。.msi 文件是一种 Microsoft Installer 文件。


选择所有产品对管理映像会产生什么影响？过后我可以添加产品吗？

什么是管理映像 (MSI) 文件？
联网问题
卸载和维护问题
安装疑难解答 > 联网问题 >
选择所有产品对管理映像会产生什么影响？过后我可以添加产品吗？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果选择将所有产品包括在展开中，则管理映像将会变大。用户应仅在通过此映像创建多个展开，并且不希望使用安装磁盘时选择所有产品。如果有几乎不使用或从来不使用的产品，并且不希望创建其他展开，则应仅选择产品的子集。

用户仍可以在以后创建展开并包括其他产品，但是需要创建新的管理映像。用户需要具有安装磁盘才能执行此操作。


卸载和维护问题

选择所有产品对管理映像会产生什么影响？过后我可以添加产品吗？
安装疑难解答
添加或删除功能时，如何得知默认情况下安装什么功能？
安装疑难解答 >
卸载和维护问题
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节概述了有关添加和删除功能、重新安装或修复安装以及卸载产品的常见问题及其解决方案。

本节内容

  • 添加或删除功能时，如何得知默认情况下安装什么功能？
  • 添加或删除功能时能否更改安装文件夹？
  • 什么时候应该重新安装产品而不进行修复？
  • 重新安装软件时，是否需要原始磁盘？
  • 修复安装后，能否恢复设置？
  • 卸载软件时，哪些文件会留在系统中？


添加或删除功能时，如何得知默认情况下安装什么功能？

卸载和维护问题
卸载和维护问题
添加或删除功能时能否更改安装文件夹？
安装疑难解答 > 卸载和维护问题 >
添加或删除功能时，如何得知默认情况下安装什么功能？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要快速查看在典型默认安装过程中安装的功能，请单击“添加/删除功能”页面上的“恢复默认”按钮。

CAD 标准 | 包含用于查看设计文件与标准的兼容性的工具。
数据库 | 包含数据库访问工具。
词典 | 包含多语言词典。
图形加密 | 允许用户通过“安全选项”对话框使用密码保护图形。
Express Tools | 包含 AutoCAD 支持工具和实用程序（Autodesk 不提供支持）。
字体 | 包含 AutoCAD 字体和 TrueType 字体。
Autodesk Impression 工具栏 | 可以使用 Impression 工具栏将任意视图快速输出到 Autodesk Impression 中，以获得高级线条效果。
Autodesk Seek | Autodesk Seek。 注意Seek 将仅安装在英文版 AutoCAD 中。
新功能专题研习 | 包含动画演示、练习和样例文件，以帮助用户了解新功能。
许可证转移实用程序 | 使用户可以在计算机之间传输 Autodesk 产品许可。 注意此实用程序将不安装在 AutoCAD 的已解锁版本中。
移植自定义设置 | 将早期版本产品中的自定义设置和文件移植到此版本的产品中。
初始设置 | 允许用户基于单位系统、行业和常用的基于任务的工具设置 AutoCAD 的初始配置（联机内容、工作空间）。
参照管理器 | 使用户可以查看和编辑与图形关联的外部参照文件的路径。
样例 | 包含各种功能的样例文件。
VBA 支持 | 包含 Microsoft Visual Basic for Applications 支持文件。


添加或删除功能时能否更改安装文件夹？

添加或删除功能时，如何得知默认情况下安装什么功能？
卸载和维护问题
什么时候应该重新安装产品而不进行修复？
安装疑难解答 > 卸载和维护问题 >
添加或删除功能时能否更改安装文件夹？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装产品后，将无法从“安装/删除功能”页面更改安装路径。在添加功能时更改路径会导致程序损坏，所以不存在该选项。


什么时候应该重新安装产品而不进行修复？

添加或删除功能时能否更改安装文件夹？
卸载和维护问题
重新安装软件时，是否需要原始磁盘？
安装疑难解答 > 卸载和维护问题 >
什么时候应该重新安装产品而不进行修复？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果意外删除或更改了程序需要的文件，应该重新安装产品。缺少或更改的文件会对产品性能产生不利影响，并会导致在用户尝试执行命令或查找文件时出现错误消息。

如果试图修复安装失败，则接下来最好的选择是重新安装。


重新安装软件时，是否需要原始磁盘？

什么时候应该重新安装产品而不进行修复？
卸载和维护问题
修复安装后，能否恢复设置？
安装疑难解答 > 卸载和维护问题 >
重新安装软件时，是否需要原始磁盘？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

重新安装产品时，无需使用原始磁盘。安装数据缓存在本地的驱动器上，并可在重新安装时重复使用。


修复安装后，能否恢复设置？

重新安装软件时，是否需要原始磁盘？
卸载和维护问题
卸载软件时，哪些文件会留在系统中？
安装疑难解答 > 卸载和维护问题 >
修复安装后，能否恢复设置？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果必须修复程序安装，可以将自定义设置输出并在以后重新输入到同一系统中。

有关输出和输入自定义设置的详细信息，请参见 Migrate Custom Settings and Files from Previous Releases。


卸载软件时，哪些文件会留在系统中？

修复安装后，能否恢复设置？
卸载和维护问题
词汇表
安装疑难解答 > 卸载和维护问题 >
卸载软件时，哪些文件会留在系统中？
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果卸载产品，某些文件将保留在系统中，例如用户创建或编辑过的文件（例如图形或自定义菜单）。

卸载产品时，许可文件也将保留在工作站上。如果在同一工作站上重新安装产品，许可信息将仍然有效，因此无需重新激活产品。


词汇表

卸载软件时，哪些文件会留在系统中？
词汇表
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
Active Directory

Microsoft 的目录服务是 Windows 2000 和 Windows 2003 Server 的一部分，用于管理组成网络环境的标识和关系。

Autodesk 产品启动加速器 (acstart17.exe)

一种运行时进程，可以加快 AutoCAD 的初始启动速度。

FLEXnet

Acresso Software, Inc. 提供了许可管理技术。FLEXnet 提供了有助于简化网络许可管理的管理工具。FLEXnet 可用于监视网络许可状态、重置因系统故障而丢失的许可、对许可服务器进行故障排除以及更新现有许可文件。

MSI

Microsoft Installer，支持各种可用于脚本编写的参数。

MSP

Microsoft 修补程序文件（参见修补程序）

MST

Microsoft 转换文件。修改通过 MSI 文件安装的组件。例如，展开向导使用指定的设置创建 MST 文件。通过展开向导创建的展开结合使用 MST 文件和 MSI 文件以及 MSIEXEC 在本地工作站上安装。

SCCM

Microsoft System Center Configuration Manager。一种工具，通过进行远程配置、推入展开和用户管理帮助用户管理联网计算机。SCCM 是一种成本很高的技术，必须作为附加服务器购买。

Service Pack

Autodesk 术语，表示应用程序的修补程序。

修补程序

应用程序的软件更新。

公布

一种拉技术，用于通知用户已有更新的软件产品可供安装。通常情况下，用户双击快捷方式（或执行类似的操作）即可完成已公布产品的安装。

多套单机安装

一种安装类型，使用一个序列号在多个单独的计算机上安装程序。

安装映像

一种展开，由 MSI 文件、关联的转换、用户指定的附加自定义文件以及配置和注册表设置组成。

局部配置

一种包含部分注册信息的配置，这些信息与“选项”对话框“文件”选项卡中可用选项的子集相对应。

展开

将 Autodesk 产品安装到网络中的一台或多台计算机上的过程。

展开

指向用作安装基础的唯一的 MST（Microsoft 转换）文件的链接。使用展开向导，管理员可以为用户创建多个用于不同安装类型的展开。

拉技术

一种安装技术，需要用户进行交互才能完成安装。

推技术

一种安装技术，可将文件安装到远程桌面而无需用户进行交互。

激活

Autodesk 软件注册过程的一部分，允许用户按产品的最终用户许可协议运行产品。

目录服务

一种网络服务，用于标识网络上的所有资源，并使资源可供用户和应用程序使用。资源包括电子邮件地址、计算机和外围设备（例如打印机）。理想情况下，目录服务应使物理网络拓扑结构和协议透明，使网络用户不必了解网络的实际连接方式和位置即可访问所有资源。几乎所有目录服务都基于 X.500 ITU 标准。

管理映像

通过展开向导创建的共享文件资源集合，展开使用它将程序安装到网络工作站。

组策略

Microsoft 服务器技术，用于通过标准 Microsoft 2000 Server 管理组件，执行推安装和基于公布的安装。

编写脚本

使用脚本语言（例如 VB Script）简化软件包展开的过程。

网络许可安装

一种安装类型，在此安装过程中，可以将程序（包括程序用来与 Network License Manager 进行通信的文件和注册表项）安装到工作站。

许可证转移实用程序

使用户可以在多台计算机上使用 Autodesk 产品，而不必为每台计算机购买单独的许可。

语言包

提供了核心产品的安装以及语言选择。语言包由程序的本地化内容以及安装程序文件组成。

超级用户

对注册表的“Program Files”文件夹和“HKEY_Local_Machine”文件夹具有访问权限和写入权限的用户。

转换

参见 MST。

静默模式

一种无需用户专门输入即可进行的安装方式。不显示要求用户进行交互操作的对话框。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！