Autodesk 网络许可快速入门

如何安装 Network License Manager
Autodesk 网络许可快速入门
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

设置 Autodesk® 产品的网络许可需要进行仔细地规划和执行。本节提供了逐步介绍有关如何设置网络许可环境的快速指导，并假定用户熟悉设置在网络上运行的 Autodesk 产品所需的术语和过程。如果对网络许可没有什么了解，则在尝试设置网络许可服务器之前，请通读《网络许可指南》，以获取详细信息。

本节内容

  • 如何安装 Network License Manager
  • 如何安装和使用网络许可证激活实用程序
  • 如何配置许可服务器 (Windows)
  • 如何安装和使用 SAMreport-Lite（可选）
请将您关于此页内容的评论发送给我们


如何安装 Network License Manager

Autodesk 网络许可快速入门
Autodesk 网络许可快速入门
如何安装和使用网络许可证激活实用程序
Autodesk 网络许可快速入门 >
如何安装 Network License Manager
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Network License Manager 用于配置和管理许可服务器。

安装 Network License Manager 的步骤

  1. 在 Autodesk 安装向导中，单击“安装工具和实用程序”。
  2. 在“选择要安装的产品”页面中，选择“Autodesk Network License Manager”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面中，查看产品选择和当前设置。如果不打算更改任何内容，请单击“安装”。如果要更改安装类型或安装路径，请单击“配置”。
  5. 在“选择安装类型”页面中，选择“典型”或“自定义”，然后接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新文件夹。单击“下一步”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，用户必须提供一个本地驱动器的路径。用户必须指定驱动器号；不允许使用通用命名约定 (UNC)。
  6. 在“配置完成”页面上，单击“配置完成”以返回到确认页面。
  7. 在“查看 - 配置 - 安装”页面上，单击“安装”。
  8. 显示“安装完成”页面时，单击“完成”。


如何安装和使用网络许可证激活实用程序

如何安装 Network License Manager
Autodesk 网络许可快速入门
如何配置许可服务器 (Windows)
Autodesk 网络许可快速入门 >
如何安装和使用网络许可证激活实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用网络许可证激活实用程序可以在 Internet 上获取许可，这样可以节省设置网络许可版本程序所用的时间和精力。此外，如果无法通过 Internet 获得许可，还可以通过电子邮件注册产品、获取自动支持，然后可以自动保存和移植许可文件。

安装网络许可证激活实用程序的步骤

  1. 在 Autodesk 安装向导中，单击“安装工具和实用程序”。
    注意每个网络许可证激活实用程序的安装都是特定于产品的。如果用户具有多个 Autodesk 产品，且希望在所有的产品上均安装网络许可证激活实用程序，则必须对每个产品执行一次安装。
  2. 在“选择要安装的产品”页面上，请选择“Autodesk 网络许可证激活实用程序”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面中，查看产品选择和当前设置。如果不打算更改任何内容，请单击“安装”。

    如果要更改安装类型或安装路径，请单击“配置”。

  5. 在“选择安装类型”页面上，选择“典型”或“自定义”，然后接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility) 或单击“浏览”以指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新文件夹。单击“下一步”。
  6. 在“配置完成”页面上，单击“配置完成”以返回到确认页面。
  7. 在“查看 - 配置 - 安装”页面上，单击“安装”。
  8. 显示“安装完成”页面时，单击“完成”。

使用网络许可证激活实用程序（联机请求）的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
    • (Windows Vista) 依次单击“开始” [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，确保“直接连接(通过 Internet)”处于激活状态，输入产品密钥，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号
      注意如果是在修改现有许可文件或是获取现有产品的新许可，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      有关每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      (Windows) 如果不知道主机名，请在命令提示下输入以下内容以查找计划使用的每台服务器的名称：

      <提示> lmutil lmhostid -hostname
      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      (Windows) 如果找不到主机 ID，请单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 在“登录”页面上，输入用户 ID 和密码，然后单击“登录”。

    如果没有用户帐户，请单击“现在创建用户 ID”链接，然后按照说明创建一个用户帐户。

  6. 在“选择帐户”页面上，选择一个帐户，然后单击“下一步”。
  7. 在“已收到许可”页面的“保存 [计算机名称] 的许可文件”字段中，输入要保存许可文件的位置，或单击“浏览”以浏览至相应的位置。
    注意建议将许可文件保存到 C:\Program Files\Autodesk Network License Manager\License。

    根据选定的服务器模式，该页的内容会有所不同。

    单击“下一步”。

  8. 在“许可证激活成功”页面上，单击“打印”以保存许可信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。

(Windows) 接收许可文件并将它保存到本地后，请参见如何配置许可服务器 (Windows)以配置许可管理器。

使用网络许可证激活实用程序（脱机请求）的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
    • (Windows Vista) 依次单击“开始” [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，单击“通过电子邮件、传真、电话或邮寄方式发送申请”，输入产品密钥，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号
      注意如果是在修改现有许可文件或是获取现有产品的新许可，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      有关每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      (Windows) 如果不知道主机名，请在命令提示下输入以下内容以查找计划使用的每台服务器的名称：

      <提示> lmutil lmhostid -hostname
      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      (Windows) 如果找不到主机 ID，请单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 在“产品注册”页面上，指定下列情况：
    • 将产品注册给公司还是个人。
    • 产品将在哪个国家或地区使用。
    • 产品是否为升级版。如果是，用户还需要以前产品的序列号。

    单击“下一步”。

  6. 在“客户信息”页面上输入个人数据，然后选择希望接收激活码的方式 - 电子邮件、传真或邮寄。单击“下一步”。
  7. 在“确认信息”页面上检查个人数据，然后选择要用来提交申请的方法。可以通过电子邮件、传真或电话发送申请。

    如果选择“通过电子邮件发送申请”，则将显示需要用户填写的电子邮件信息。如果选择“通过传真或电话发送申请”，则将显示“与 Autodesk 联系”页面以及相关的联系信息。

    激活码将通过用户在“客户信息”页面上指定的方法发送。

  8. 如果需要打印一份注册信息，请选择“打开激活申请表”。完成后单击“关闭”。

(Windows) 接收许可文件并将它保存到本地后，请参见如何配置许可服务器 (Windows)以配置许可管理器。

注意建议将许可文件保存在安装 Network License Manager 的位置。


如何配置许可服务器 (Windows)

如何安装和使用网络许可证激活实用程序
Autodesk 网络许可快速入门
如何安装和使用 SAMreport-Lite（可选）
Autodesk 网络许可快速入门 >
如何配置许可服务器 (Windows)
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要能够管理运行网络许可证激活实用程序时收到的 Autodesk 产品许可，需要配置许可服务器。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，确保“Configure Using Services”选项处于激活状态。
  3. 单击“Config Services”选项卡。
  4. 在“Service Name”列表中，选择要用来管理许可证的服务名。

    默认情况下，服务名为“Flexlm Service 1”。如果 FLEXnet® 正在管理计算机上安装的除 Autodesk 外的其他软件，则可以更改服务名以避免冲突。例如，可以将“Flexlm Service 1”重命名为“Autodesk Server1”。

    注意如果有多个软件供应商使用 FLEXnet® 进行许可证管理，则“Service Name”列表将包含多个选项。确保仅列出一个 Autodesk 服务。
  5. 在“Path to Lmgrd.exe File”字段中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此后台程序将安装在 C:\Program Files\Autodesk Network License Manager 文件夹。

  6. 在“Path to the license file”框中，输入指向许可文件的路径，或单击“Browse”以定位文件。

    这是通过网络许可证激活实用程序获得的许可文件的路径，或脱机获得的许可文件的放置位置。

  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。

    建议保存至 \Program Files\Autodesk Network License Manager 文件夹。日志文件必须具有 .log 文件扩展名。对于新的日志文件，用户必须手动输入 .log 扩展名。

  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。如果要将设置保存到服务，则在提示时单击“是”。
  11. 单击“Start/Stop/Reread”选项卡，然后执行下列操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”，使用对许可文件或选项文件所做的所有更改来刷新 Network License Manager。

    许可服务器开始运行，并准备响应客户端请求。

  12. 关闭 lmtools.exe。


如何安装和使用 SAMreport-Lite（可选）

如何配置许可服务器 (Windows)
Autodesk 网络许可快速入门
Autodesk 网络许可工具简介
Autodesk 网络许可快速入门 >
如何安装和使用 SAMreport-Lite（可选）
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

SAMreport-Lite 是一个报告工具，帮助跟踪网络许可的使用情况。使用 Acresso™ Software 提供的 SAMreport-Lite 技术，可以监控经过 Autodesk 网络许可的产品的客户端使用情况。

要了解有关安装和使用 SAMreport-Lite 的详细信息，请参见《SAMreport-Lite 用户手册》；单击安装向导左下角的“文档”链接或参见 Autodesk 产品的帮助系统。


Autodesk 网络许可工具简介

如何安装和使用 SAMreport-Lite（可选）
Network License Manager
Autodesk 网络许可工具简介
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 网络许可工具包括 Network License Manager、网络许可证激活实用程序、FLEXnet 配置工具和 SAMreport-Lite。以下各节中分别对每种工具进行了介绍。

本节内容

  • Network License Manager
  • 网络许可证激活实用程序
  • FLEXnet 配置工具
  • SAMreport-Lite 许可报告工具


Network License Manager

Autodesk 网络许可工具简介
Autodesk 网络许可工具简介
Network License Manager 的系统需求
Autodesk 网络许可工具简介 >
Network License Manager
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Network License Manager 用于配置和管理许可服务器。创建展开时，安装向导将提示用户输入有关许可管理器的信息，例如许可服务器模式和服务器名称。

有关从网络位置展开 Autodesk 产品的详细信息，请通过单击安装向导左下角的“文档”链接或在帮助系统中参见《网络管理员手册》。

本节内容

  • Network License Manager 的系统需求


Network License Manager 的系统需求

Network License Manager
Network License Manager
网络许可证激活实用程序
Autodesk 网络许可工具简介 > Network License Manager >
Network License Manager 的系统需求
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

确保网络许可服务器达到所建议的最低需求。请参见下面的硬件和软件需求表。

注意并不是所有的产品均支持所有的操作系统。请参见产品的《网络管理员手册》以查看所支持的操作系统。
网络许可服务器的硬件和软件需求
硬件/软件 | 需求 | 说明
操作系统 | Windows Vista® 32 位 SP1 Windows Vista 64 位 SP1 Windows® XP 32 位 SP3 Windows XP 64 位 SP2 Windows 2003 R2 Server Edition Windows 2003 Server Edition Windows 2000 Server Edition* | Network License Manager 仅支持以太网网络配置。 *如果用户使用的是 Windows 2000 Server，则必须手动安装 Network License Manager，其位于产品安装目录：CDROM1\x86\support\NLM\en-US\NLM.msi。
计算机/处理器 | Pentium® III 或更高 450 Mhz（最低要求） Intel Mac |
网络接口卡 | 与现有的以太网网络基础构造兼容 | Network License Manager 支持多块网络适配卡，但必须至少有一块是以太网卡。
通讯协议 | TCP/IP | Network License Manager 使用 TCP 包类型。


网络许可证激活实用程序

Network License Manager 的系统需求
Autodesk 网络许可工具简介
FLEXnet 配置工具
Autodesk 网络许可工具简介 >
网络许可证激活实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用网络许可证激活实用程序可以通过 Internet 获取许可，这样可以节省设置网络许可版本的 Autodesk 产品所用的时间和精力。

此外，此实用程序还用于注册产品，为电子邮件提供自动支持（如果无法通过 Internet 获取许可）以及自动保存和移植许可文件，从而使用户无需进行手动操作。

注意建议使用网络许可证激活实用程序来获取许可文件。然而，如果无法通过连接到 Internet 来获取许可文件，请参见使用网络许可证激活实用程序。


FLEXnet 配置工具

网络许可证激活实用程序
Autodesk 网络许可工具简介
许可服务器管理实用程序
Autodesk 网络许可工具简介 >
FLEXnet 配置工具
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Network License Manager 使用 Acresso Softwareuses 提供的 FLEXnet® 许可管理技术。FLEXnet 提供了有助于简化网络许可管理的管理工具。可以使用 FLEXnet 工具监视网络许可的状态、重置因系统故障而丢失的许可、对许可服务器进行故障排除以及动态更新现有许可文件。

本节内容

  • 许可服务器管理实用程序
  • 选项文件


许可服务器管理实用程序

FLEXnet 配置工具
FLEXnet 配置工具
选项文件
Autodesk 网络许可工具简介 > FLEXnet 配置工具 >
许可服务器管理实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

FLEXnet 提供了两个用于管理许可服务器的实用程序。这些工具位于 C:\Program Files\Autodesk Network License Manager 文件夹中。

lmtools.exe

提供了一个用于管理许可服务器的 Microsoft® Windows 图形用户界面。

lmutil.exe

提供了一组用于管理许可服务器的命令行选项。

可以使用 lmtools.exe 或 lmutil.exe 执行以下服务器管理任务：

  • 启动、停止和重新启动服务器。
  • 配置、更新和重新读取许可文件。
  • 诊断系统或许可问题。
  • 查看服务器状态，包括活动的许可状态。


选项文件

许可服务器管理实用程序
FLEXnet 配置工具
SAMreport-Lite 许可报告工具
Autodesk 网络许可工具简介 > FLEXnet 配置工具 >
选项文件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

FLEXnet 的另一个组件是选项文件。您可以创建该文件以设置特定的配置选项。关于创建和使用选项文件的信息，请参见设置和使用选项文件。

使用选项文件可以为以下服务器相关的特性设置参数：

报告日志文件

将创建一个压缩的加密文件，用于生成有关许可活动的精确使用情况报告，以供 SAMreport-Lite 使用。有关 SAMreport-Lite 的详细信息，请参见《SAMreport-Lite User's Guide》，可以通过菜单浏览器的“文档”选项卡访问该手册。

许可借用

如果 Autodesk 产品支持许可借用功能，则可以允许用户从网络许可服务器借用 Autodesk 产品许可，以便他们可以使用产品而无需建立许可服务器连接。许可借用具有时间限制。

许可超时

通过许可超时，可以在许可服务器上每次为一种 Autodesk 产品设置超时时间。设置后，如果出现以下情况，许可超时会将许可返回给许可服务器：与工作站的连接断开，或者许可已检出，但 Autodesk 产品在工作站上处于空闲状态的时间超过了定义的超时时间。

全局许可超时

通过全局许可超时，可以在许可服务器上设置应用于计算机上安装的所有 Autodesk 产品的超时时间。设置后，如果出现以下情况，许可超时会将许可返回给许可服务器：与工作站的连接断开，或者许可已检出，但 Autodesk 产品在工作站上处于空闲状态的时间超过了定义的超时时间。

关于配置选项的详细信息，请参见设置和使用选项文件。

有关使用 FLEXnet 配置工具的详细信息，请导航至 C:\Program Files\Autodesk Network License Manager\Docs\FlexUser\LicenseAdministration.pdf 查看 FLEXnet 文档。


SAMreport-Lite 许可报告工具

选项文件
Autodesk 网络许可工具简介
规划网络许可
Autodesk 网络许可工具简介 >
SAMreport-Lite 许可报告工具
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

尽管不是网络安装的组成部分，但 SAMreport 的 SAMreport-Lite 版本将有助于追踪网络许可的使用情况。使用 Acresso Software 提供的 SAMreport-Lite 技术，可以监控经过 Autodesk 网络许可的产品的客户端使用情况。

SAMreport-Lite 生成各种输出格式（包括 HTML 格式、文本格式和报告交换格式）的使用情况报告。有关 SAMreport-Lite 功能的详细信息以及 SAMreport-Lite 的安装说明，请参见《SAMreport-Lite User's Guide》。

注意可以通过 Autodesk 产品的菜单浏览器来安装 SAMreport-Lite 和访问《SAMreport-Lite User's Guide》。

关于 SAMreport-Lite 的其他信息以及此功能的更新和更正，请访问 Autodesk 站点：

www.autodesk.com/samreportlite


规划网络许可

SAMreport-Lite 许可报告工具
规划许可服务器配置
规划网络许可
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节中包括在设置网络许可服务器之前需要知道的信息。本节包括有关所支持的许可服务器模式、许可操作和可用性、网络许可文件定义和参数、许可文件样例、许可类型和行为以及许可服务器心跳信号的信息。

本节内容

  • 规划许可服务器配置
  • 了解许可


规划许可服务器配置

规划网络许可
规划网络许可
单一许可服务器模式
规划网络许可 >
规划许可服务器配置
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

用户必须确定使用哪种许可服务器模式管理服务器上的 Autodesk 产品许可。Autodesk 支持以下网络许可服务器模式：

  • 单一许可服务器模式
  • 分布式许可服务器模式
  • 冗余许可服务器模式

本节内容

  • 单一许可服务器模式
  • 分布式许可服务器模式
  • 冗余许可服务器模式


单一许可服务器模式

规划许可服务器配置
规划许可服务器配置
分布式许可服务器模式
规划网络许可 > 规划许可服务器配置 >
单一许可服务器模式
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在单一许可服务器模式中，Network License Manager 安装在一台服务器上，因此许可管理和活动只能在此服务器上进行。单一许可文件表示服务器上可用许可的总数。

单一许可服务器模式的优点

  • 由于所有许可管理都在一台服务器上进行，所以只有一个管理点和一个故障点。
  • 在三种许可服务器模式中，此配置需要的维护工作量最少。

单一许可服务器模式的缺点

  • 如果单一许可服务器出现故障，在服务器恢复工作之前，Autodesk 产品将无法运行。


分布式许可服务器模式

单一许可服务器模式
规划许可服务器配置
冗余许可服务器模式
规划网络许可 > 规划许可服务器配置 >
分布式许可服务器模式
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在分布式许可服务器模式中，许可分布在多台服务器上。每台服务器都要求具有唯一的许可文件。要创建分布式许可服务器，必须在分布式服务器池中的每台服务器上运行 Network License Manager。

分布式许可服务器模式的优点

  • 服务器可分布在广域网 (WAN) 范围内，而不必位于同一个子网中。
  • 当分布式服务器池中的一台服务器出现故障时，其他服务器中的许可仍然可用。
  • 需要替换分布式服务器池中的服务器时，不必重新建立整个服务器池。
  • 这比在冗余服务器池中替换服务器更容易，因为在冗余服务器池中替换服务器时必须重新激活整个服务器池。

分布式许可服务器模式的缺点

  • 如果分布式服务器池中的某台服务器出现故障，该服务器中的许可将不可用。


冗余许可服务器模式

分布式许可服务器模式
规划许可服务器配置
了解许可
规划网络许可 > 规划许可服务器配置 >
冗余许可服务器模式
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在冗余许可服务器模式下，可以使用三台服务器验证单个许可文件。一台服务器作为主服务器，另外两台服务器在主服务器无法工作时提供备份。使用此配置，只要有两台服务器正常工作，即可继续监视和分发许可。三台服务器上的许可文件是同一文件。每台服务器上都必须安装 Network License Manager。

在冗余许可服务器模式下，所有服务器必须位于同一子网中并具有稳定的网络通信。（不支持低速、不稳定或拨号连接。）

冗余许可服务器模式的优点

  • 如果三台服务器中有一台服务器出现故障，服务器池中管理的所有许可仍然可用。

冗余许可服务器模式的缺点

  • 如果多台服务器出现故障，所有许可都将不可用。
  • 三台服务器必须位于同一个子网中，且必须具有可靠的网络通信。冗余服务器池不提供网络容错。
  • 如果更换三台服务器中的一台，则必须重新建立整个冗余服务器池。
  • 如果 Autodesk 产品支持许可借用功能，并且许可是从冗余许可服务器池借用的，则在停止 Network License Manager 之后必须重新启动许可服务器。


了解许可

冗余许可服务器模式
规划网络许可
许可操作及可用性
规划网络许可 >
了解许可
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节介绍许可的操作和可用性、许可文件、许可类型和行为以及心跳信号。

本节内容

  • 许可操作及可用性
  • 许可文件
  • 许可文件样例
  • 文件包许可文件样例
  • 许可类型和行为
  • 心跳信号


许可操作及可用性

了解许可
了解许可
许可文件
规划网络许可 > 了解许可 >
许可操作及可用性
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

启动 Autodesk 产品时，产品自己会决定应该从哪台服务器上获取许可。然后，产品将通过 TCP/IP 网络协议向许可服务器请求许可。

如果许可服务器上还有可用许可，Network License Manager 则为工作站分配一个许可。然后，工作站上将启动一个产品任务，许可服务器上的可用许可数目也相应减少一个。

同样，退出产品时，Network License Manager 将释放许可以供其他用户使用。如果在单个工作站上运行 Autodesk 产品的多个任务，则只使用一个许可。当最后一个任务关闭时，许可才被释放。

以下三个过程用于管理许可的分发和可用性：

  • 许可管理器守护程序 (lmgrd.exe)。处理与应用程序的初始联系，然后将连接传递给供应商守护程序。lmgrd.exe 守护程序仅用于与供应商守护程序进行通信；lmgrd.exe 不能验证或分发许可，而只能将用户请求传递给供应商守护程序。使用此方法，多家软件供应商可以使用一个 lmgrd.exe 守护程序提供许可验证。lmgrd.exe 守护程序可以根据需要启动和重新启动供应商守护程序。
  • Autodesk 供应商守护程序 (adskflex.exe)。对已检出的许可及使用这些许可的工作站进行追踪。每个软件供应商都具有唯一的供应商守护程序，用来管理特定供应商的许可。顾名思义，adskflex.exe 供应商守护程序针对的是 Autodesk 产品。
注意如果 adskflex.exe 供应商守护程序因为某种原因而终止，所有用户都将丢失许可，除非 lmgrd.exe 重新启动供应商守护程序或导致终止的问题已被解决。
  • 许可文件。包含特定于供应商的许可信息的文本文件。


许可文件

许可操作及可用性
了解许可
许可文件样例
规划网络许可 > 了解许可 >
许可文件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

从 Autodesk 收到的网络许可文件包含网络安装所需的许可信息。可以在注册 Autodesk 产品时获取许可文件数据。

许可文件包含关于网络服务器节点和供应商守护程序的信息，还包含 Autodesk 生成该文件时创建的加密数字签名。

许可文件位于用户在展开向导中指定的网络位置。对于从网络安装运行该产品的每一个用户，该网络位置都必须是可访问的。

下表定义了所有许可文件参数。

许可文件参数的定义
直线 | 参数 | 定义 | 样例
SERVER | Host Name | Network License Manager 所在服务器的主机名 | LABSERVER
 | Host ID | Network License Manager 所在服务器的以太网地址 | 03D054C0149B
USE_SERVER | [无] |  |
VENDOR | 供应商守护程序 | 服务器端 Autodesk 供应商守护程序的名称 | adskflex.exe
 | Port Number | 保留并指定仅由运行 Autodesk 供应商守护程序的 Autodesk 产品使用的网络端口号 | port=2080
PACKAGE | 名称 | 功能代码编组的名称 | SERIES_1
 | Version | 内部版本号参照 | 1.000
 | COMPONENTS | 软件包中受支持的功能代码的列表 | COMPONENTS="526000REVIT_9_OF\ 51200ACD_2007_OF\ 513001INVBUN_11_OF"
 | OPTIONS |  | OPTIONS=SUITE
 | SUPERSEDE | 同一许可服务器上日期早于定义的“Issue Date”（发布日期）的任何许可文件中，相同功能代码的任何现有“Increment”（增量）行的替换 | SUPERSEDE
 | SIGN | 用于验证许可文件属性的加密签名 | SIGN=0 SIGN2=0
INCREMENT | Feature Code | 许可文件支持的产品 | 51200ACD_2007_0F
 | Expiration Date | 许可的有效期 | permanent
 | Number of Licenses | 许可文件支持的许可数目 | 25
 | VENDOR_STRING | 许可文件支持的产品的许可使用类型和许可行为。 | COMMERCIAL
 | BORROW | 在同一增量行下定义的许可的许可借用时间定义。 在本样例中，许可可借用的最长时间为 4320 小时（180 天），除非另有说明（例如，BORROW=2880 表示该许可最长可借用 2880 小时，即 120 天）。 如果许可文件中没有此参数，将禁用许可借用功能。 | BORROW=4320
 | DUP_GROUP | 同一用户和同一主机共享同一许可时的多个许可请求定义 | DUP_GROUP=UH
 | ISSUED | Autodesk 生成许可文件的日期 | 15-jul-2006
 | 序列号 | Autodesk 产品的序列号 | 123-12345678
 | SIGN | 用于验证许可文件属性的加密签名 | SIGN=6E88EFA8D44C


许可文件样例

许可文件
了解许可
不特定于产品的许可文件样例
规划网络许可 > 了解许可 >
许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本文档中提供的许可文件样例可以帮助您理解在特定的网络设置中许可文件的作用方式。Autodesk 为每个产品都提供标准许可文件，并为既可单独销售又可作为产品集一部分销售的产品提供具有附加参数的许可文件。

  • 标准许可文件。如果用户购买了一个或多个不是作为产品套件的一部分提供的产品，将收到标准许可文件。
  • 具有附加参数的标准许可文件。如果用户购买了包括在产品套件中并且还可以作为单个产品销售的 Autodesk 产品，将收到一个标准许可文件，该许可文件中包括了附加参数。附加参数定义了许可使用的次序，以便在使用产品集许可之前使用单个产品许可。

Autodesk 许可文件样例包括一个不特定于某产品的许可文件，针对单一服务器模式、分布式服务器模式和冗余服务器模式的完整许可文件，一个已合并的产品版本许可文件和已添加至标准许可文件的附加参数的样例。

本节内容

  • 不特定于产品的许可文件样例
  • 单一或分布式服务器的许可文件样例
  • 冗余服务器的许可文件样例
  • 已合并的 Autodesk 产品版本的许可文件样例
  • 许可文件中附加参数的样例


不特定于产品的许可文件样例

许可文件样例
许可文件样例
单一或分布式服务器的许可文件样例
规划网络许可 > 了解许可 > 许可文件样例 >
不特定于产品的许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是包括某一个许可文件的内容以及与其每一行相关联的参数的样例：

SERVER ServerName HostID
USE_SERVER
VENDOR adskflex port=portnumber
INCREMENT feature_code Adskflex Version ExpDate NumberofLicenses \
VENDOR_STRING=UsageType:Behavior BORROW=4320 SUPERSEDE \ DUP_GROUP=DupGrp ISSUED=IssueDate SN=SerialNumber SIGN= \


单一或分布式服务器的许可文件样例

不特定于产品的许可文件样例
许可文件样例
冗余服务器的许可文件样例
规划网络许可 > 了解许可 > 许可文件样例 >
单一或分布式服务器的许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是单一或分布式许可服务器模式的完整许可文件的样例：

SERVER XXHP0528 0019bbd68993
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \
   E368 816E D417 C1CD 7DBD 7B90 1354 D6F0 48FE EBB8 9C84 C3AF \
   7D79 BEE1 0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
   057C A579 7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 E00B D967 \
   D821 BD37 BE6D B78A F074 B223 88AA 242C DD0A 1292 D56F 4108 \
   62CD FA35 E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"


冗余服务器的许可文件样例

单一或分布式服务器的许可文件样例
许可文件样例
已合并的 Autodesk 产品版本的许可文件样例
规划网络许可 > 了解许可 > 许可文件样例 >
冗余服务器的许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是冗余许可服务器模式的完整许可文件的样例：

SERVER CCN12378042 001cc4874b03 27005
SERVER XXHP0528 0019bbd68993 27005
SERVER CCN12378043 001cc4874b10 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=10-Jan-2008 SN=123-12345678 SIGN="11C4 \
   CA79 07FC 7AD0 409A 6E04 6E98 D76C 197C 0416 076C B211 1CDD \
   D0AB 698B 16BF 7A0E D4F8 1CFE 2985 644F 64CD CECE 0DDB 5951 \
   3262 7C31 13A8 F08F 55B2" SIGN2="19A6 FDA3 2ED5 5301 8675 7B81 \
   1B0E 451B 19F1 1A99 C8E9 CBA6 8CB3 6AC3 8B38 1519 13F2 2373 \
   82AE 55E5 1A25 4952 4458 F3A2 6F28 D25D 1DC0 E066 209B 0953"
注意冗余服务器模式需要为每台服务器都添加一个端口号（默认值为 27005）。


已合并的 Autodesk 产品版本的许可文件样例

冗余服务器的许可文件样例
许可文件样例
许可文件中附加参数的样例
规划网络许可 > 了解许可 > 许可文件样例 >
已合并的 Autodesk 产品版本的许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以合并同一 Autodesk 产品的不同版本或是不同 Autodesk 产品的许可文件，然后从一个许可服务器运行所有产品。例如，可以将 AutoCAD 2009 的许可文件与 Maya® 2009 和 AutoCAD Map 的许可文件合并。

以下是 AutoCAD 2008 和 AutoCAD 2009 的合并许可文件的内容样例：

SERVER XXHP0528 0019bbd68993
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 57600ACD_2009_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \
   E368 816E D417 C1CD 7DBD 7B90 1354 D6F0 48FE EBB8 9C84 C3AF \
   7D79 BEE1 0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
   057C A579 7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 E00B D967 \
   D821 BD37 BE6D B78A F074 B223 88AA 242C DD0A 1292 D56F 4108 \
   62CD FA35 E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 3 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1E6E \
   4B61 5712 4766 92A0 6782 9EF4 3F47 56A1 1F38 6DE8 C0C7 90AC \
   7289 152E 0EA2 CC0D 3F10 577A 0489 CEB6 10D5 FBCC B552 0C9D \
   5966 91A6 59F0 2788 FACE" SIGN2="1DDF 3B9D 3392 71D5 AB08 7E05 \
   8497 111E 092F 0E54 8DC2 2BED 17C2 2CC1 981B 0EC2 BC15 8F00 \
   C79A ABFD 2136 BABA 2EDF E941 EA53 32C6 597F F805 5A8A 599A"


许可文件中附加参数的样例

已合并的 Autodesk 产品版本的许可文件样例
许可文件样例
文件包许可文件样例
规划网络许可 > 了解许可 > 许可文件样例 >
许可文件中附加参数的样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

对于包括在产品集中并且还可以作为单个产品销售的 Autodesk 产品，将根据许可文件中定义的优先级次序来分配许可。对于这些产品，许可文件中将显示类似于以下样例的信息：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
   45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
   3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
   76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
   2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
   136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"


文件包许可文件样例

许可文件中附加参数的样例
了解许可
单一或分布式服务器的文件包许可文件样例
规划网络许可 > 了解许可 >
文件包许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 提供了一个文件包许可文件选项，用户可以使用打包且捆绑销售的一系列产品。该文件包许可文件包含适用于四个不同版本软件的一组许可。运行任一版本的一个实例将使用文件包中的一个许可。打包的许可文件支持之前针对速博应用用户的版本控制。使用文件包许可文件时需遵循以下指导：

  • 文件包许可文件随附软件的当前版本以及同一产品的前三个版本。
  • 许可文件可能由不同产品的许可文件合并而成。有关合并许可文件的详细信息，请参见已合并的 Autodesk 产品版本的许可文件样例。
  • 文件包许可文件不可与适用于该文件包中包含的产品版本的非文件包许可文件合并。例如，无法将 Autodesk 产品 2009 文件包许可文件与适用于 Autodesk 产品 2008、2007 或 2006 的常规许可文件合并。
  • 要使许可正常工作，必须同时具备许可证的 PACKAGE 和 INCREMENT 部分。合并许可文件时，请务必包含这两部分。
  • 许可借用、选项文件和许可级联处理文件包许可证的方式与处理常规许可文件的方式相同。
  • 新的许可文件将替代旧的许可文件。

以下提供了适用于单一许可服务器、分布式许可服务器和冗余许可服务器的文件包许可文件样例，以及适用于已合并的 Autodesk 产品版本的文件包许可文件样例。

本节内容

  • 单一或分布式服务器的文件包许可文件样例
  • 冗余服务器的文件包许可文件样例
  • 已合并的 Autodesk 产品版本的文件包许可文件样例


单一或分布式服务器的文件包许可文件样例

文件包许可文件样例
文件包许可文件样例
冗余服务器的文件包许可文件样例
规划网络许可 > 了解许可 > 文件包许可文件样例 >
单一或分布式服务器的文件包许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是单一或分布式许可服务器模式的完整许可文件的样例：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2009_0F \
   54600ACD_2009_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
   ISSUED=09-Jan-2008 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
   AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
   FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
   SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 98E2 \
   5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
   CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
   VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
   SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
   692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
   3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
   SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
   5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
   CD68 1D77 27F8 8555 9CF7 DEDD 9380"


冗余服务器的文件包许可文件样例

单一或分布式服务器的文件包许可文件样例
文件包许可文件样例
已合并的 Autodesk 产品版本的文件包许可文件样例
规划网络许可 > 了解许可 > 文件包许可文件样例 >
冗余服务器的文件包许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是冗余许可服务器模式的完整许可文件的样例：

SERVER 1a34567c90d2 27005
SERVER 2a34567c90d2 27005
SERVER 3a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE 64300ACD_F adskflex 1.000 COMPONENTS="57600ACD_2009_0F \
   54600ACD_2008_0F 51200ACD_2007_0F 48800ACD_2006_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=27-May-2008 SIGN="1092 05D8 \
   A206 276B 2C84 EFAD ACA5 C54B 68A4 653E C61F 31DE C8CE B532 \
   CFBB 0006 5388 347B FDD6 A3F4 B361 7FD4 CDE4 4AAC 0D11 B0EF \
   4B44 BFD6 3426 97DD" SIGN2="0670 B01A D060 0069 FF25 F1CD D06B \
   314E E7C9 3552 5FFA 4AC7 28A7 C897 F56A 19BB FB1C 754E 6704 \
   DEEA AC4E F859 2E9B 64B6 0DD0 9CCE 9556 269F EAC0 2326"
INCREMENT 64300ACD_F adskflex 1.000 permanent 50 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=27-May-2008 \
   SN=399-99999999 SIGN="1B5B 8D70 4CAD 32E5 9CA2 82E0 5C47 291C \
   35AB 9B9C 5B3E 5067 F61B 4139 1B32 0716 1FD3 5105 A991 B78E \
   9D1E 63AB BC23 0D1E B70C 2A05 E1C1 F605 ABB1 2EA8" SIGN2="01D6 \
   31F5 2951 4500 E5C8 058F 7490 9789 9EF4 CBED DA27 5F06 6780 \
   9033 2018 0C3B E1E0 3580 E60E C2BB B4AB 8D6A 4245 3059 8CA6 \
   2EFE DFAE 027F 2ABE 3F2B"


已合并的 Autodesk 产品版本的文件包许可文件样例

冗余服务器的文件包许可文件样例
文件包许可文件样例
许可类型和行为
规划网络许可 > 了解许可 > 文件包许可文件样例 >
已合并的 Autodesk 产品版本的文件包许可文件样例
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

以下是适用于已合并的 Autodesk 产品版本的已完成许可文件样例。

SERVER servername 123456789111
USE_SERVER
VENDOR adskflex port=2080
PACKAGE 64300ACD_F adskflex 1.000 COMPONENTS="57600ACD_2009_0F \
   54600ACD_2008_0F 51200ACD_2007_0F 48800ACD_2006_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="03EF DE18 \
   8046 0124 4EA4 6953 F82D 3169 7C24 D0DE E58E 8168 FFA3 D891 \
   B43B 08D8 7E7F C6ED CBCC FE2A BB0A 4566 C2AE F1C1 D373 8348 \
   E6E3 884A E398 1C78" SIGN2="07AC D696 8844 D19F AB00 8B75 53A3 \
   2F76 91DF AED0 3231 1506 0E6B ADC6 C3B8 1797 93B5 9756 8C0F \
   8811 56E6 B2BA 0523 FE2E 82B7 1628 076F 173B F37C 7240"
INCREMENT 64300ACD_F adskflex 1.000 permanent 2 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=25-Jun-2008 \
   SN=399-99999999 SIGN="1CCB E88D B819 8604 06FA 9AEE 42F1 CBEA \
   37B9 3CFA A0A8 697F 9CB1 8354 6256 05ED 69D4 D2FF D512 6A2E \
   D5DD B722 EF5B 3172 BA95 4625 F8D3 DD24 BB39 6A58" SIGN2="0DFF \
   FA6F C378 20E0 2622 BE52 B434 F99F 2681 2B93 64F2 CE0C 7F4A \
   7024 B3D1 051A 6920 72BD DE35 8920 E6A1 C8D6 AF23 7BE7 CC91 \
   6916 70B1 9E80 AB07 1644"
PACKAGE 64800INVPRO_F adskflex 1.000 \
COMPONENTS="59600INVPRO_2009_0F \
   55300INVPRO_2008_0F 51400INVPRO_11_0F 49000INVPRO_10_0F" \
   OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="1306 5990 \
   F8A1 56FB 1D8A 9DA7 D6AE 8E9E F6EC 2862 367A 36E2 C5FB E6E1 \
   4AAA 0128 8C2D 95FD 09B2 ABA1 6F98 A0A3 70DE 3220 6835 7E51 \
   3849 9D81 8BDC 9DC1" SIGN2="0021 AA08 F2E7 8AEB 5345 341A 7E42 \
   3001 B8C5 DFC2 6EB8 87C5 C04A AE43 A10F 1DA1 EF8A F0FA 10F5 \
   AC81 1E22 789F A18D 650F 6BBB 563A BDA5 DD1C 82EC 27F6"
INCREMENT 64800INVPRO_F adskflex 1.000 permanent 2 \
   VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
   DUP_GROUP=UH SUITE_DUP_GROUP=UHV ISSUED=25-Jun-2008 \
   SN=399-99999966 SIGN="0BE4 51F4 570C DC48 5E66 F952 629E EDF0 \
   019C 6FF7 0509 1FF0 D4FB 3B16 1981 073F 31EC A241 8CB3 8782 \
   E655 00C6 E097 D5EF B0D8 67D3 199D 699D 2E09 B16F" SIGN2="1254 \
   3E37 0CE4 F42D B7CD 858C 92FC A963 5274 770F 9354 FE29 E117 \
   205D C632 0C4E AEC0 7501 9D9E FFEB D84D F154 16A1 E120 339A \
   FDBF 3F07 4477 B8B3 5DA4"


许可类型和行为

已合并的 Autodesk 产品版本的文件包许可文件样例
了解许可
心跳信号
规划网络许可 > 了解许可 >
许可类型和行为
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 支持动态产品使用和许可行为。这意味着用户可以使用特定许可购买特定的行为类型，并且以后更改许可时不必删除安装和重新安装 Autodesk 产品。

许可类型包括以下几种：

  • 商业许可。以商业方式购买的产品的许可。
  • 非销售许可。非作为商品销售的产品的许可。非销售产品仅用于评估或演示用途，不可用于商业或生产方面。
  • 教育版 (EDU) 许可。专门用于教育机构的许可。
  • 学生版。用于使用 Autodesk 产品作为课程内容的学生的许可。

许可行为包括以下几种：

  • 永久性。允许永久使用 Autodesk 产品。
  • 可延长期限。允许在有限时间内使用 Autodesk 产品。该期限可以随时延长。
  • 不可延长期限。允许在有限时间内使用 Autodesk 产品。该期限不能延长。


心跳信号

许可类型和行为
了解许可
网络许可工具
规划网络许可 > 了解许可 >
心跳信号
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 产品运行时，会定期与许可服务器进行通信，它使用的通信方法称为“心跳”信号。如果心跳信号丢失，服务器会尝试重新连接。如果服务器无法重新连接，用户将收到许可错误信息。

如果产品因丢失与服务器的连接而停止工作，必须关闭该产品然后重新启动。如果最初导致心跳信号丢失的问题得到解决，且服务器上有可用的许可，则可以重新启动程序。


网络许可工具

心跳信号
从早期版本更新 FLEXnet
网络许可工具
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本节包括有关通过网络更新 FLEXnet、安装和配置 Autodesk Network License Manager 的信息，以及有关安装和使用网络许可证激活实用程序的信息。

本节内容

  • 从早期版本更新 FLEXnet
  • 安装 Autodesk Network License Manager
  • 安装网络许可证激活实用程序
  • 使用网络许可证激活实用程序
  • 手动获取服务器主机名和主机 ID
  • 配置许可服务器 (Windows)
  • 停止和重新启动许可服务器
  • 设置和使用选项文件
  • 删除安装 Network License Manager


从早期版本更新 FLEXnet

网络许可工具
网络许可工具
安装 Autodesk Network License Manager
网络许可工具 >
从早期版本更新 FLEXnet
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

Autodesk 产品的此版本及更高版本要求 FLEXnet 11.5 版或更高版本。如果当前所使用的 FLEXnet 的版本早于 11.5 版，则需要升级到 11.5 版或更高版本。

注意如果要安装 Autodesk Network License Manager 的服务器上已安装了用于其他产品的 FLEXnet，请确保 lmgrd.exe 是最新版本。

要确定安装的 FLEXnet 的版本，需要确认以下文件的版本：

Windows

  • lmgrd.exe
  • lmtools.exe
  • lmutil.exe
  • adskflex.exe

确认 lmutil.exe、lmtools.exe 或 adskflex.exe 的版本的步骤 (Windows)

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 lmtools.exe 中，单击“Utility”选项卡。
  3. 在“Utility”选项卡中，输入文件的位置，或单击“Browse”按钮定位相应文件并单击“打开”。文件位置应与下面内容相似：

    C:\Program Files\Autodesk Network License Manager\lmutil.exe

  4. 在“Utility”选项卡中，单击“Find Version”。

    将显示选定文件的版本号。如果需要，请使用以下步骤更新 FLEXnet 的版本。

更新 FLEXnet 的步骤 (Windows)

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 备份许可文件。
  2. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  3. 在 LMTOOLS 程序中，单击“Start/Stop/Reread”选项卡。
  4. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  5. 关闭 lmtools.exe。
  6. 记下 Network License Manager 的安装位置，然后卸载 Network License Manager。关于删除安装 Network License Manager 的详细信息，请参见删除安装 Network License Manager。
  7. 安装 Network License Manager。有关将 Network License Manager 安装在之前版本的相同位置的详细信息，请参见安装 Autodesk Network License Manager。
  8. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  9. 在 LMTOOLS 程序中，单击“Start/Stop/Reread”选项卡。
  10. 在“Start/Stop/Reread”选项卡中，单击“Start Server”。
  11. 关闭 lmtools.exe。


安装 Autodesk Network License Manager

从早期版本更新 FLEXnet
网络许可工具
安装网络许可证激活实用程序
网络许可工具 >
安装 Autodesk Network License Manager
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以在使用安装向导之前或之后安装 Network License Manager。安装网络应用程序的顺序无关紧要，只要您安装所有所需应用程序并为所有网络应用程序提供一致的许可服务器信息。

如果该计算机中已经安装了早期版本的 Network License Manager，则应进行升级，方法是将 Autodesk Network License Manager 安装到该早期版本所在的文件夹中。

安装 Autodesk Network License Manager 的步骤

  1. 在 Autodesk 安装向导中，单击“安装工具和实用程序”。
  2. 在“选择要安装的产品”页面中，选择“Network License Manager”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  5. 如果在上一步骤中选择了多个产品，则请单击“Network License Manager”选项卡。
  6. 在“选择安装位置”页面中，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\) 或单击“...”指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新的文件夹。单击“配置完成”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，用户必须提供一个本地驱动器的路径。用户必须指定驱动器号；不允许使用通用命名约定 (UNC)。
  7. 返回“查看 - 配置 - 安装”页面后，请单击“安装”以开始安装 Network License Manager 及其他任何选定的工具和实用程序。
  8. 显示“安装完成”页面时，单击“完成”。


安装网络许可证激活实用程序

安装 Autodesk Network License Manager
网络许可工具
使用网络许可证激活实用程序
网络许可工具 >
安装网络许可证激活实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装网络许可证激活实用程序，以便可以通过 Internet 获取许可文件。

安装网络许可证激活实用程序的步骤

  1. 在 Autodesk 安装向导中，单击“安装工具和实用程序”。
  2. 在“选择要安装的产品”页面上，选择“网络许可证激活实用程序”，然后单击“下一步”。
  3. 查看适用于用户所在国家/地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家/地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意许可协议的条款并希望终止安装，请单击“取消”。
  4. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  5. 如果在上一步骤中选择了多个产品，则请单击“网络许可证激活实用程序”选项卡。
  6. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility) 或单击“...”指定其他路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新的文件夹。单击“配置完成”。
  7. 返回“查看 - 配置 - 安装”页面后，请单击“安装”以开始安装网络许可证激活实用程序及其他任何选定的工具和实用程序。
  8. 显示“安装完成”页面时，单击“完成”。


使用网络许可证激活实用程序

安装网络许可证激活实用程序
网络许可工具
手动获取服务器主机名和主机 ID
网络许可工具 >
使用网络许可证激活实用程序
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用网络许可证激活实用程序，可以通过 Internet 获取许可。此外，此实用程序还用于注册产品、提供有关电子邮件的自动支持（如果不能通过 Internet 获取许可）以及自动保存并移植许可文件。

如果要使用网络许可证激活实用程序来获取许可文件，请确保提供了以下信息：

  • 许可服务器信息，包括主机名和主机 ID
  • 早期产品的序列号（仅对于升级）
  • 对可以保存许可文件的位置的访问权限

使用网络许可证激活实用程序（联机请求）的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
    • (Windows Vista) 依次单击“开始” [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，确保“直接连接(通过 Internet)”处于激活状态，输入产品密钥，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号
      注意如果是在修改现有许可文件或是获取现有产品的新许可，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      有关每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      (Windows) 如果不知道主机名，请在命令提示下输入以下内容以查找计划使用的每台服务器的名称：

      <提示> lmutil lmhostid -hostname
      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      (Windows) 如果找不到主机 ID，请单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 在“登录”页面上，输入用户 ID 和密码，然后单击“登录”。

    如果没有用户帐户，请单击“现在创建用户 ID”链接，然后按照说明创建一个用户帐户。

  6. 在“选择帐户”页面上，选择一个帐户，然后单击“下一步”。
  7. 在“已收到许可”页面的“保存 [计算机名称] 的许可文件”字段中，输入要保存许可文件的位置，或单击“浏览”以浏览至相应的位置。
    注意建议将许可文件保存到 C:\Program Files\Autodesk Network License Manager\License。

    根据选定的服务器模式，该页的内容会有所不同。

    单击“下一步”。

  8. 在“许可证激活成功”页面上，单击“打印”以保存许可信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。

(Windows) 接收许可文件并将它保存到本地后，请参见如何配置许可服务器 (Windows)以配置许可管理器。

使用网络许可证激活实用程序（脱机请求）的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
    • (Windows Vista) 依次单击“开始” [image] “所有程序” [image] “Autodesk” [image] “Network License Manager” [image] “[Autodesk 产品] 网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，单击“通过电子邮件、传真、电话或邮寄方式发送申请”，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号
      注意如果是在修改现有许可文件或是获取现有产品的新许可，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      有关每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      (Windows) 如果不知道主机名，请在命令提示下输入以下内容以查找计划使用的每台服务器的名称：

      <提示> lmutil lmhostid -hostname
      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      (Windows) 如果找不到主机 ID，请单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 在“产品注册”页面上，指定下列情况：
    • 将产品注册给公司还是个人。
    • 产品将在哪个国家或地区使用。
    • 产品是否为升级版。如果是，用户还需要以前产品的序列号。

    单击“下一步”。

  6. 在“客户信息”页面上输入个人数据，然后选择希望接收激活码的方式 - 电子邮件、传真或邮寄。单击“下一步”。
  7. 在“确认信息”页面上检查个人数据，然后选择要用来提交申请的方法。可以通过电子邮件、传真或电话发送申请。

    如果选择“通过电子邮件发送申请”，则将显示需要用户填写的电子邮件信息。如果选择“通过传真或电话发送申请”，则将显示“与 Autodesk 联系”页面以及相关的联系信息。

    激活码将以用户在“客户信息”页面上指定的方式发送。

  8. 如果需要打印一份注册信息，请选择“打开激活申请表”。完成后单击“关闭”。

(Windows) 接收许可文件并将它保存到本地后，请参见如何配置许可服务器 (Windows)以配置许可管理器。

注意建议将许可文件保存在安装 Network License Manager 的位置。


手动获取服务器主机名和主机 ID

使用网络许可证激活实用程序
网络许可工具
配置许可服务器 (Windows)
网络许可工具 >
手动获取服务器主机名和主机 ID
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果无法使用网络许可证激活实用程序获取服务器主机名和主机 ID，则可以手动获取这些信息。Autodesk 使用服务器主机名、主机 ID 和产品序列号生成许可文件。

要手动获取这些信息，可以使用 Windows 命令提示符或运行 lmtools.exe 实用程序。如果使用 lmtools.exe，请勿在远程工作站上运行。

使用 Windows 命令提示符获取主机名和主机 ID 的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “附件” [image] “命令提示符”。
    • (Windows Vista) 依次单击“开始” [image] “所有程序” [image] “附件” [image] “命令提示符”。
  2. 在 Windows 命令提示符下，输入以下命令，然后按 ENTER 键：

    ipconfig /all

  3. 找到“Host Name”行，记下主机名。
  4. 找到“Physical Address”行。记下物理地址，并删除虚线。这就是十二个字符的主机 ID。
    注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。确定哪些适配器是物理适配器的步骤：在 Windows 命令提示中，输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中的任意一个。VPN 适配器、PPP 适配器和调制解调器等设备无效。
  5. 关闭 Windows 命令提示。

使用 lmtools.exe 获取主机名和主机 ID 的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 Lmtools 程序中，单击“System Settings”选项卡。
  3. 在“System Settings”选项卡中，找到“Computer/Hostname”框。复制主机名并将该信息粘贴到文本编辑器中。
  4. 找到“Ethernet Address”框。以太网地址为主机 ID。该地址包含十二个字符。记下相应信息。如果以太网地址包含的字符超过十二个，则只需记下前十二个字符。
    注意如果服务器具有多个以太网适配器，请选择与物理网络适配器相对应的适配器。
  5. 关闭 lmtools.exe。


配置许可服务器 (Windows)

手动获取服务器主机名和主机 ID
网络许可工具
停止和重新启动许可服务器
网络许可工具 >
配置许可服务器 (Windows)
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

要能够管理运行网络许可证激活实用程序时收到的 Autodesk 产品许可，需要配置许可服务器。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，确保“Configure Using Services”选项处于激活状态。
  3. 单击“Config Services”选项卡。
  4. 在“Service Name”列表中，选择要用来管理许可证的服务名。

    默认情况下，服务名为“Flexlm Service 1”。如果 FLEXnet® 还用于管理计算机上除 Autodesk 外的其他软件，可更改服务名称以避免混淆，例如，可将 Flexlm Service 1 重命名为 Autodesk Server1。

    注意如果有多个软件供应商使用 FLEXnet® 进行许可管理，则“Service Name”列表将包含多个选项。确保仅列出一个 Autodesk 服务。
  5. 在“Path to Lmgrd.exe File”字段中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此后台程序将安装在 C:\Program Files\Autodesk Network License Manager 文件夹。

  6. 在“Path to the license file”框中，输入指向许可文件的路径，或单击“Browse”以定位文件。

    这是通过网络许可证激活实用程序获得的许可文件的路径，或脱机获得的许可文件的放置位置。

  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。

    建议保存至 \Program Files\Autodesk Network License Manager 文件夹。日志文件必须具有 .log 文件扩展名。对于新的日志文件，用户必须手动输入 .log 扩展名。

  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。如果要将设置保存到服务，则在提示时单击“是”。
  11. 单击“Start/Stop/Reread”选项卡，然后执行下列操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”，使用对许可文件或选项文件所做的所有更改来刷新 Network License Manager。

    许可服务器开始运行，并准备响应客户端请求。

  12. 关闭 lmtools.exe。


停止和重新启动许可服务器

配置许可服务器 (Windows)
网络许可工具
设置和使用选项文件
网络许可工具 >
停止和重新启动许可服务器
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

对许可服务器进行系统维护之前，必须停止该许可服务器。完成维护后，可以重新启动该许可服务器。

停止许可服务器的步骤 (Windows)

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 LMTOOLS 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 选择要手动启动的许可服务器的服务名。
  4. 单击“Start/Stop/Reread”选项卡。
  5. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  6. 关闭 lmtools.exe。

重新启动许可服务器的步骤 (Windows)

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 LMTOOLS 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 选择要手动启动的许可服务器的服务名。
  4. 单击“Start/Stop/Reread”选项卡。
  5. 在“Start/Stop/Reread”选项卡中，单击“Start Server”以重新启动许可服务器。


设置和使用选项文件

停止和重新启动许可服务器
网络许可工具
创建报告日志
网络许可工具 >
设置和使用选项文件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

使用选项文件可以设置配置选项，以管理所设置的每台许可服务器上的许可。选项文件可设置由许可文件读取并由 Lmgrd 程序执行的参数。

如果希望部分或所有许可服务器具有相同的许可行为，必须将同一个选项文件保存到每台许可服务器中。如果要在不同的许可服务器上指定不同的许可行为，则必须为每个许可行为都创建一个选项文件。必须将每个选项文件保存到需要特定许可行为的服务器中。

注意要使对选项文件所做的修改在许可服务器中生效，必须保存该选项文件，然后使用 lmtools.exe 重新读取该许可文件。

使用选项文件可以完成以下操作：

  • 创建报告日志
  • 配置许可借用功能
  • 设置许可超时

以下是选项文件内容的样例：

REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk_f1 3

TIMEOUT Autodesk_f1 7200

还可以设置高级许可参数，例如，保留许可、限制许可的使用或定义用户组。要了解有关设置高级选项文件参数的详细信息，请参见 C:\Program Files\Autodesk Network License Manager\docs\FlexUser 文件夹中的 FLEXnet 文档。

创建选项文件的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 打开文本编辑器，输入所需参数，然后将文档命名为 adskflex.opt 并将其保存到许可文件所在位置。
    注意请确保使用扩展名 .opt 保存该文件。Network License Manager 无法识别默认的扩展名 .txt。
  2. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  3. (Windows) 在程序中的“Start/Stop/Reread”选项卡中，单击“ReRead License File”。
  4. (Windows) 关闭 lmtools.exe。

本节内容

  • 创建报告日志
  • 配置许可借用功能
  • 设置许可超时


创建报告日志

设置和使用选项文件
设置和使用选项文件
配置许可借用功能
网络许可工具 > 设置和使用选项文件 >
创建报告日志
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以在选项文件中创建与 SAMreport-Lite 一起使用的报告日志文件。

创建报告日志的步骤

  1. 在文本编辑器中，打开选项文件 adskflex.opt。
  2. 在选项文件中，在单独的行中输入以下语法（以大写形式输入 REPORTLOG，如下所示）：

    REPORTLOG [+]report_log_path

    例如，(Windows) 语法 REPORTLOG +"c:\My Documents\report.rl" 表示名为 report.rl 的报告日志位于 c:\My Documents 文件夹中。

    注意包含空格的路径名必须用引号括起。

    在 REPORTLOG 语法中，“[+]”表示每次重新启动 Network License Manager 时，将向所创建的日志文件中附加条目而不是替换其中的条目。（建议您使用此选项，这样可以保留日志条目的历史记录。）


配置许可借用功能

创建报告日志
设置和使用选项文件
设置许可超时
网络许可工具 > 设置和使用选项文件 >
配置许可借用功能
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

如果 Autodesk 产品支持许可借用功能，则可以使用选项文件配置许可借用选项。例如，可以定义一次最多可以从网络上借用的许可数。另外，还可以定义哪些用户可以借用 Autodesk 产品许可。许可是按用户借用，而不是按计算机借用的。

注意如果 Autodesk 产品支持许可借用功能，并且许可是从冗余许可服务器池借用的，则在停止 Network License Manager 之后必须重新启动许可服务器。

当借用到期时，借用的许可将自动在用户计算机上被禁用，而在许可服务器上重新变为可用状态。用户也可以在借用到期之前返还许可。

设置许可借用参数的步骤

  1. 在选项文件中，在单独的行中输入以下语法（以大写形式输入 BORROW_LOWWATER，如下所示）：

    BORROW_LOWWATER feature_code n

    在 BORROW 语法中，“feature_code”表示许可文件中的产品名称，“n”表示无法借用的许可数目。

    例如，语法 BORROW_LOWWATER Autodesk_f1 3 表示对于产品 Autodesk_f1，有三个许可无法从许可服务器借用。

  2. 在下一行输入以下语法（以大写形式输入 MAX_BORROW_HOURS，如下所示）：

    MAX_BORROW_HOURS feature_code n

    在此语法中，“n”表示许可可以借用的小时数。

    例如，语法 MAX_BORROW_HOURS Autodesk_f1 360 表示对于产品 Autodesk_f1，许可可以借用 360 小时，即 15 天。

    注意许可的借用仅以 24 小时为增量单位，不使用任何大于 24 小时的增量。例如，365 将舍入为 360 小时，即 15 天。

有关设置许可借用功能的详细信息，请参见 C:\Program Files\Autodesk Network License Manager\Docs\FlexUser 文件夹中的 FLEXnet 文档。

注意用户可以通过在 Autodesk 产品中依次单击“工具”菜单 [image] “许可借用”，或者在 Autodesk 产品命令行中输入 borrowlicense，来借用许可。可以从“借用 [Autodesk 产品] 的许可”窗口中，以及 C:\Program Files\[Autodesk Product]\Help\adsk_brw.chm. 中获取关于此功能的帮助信息。


设置许可超时

配置许可借用功能
设置和使用选项文件
删除安装 Network License Manager
网络许可工具 > 设置和使用选项文件 >
设置许可超时
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

许可超时是在选项文件中设置的，用于指定在许可服务器收回许可之前产品任务处于空闲状态的时间。在选项文件中设置此标志后，如果产品在工作站上空闲的时间超过定义的超时时间，则许可服务器将收回用户的许可。

如果因空闲时间超时而导致用户许可丢失，则当用户再次使用该产品时，它将尝试获取新的许可。如果无可用许可，用户可以在产品关闭之前保存工作。

可使用 TIMEOUT 参数为计算机上的每个 Autodesk 产品设置单独的许可超时，也可以使用 TIMEOUTALL 参数为计算机上所有的 Autodesk 产品设置一个许可超时。

设置许可超时参数的步骤

  • 对于单独的 Autodesk 产品：在选项文件中，在单独的行中输入以下语法（以大写形式输入 TIMEOUT，如下所示）：

    TIMEOUT feature_code n

    在 TIMEOUT 语法中，“feature_code”表示产品的名称（在许可文件中的 INCREMENT 行），“n”表示距离许可服务器收回不活动许可的秒数。

    例如，语法 TIMEOUT Autodesk_f1 7200 表示对于产品 Autodesk_f1，许可超时时间设置为 7200 秒，即两小时。

  • 对于所有的 Autodesk 产品：在选项文件中，在单独的行中输入以下语法（以大写形式输入 TIMEOUTALL，如下所示）：

    TIMEOUTALL n

    在 TIMEOUTALL 语法中，“n” 表示距离许可服务器收回不活动许可的秒数。

    例如，语法 TIMEOUTALL Autodesk 7200 表示对于所有的 Autodesk 产品，许可超时时间设置为 7200 秒，即两小时。

关于使用许可超时功能的详细信息，请参见 C:\Program Files\Autodesk Network License Manager\Docs\FlexUser 文件夹中的 FLEXnet 文档。


删除安装 Network License Manager

设置许可超时
网络许可工具
词汇表
网络许可工具 >
删除安装 Network License Manager
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

可以从许可服务器删除安装 Network License Manager。删除安装 Network License Manager 后，用户将无法再使用许可。

删除安装 Network License Manager 的步骤

  1. 执行以下操作之一：
    • (Windows XP) 依次单击“开始” [image] “程序” [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • (Windows Vista) 双击桌面上的 LMTOOLS 图标。
  2. 在 LMTOOLS 程序中，单击“Start/Stop/Reread”选项卡。
  3. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  4. 关闭 lmtools.exe。
  5. 在 Windows“控制面板”窗口中，双击“添加/删除程序”。
  6. 在“添加/删除程序”窗口中，单击“Autodesk Network License Manager”。单击“删除”。
  7. 如果出现提示，请重新启动计算机。
注意必须手动删除所创建的用来与 Network License Manager 一起使用的文件（例如日志文件、许可文件和选项文件）。删除安装 Network License Manager 时，系统不会自动删除这些文件。


词汇表

删除安装 Network License Manager
词汇表
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节
adskflex.exe

Autodesk 供应商后台程序，与 FLEXnet 许可技术一起使用。此守护程序用于跟踪签出的 Autodesk 许可和使用这些许可的工作站。

ADSKFLEX_LICENSE_FILE

分布式许可服务器配置中的环境变量，用于将工作站指向分布式许可服务器。

FLEXnet

在 Autodesk 系列产品中应用的 Acresso Software 许可管理技术。

JRE（Java 运行时环境）

运行 Java 程序所需的程序。此程序必须与 SAMreport-Lite 一起安装。

licpath.lic

在单个服务器和冗余服务器配置中，用来将工作站指向 FLEXnet 许可服务器的文件。Licpath.lic 位于根安装文件夹中。

lmgrd.exe

许可管理器守护程序。此后台程序处理与程序的初始连接，然后将连接传递给供应商后台程序 adskflex.exe。

lmtools.exe

一个图形用户界面实用程序，用来管理 FLEXnet 许可技术。（Lmutil.exe 是此实用程序的命令行版本。）

lmutil.exe

一个命令行实用程序，用来管理 FLEXnet 许可技术。（Lmtools.exe 是此实用程序的图形用户界面版本。）

Network License Manager

Autodesk 用来管理网络许可的技术。

SAMreport-Lite

Acresso Softwares 的 SAMreport 工具的一个版本。SAMreport-Lite 包含在 Autodesk 产品光盘中。

主守护程序

参见 lmgrd.exe。

主机 ID

网络适配器的唯一硬件地址。也称为以太网地址或物理地址。

主机名

与计算机相关联的 TCP/IP 名称。FLEXnet 技术将主机名用作参数，主机名必须不同于 NetBIOS（服务器）名。

以太网地址

请参见主机 ID。

供应商守护程序

参见 adskflex.exe。

借用的许可

一种许可，允许用户在有限时间内使用 Autodesk 产品，而无需购买单独的许可或具备对许可服务器的网络访问权。

冗余服务器

一个许可服务器配置选项，其中使用三台服务器管理许可。冗余服务器共享一个许可文件和一个许可池。只要三台服务器中有两台在运行并与其他服务器进行通讯，冗余服务器池即可正常运作。

分布式服务器

一个许可服务器配置选项，在其中使用若干台服务器来管理许可的分发。每台分布式许可服务器都有自己的许可文件和一定数量的许可。如果一台分布式许可服务器出现故障，其他服务器仍能分发它们的许可。

功能代码

表示产品受该许可文件支持的许可文件参数。

守护程序

一个在计算机后台连续运行的程序。守护程序处理来自计算机的请求，然后将这些请求转发给其他程序或进程。Network License Manager 使用两种守护程序：供应商守护程序 (adskflex.exe) 和许可管理器守护程序 (lmgrd.exe)。

展开

在服务器上创建的文件和文件夹，由工作站用来安装 Autodesk 程序。

工作站

由网络中的单个用户使用的桌面计算机。

心跳信号

Network License Manager 和工作站之间的通信信号，用于确认工作站是否可以访问以及是否正在运行活动的 Autodesk 产品任务。

报告日志文件

与 FLEXnet 和 SAMreport-Lite 一起使用的文件。此日志文件提供有关网络许可使用情况的信息。报告日志由选项文件中创建。

物理地址

参见主机 ID。

空闲

产品中的非活动状态，用于提示网络许可服务器收回许可。如果在选项文件中定义的时间段内，不进行任何鼠标或键盘操作，不执行任何命令、LISP 表达式、菜单宏或脚本，将进入不活动状态。请参见许可超时。

网络许可安装

一种安装，要求用户从网络服务器安装并运行 Network License Manager。必须先安装并配置 Network License Manager，客户端才能运行 Autodesk 产品。

网络许可证激活实用程序

允许网络管理员通过 Internet 向网络版的 Autodesk 产品颁发许可和进行授权的实用程序。

许可文件

与 FLEXlm 一起使用的文件，用来控制允许使用的套数。此文件必须是 ASCII 纯文本格式。

许可服务器

包含 Network License Manager 的服务器。

许可超时

一个允许用户在许可服务器上设置超时时间的特征，当到达所设置的时间后，则自动将空闲的许可返回服务器以便再次使用。

调试日志文件

与 FLEXnet 一起使用的文件，用以记录 Network License Manager 和工作站之间的连接活动（例如许可故障、启动或停止）。

选项文件

由 FLEXnet 使用的文件，用来控制许可管理器参数（例如，保留许可以及创建与 SAMreport-Lite 一起使用的报告日志）。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！