AutoCAD 2010 自述

安装、配置和硬件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

本自述包含有关 AutoCAD 的重要信息，这些信息可能未包含在印刷文档或帮助中。

本节内容

  • 安装、配置和硬件
  • 加入客户参与计划

    将邀请用户参与帮助引导 Autodesk 设计软件的方向。

  • 概述
  • 图形卡驱动程序更新
  • 绘图和编辑
  • 用户界面
  • 命令和系统变量历史记录
  • 系统需求
  • 产品删除
  • 商标
  • 附加信息
请将您关于此页内容的评论发送给我们


安装、配置和硬件

加入客户参与计划
AutoCAD 2010 自述 >
安装、配置和硬件
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

安装和配置

注意安装 AutoCAD 2010 之前，应关闭所有正在运行的应用程序。

从双 CD/DVD ROM 驱动器系统安装

如果尝试将两张安装光盘同时放入双 CD/DVD ROM 驱动器系统中的两个驱动器来安装 AutoCAD 2010，安装将失败。为完成安装过程，必须使用同一光盘驱动器。

Visual Basic for Applications (VBA)

现在可以通过我们的网站 http://www.autodesk.com/vba-download 免费下载 Microsoft VBA。Autodesk 已开始从 VBA 技术向 VSTA 和 .NET 支持过渡。此过渡将将持续几年时间。在此期间，Autodesk 将提供文档及其他帮助来帮助我们的客户和开发人员从 VBA 移植到此项新自动化技术。我们将继续在我们的产品（包括 AutoCAD 2010 及所有基于 AutoCAD 2010 的工业设计产品）中完全支持 VBA。免费下载并安装 VBA 后，现有的基于 VBA 的应用程序应以在 AutoCAD 的早期版本中相同的方式运行。

要安装 AutoCAD 2010 VBA 模块，请根据操作系统从 http://www.autodesk.com/vba-download 下载其 32 位版本或 64 位版本。

对于 32 位版本
AutoCAD2010VbaEnabler32.exe
对于 64 位版本
AutoCAD2010VbaEnabler64.exe
  1. 关闭所有程序。
  2. 在 Windows 资源管理器中，双击已下载的自解压 EXE 文件。
  3. 将该文件解压到所选位置，也可以使用默认位置。
  4. 按照屏幕上的说明进行操作。

从网络驱动器启动 HTML 帮助时失败

用户无法通过网络驱动器启动帮助系统。将显示“无法显示页面”警告。产生此限制的原因是 Microsoft 提供的 Windows 安全更新 #896258。

使用 SCCM 安装 DirectX 失败

在运行 Microsoft Windows XP 的 32 位和 64 位系统上使用 Microsoft System Center Configuration Manager 2007 安装 DirectX 将失败。使用 SCCM 进行安装之前，请从 AutoCAD 2010 安装光盘下载并安装 DirectX 2008（位于下列某一目录中，请根据您的处理器类型进行选择）：

  • <介质根目录>\x86\support\DirectX
  • <介质根目录>\x64\support\DirectX

使用 SCCM 安装 VC++ Runtime 会强制重启动

在运行 Microsoft Windows XP 的系统上使用 SCCM 2007 安装 VC++ Runtime 将失败。使用 SCCM 进行安装之前，请从 AutoCAD 2010 安装光盘下载并安装 VC++ 2008 SP1 Runtime（位于下列某一目录中，请根据您的处理器类型进行选择）：

  • <介质根目录>\x86\support\VCRedist\2008\x86
  • <介质根目录>\x64\support\VCRedist\2008\x64

REMEMBERFOLDERS 系统变量

REMEMBERFOLDERS 系统变量的帮助主题不准确。正确信息如下所示。

类型: 整数

保存位置: 注册表

初始值: 1

控制标准文件选择对话框中“查找范围”或“保存位置”选项的默认路径。

0 | 恢复 AutoCAD 2000 和早期版本的行为。通过双击图标启动 AutoCAD 时，如果指定了图标的“起始”路径，则该路径将用作所有标准文件选择对话框的默认路径。
1 | 指定每个标准文件选择对话框中的默认路径均为该对话框中使用的最后一个路径。不使用为 AutoCAD 图标指定的起始文件夹。

使用组策略安装展开

帮助主题“使用组策略安装展开”缺少信息。正确信息如下所示。

使用组策略，可以通过将展开指定给用户的计算机来播发程序。

为了使 AutoCAD 正常运行，必须在要安装本程序的计算机上安装以下软件：

  • Microsoft .NET 3.5 SP1（可从产品光盘上获取）
  • Microsoft Internet Explorer version 6.0 SP1 或更高版本（要下载 Microsoft Internet Explorer，请访问 www.microsoft.com）
  • Microsoft Installer Package (MSI) 4.5
  • Microsoft Windows Media Format 9.5（64 位系统的必备软件）
  • Macromedia Flash Player 9.0 或更高版本（默认情况下不安装）
  • Autodesk Design Review 2010（默认情况下不安装）
  • 适用于 x86 操作系统的 VC++ 2008 SP1 Runtime 和 VC++ 2005 SP1 Runtime；适用于 64 位操作系统的 VC++ 2008 SP1 Runtime 和 VC++ 2005 SP1 Runtime（可从产品光盘上获取）
  • Microsoft National Language Support Downlevel API（可从产品光盘上获取）

展开中的自定义文件夹可能会导致 AutoCAD 崩溃。

新的 AutoCAD 2010 展开向导 - “选择“支持内容”的安装文件夹”对话框允许用户指定从中复制支持内容的自定义文件夹。

在此对话框中，如果 Microsoft Vista 用户访问控制允许用户级别对指定文件夹位置的访问权限为只读，则 AutoCAD 可能会崩溃。要避免发生崩溃，用户需确保在使用“自定义文件夹”选项创建展开时具有 Microsoft Vista 计算机上的写入选项。

适用于展开图像的“单独的共享文件夹”选项

使用“单独的共享文件夹”选项创建展开图像时，请指定文件夹名称，以避免创建无效的展开图像。请勿将文件夹名称保留为“<共享文件夹路径>”。

许可

通过 Autodesk.com 激活网络许可证的步骤

如果产品不包含网络许可证激活实用工具，可以转到 http://www.autodesk.com/register 并按照屏幕上的说明来激活许可证。

在 Microsoft Windows Vista 上运行 Network License Manager

在 Microsoft Windows Vista 工作站上启动 AutoCAD 2010 的网络版时，如果许可管理器正在 Windows Vista（FLEXlm 服务器版本 11.4.100）上运行，用户可能会遇到许可错误 - 15。请执行以下操作：

  • 为 Microsoft Windows Vista 安装最新的 Service Pack 和更新。

如果仍旧遇到错误，请执行以下操作：

  • 在“开始”菜单 (Windows Vista) 上，依次单击“控制面板” [image] “网络和共享中心” [image] “管理网络连接”。在“本地连接”上单击鼠标右键。单击“特性”。清除“Internet 协议 6 (TCP/IPv6)”的复选标记。单击“确定”。

将在两个位置创建 FlexLM 许可证

对于使用 64 位 Windows Vista 的非管理员用户来说，可能不会在启动 AutoCAD 2010 时显示“FLEXlm 许可证查找程序”对话框。许可服务器路径信息存储在路径 HLKM\STOFTWARE\Wow6432Node 中，非管理员用户无法访问该路径。

要修复该问题，请复制存储在上述路径中的许可服务器路径信息以转到“HKLM\software\FLEXlm License Manager”路径。

硬件

图形卡驱动程序更新

为了获得程序的最佳性能，请验证并更新图形卡驱动程序。有关详细信息，请参见图形卡驱动程序更新。

远程访问应用程序

将 AutoCAD 2010 配置为使用硬件加速时，建议不要将其与任何类型的远程访问应用程序配合使用。大部分远程访问应用程序都不支持硬件加速，这可能会导致出现常规显示问题和显示不稳定的情况。如果需要使用远程访问应用程序，请禁用硬件加速或使用 /NOHARDWARE 命令行参数在软件模式下启动 AutoCAD 2010。

硬件认证数据库

要下载并安装最新的硬件证书 XML 文件，请访问 硬件证书网站。


加入客户参与计划

安装、配置和硬件
概述
AutoCAD 2010 自述 >
加入客户参与计划
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

将邀请用户参与帮助引导 Autodesk 设计软件的方向。

如果用户参加客户参与计划，则有关用户如何使用 AutoCAD 的具体信息将发送至 Autodesk。这些信息包括用户最常使用的功能、遇到的问题以及有助于产品将来发展方向的其他信息。

有关详细信息，请参阅以下链接。

  • 若要了解有关 Autodesk 客户参与计划的详细信息，请访问：http://www.autodesk.com/cip

  • 阅读 Autodesk 隐私保护声明： http://www.autodesk.com/cipprivacy

启用或禁用 CIP 的步骤

  1. 请在“信息中心”工具栏上的“帮助”按钮右侧单击下拉箭头。
  2. 单击“客户参与计划”。
  3. 在“客户参与计划”对话框中，选择参与级别。
  4. 单击“确定”。


概述

加入客户参与计划
图形卡驱动程序更新
AutoCAD 2010 自述 >
概述
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

命令版本控制

从 AutoCAD 2009 开始，动作录制器中引入了命令版本控制。命令版本控制允许 AutoCAD 追踪执行动作宏、脚本文件或 CUI 命令宏时应使用的命令叠代。由于此更改，某些命令可能要求在 CUI 命令宏中使用 ^R 控制序列。

^R 控制序列强制使 AutoCAD 使用命令的最新版本。如果未使用 ^R 控制序列，则将使用命令的最早版本。

例如，使用 FILLET 命令的 CUI 命令宏将要求使用 ^R 控制序列来确保该宏在 AutoCAD 2008 和早期版本中运行方式相同。以下是一个使用 ^R 控制序列的 CUI 命令宏的样例：

^C^C^R_fillet;u; r;0.1;

受命令版本影响的与 CUI 命令宏配合使用的一些常用命令包括：

  • CHAMFER
  • COLOR
  • EXPLODE
  • FILLET
  • LAYOUT
  • LENGTHEN
  • TRIM

如果用户使用的是 AutoLISP，则可以通过在 Command 函数前添加 InitCommandVersion 函数来控制使用的命令版本。InitCommandVersion 函数的语法如下所示：

(InitCommandVersion <version_number>)

其中，version_number 控制 Command 函数所执行的命令应使用的命令版本。

将数据库配置为与 AutoCAD 图形配合使用 (dbConnect)

适用于 64 位操作系统的 AutoCAD 2010 不支持 Microsoft Jet 4.0 OLE DB Provider（用于 .MDB 连接）和 Microsoft OLE DB Provider for ODBC Drivers（用于 .XLS 连接）。有关详细信息，请参见《驱动程序和外围设备手册》中的“用 SQL Server 替代 OLE DB”。

图形文件格式兼容性

AutoCAD 2010 的原始图形文件格式与早期版本不兼容。AutoCAD 2010 可以打开早期版本中的图形文件格式；但是，要在早期版本中打开 AutoCAD 2010 文件，用户需要使用 SAVEAS 命令，并将其保存为相应格式。下表说明了保存为早期版本时要使用的图形文件格式。

图形文件格式 适用版本
AutoCAD 2007
  • AutoCAD 2007
  • AutoCAD 2008
  • AutoCAD 2009
AutoCAD 2004
  • AutoCAD 2004
  • AutoCAD 2005
  • AutoCAD 2006
AutoCAD 2000
  • AutoCAD 2000
  • AutoCAD 2000i
  • AutoCAD 2002
AutoCAD 14
  • AutoCAD R14

API 兼容性

AutoCAD 2010 不再提供与早期版本的二进制兼容性。大多数应用程序都需要进行重新编译且可能会被更改，以便可以在 AutoCAD 2010 中正确运行。有关详细信息，请参见《ObjectARX Migration Guide》。

Plot Styles 文件夹安装在 Plotters 文件夹下

Plot Styles 文件夹的路径已从与 Plotters 文件夹同一级移动到 Plotters 文件夹中的子目录。


图形卡驱动程序更新

概述
绘图和编辑
AutoCAD 2010 自述 >
图形卡驱动程序更新
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

用户应该验证并更新其图形卡驱动程序以优化 AutoCAD 2010。使用以下操作步骤确定当前的图形卡驱动程序。

确定图形卡驱动程序的步骤

  1. 启动 AutoCAD 2010。
  2. 在命令提示下，输入 3dconfig。
  3. 在“自适应降级和性能调节”对话框中，单击“查看调节日志”。
  4. 有关系统的图形卡驱动程序和驱动程序版本的信息，请查看“三维设备”部分。

如果用户认为确实需要更新驱动程序，请访问 http://www.autodesk.com/autocad-graphicscard 查找适用于用户图形卡的经过认证的驱动程序。如果没有找到，则请访问该图形卡制造商的网站。

注意如果图形卡制造商未提供更新的驱动程序，请查看系统制造商的网站。IBM、Hewlett Packard 和 Dell 等公司会经常提供各自的系统驱动程序。


绘图和编辑

图形卡驱动程序更新
用户界面
AutoCAD 2010 自述 >
绘图和编辑
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

块特性表

在块特性表中，不能输入小数和分数的组合。所有数值必须均为小数或分数。

自动约束的多段线

自动约束具有多个点的多段线可能会降低 AutoCAD 的性能，并使 AutoCAD 停止运行。

AutoCAD 早期版本中标注约束的更改

在 AutoCAD 早期版本中打开时，标注约束并不用作关联标注。要重新关联标注，请使用 DIMREASSOCIATE 命令。

在水平或竖直方向上旋转受约束的几何图形

在水平或竖直方向上旋转受约束的几何图形可能会导致产生意外结果。


用户界面

绘图和编辑
命令和系统变量历史记录
AutoCAD 2010 自述 >
用户界面
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

与在早期版本中一样显示 AutoCAD

AutoCAD 2010 引入了新外观和新用户界面，这更改了用户访问命令的方式。要与在早期版本中一样显示 AutoCAD 2010，请执行以下操作：

  1. 在状态栏上，单击“切换工作空间”。
  2. 从工作空间列表中，选择“AutoCAD 经典”。

使用工作空间切换 AutoCAD 界面

工作空间是菜单、工具栏、选项板和功能区面板的集合，将它们进行编组和组织来创建一个面向任务的绘图环境。除了“AutoCAD 传统格式”之外，以下基于任务的工作空间在 AutoCAD 2010 中可用：

二维草图与注释

显示二维绘图特有的工具。显示新界面，包括功能区和应用程序菜单。

三维建模

显示三维建模特有的工具。显示新界面，包括功能区、应用程序菜单和“工具选项板”窗口。

要在可用的工作空间之间进行切换，请执行以下步骤之一：

  • 在状态栏上，单击“切换工作空间”并选择所需的工作空间。
  • 在“工作空间”工具栏上，在“工作空间”下拉列表中，选择所需的工作空间。

联机设计中心

默认情况下，联机设计中心（“联机设计中心”选项卡）在美式英语环境中处于禁用状态。可以从 CAD 管理员控制实用工具启用联机设计中心。

约束栏显示

在将 CONSTRAINTBAR 系统变量设置为“Showall”的情况下，即使将 CONSTRAINTBARDISPLAY 系统变量设置为 0，约束栏也将始终处于显示状态。


命令和系统变量历史记录

用户界面
系统需求
AutoCAD 2010 自述 >
命令和系统变量历史记录
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

了解 AutoCAD 2010 的途径

使用以下资源查找关于 AutoCAD 2010 的详细信息。

  • 新功能专题研习（“帮助”菜单）
  • 帮助系统（“帮助”菜单）
  • 开发人员帮助（“帮助”菜单 >“其他资源”）
  • Autodesk 国际用户组 (AUGI)（“帮助”菜单 >“其他资源”）
  • Autodesk 网站 http://www.autodesk.com.cn/adsk/servlet/home?siteID=1170359&id=1810417
  • 学习资源页面 http://www.autodesk.com/autocad-learningpath
  • 教程 http://www.autodesk.com/autocad-tutorials
  • Cue Cards http://usa.autodesk.com/adsk/servlet/item?siteID=123112&id=11527343&linkID=9240615

新命令

3DPRINT

将三维模型发送到三维打印服务。

3DSCALE

在三维视图中，显示三维缩放小控件以协助调整三维对象的大小。

ACTBASEPOINT

将基点插入动作宏。

ACTMANAGER

管理动作宏文件。

ADJUST
ATTACH

将外部参照、图像或参考底图（DWF、DWFx、PDF 或 DGN 文件）插入到当前图形中。

AUTOCONSTRAIN

根据对象相对于彼此的方向将几何约束应用于对象的选择集。

BACTIONBAR

为参数对象的选择集显示或隐藏动作栏。

BCONSTRUCTION

将几何图形转换为构造几何图形。

BCPARAMETER

将约束参数应用于选定的对象，或将标注约束转换为参数约束。

BESETTINGS

显示“块编辑器设置”对话框。

BTABLE

显示对话框以定义块的变量。

BTESTBLOCK

在块编辑器内显示一个窗口，以测试动态块。

CLIP

根据指定边界修剪选定的外部参照、图像、视口或参考底图（DWF、DWFx、PDF 或 DGN）。

CONSTRAINTBAR

可显示对象上的可用几何约束的工具栏状 UI 元素。

CONSTRAINTSETTINGS

控制约束栏上几何约束的显示。

DELCONSTRAINT

从对象的选择集中删除所有几何约束和标注约束。

DIMCONSTRAINT

将标注约束应用于选定的对象或对象上的点。

EXPORTDWF

创建 DWF 文件，并使用户可于逐张图纸上设置各个页面设置替代。

EXPORTDWFX

创建 DWFx 文件，从中可逐页设置各个页面设置替代。

EXPORTPDF

创建 PDF 文件，从中可逐页设置各个页面设置替代。

GEOMCONSTRAINT

应用对象之间或对象上的点之间的几何关系或使其永久保持。

MEASUREGEOM

测量选定对象或点序列的距离、半径、角度、面积和体积。

MESH

创建三维网格图元对象，例如长方体、圆锥体、圆柱体、棱锥体、球体、楔体或圆环体。

MESHCREASE

锐化选定网格子对象的边。

MESHOPTIONS

显示“网格镶嵌选项”对话框，此对话框用于控制将现有对象转换为网格对象时的默认设置。

MESHPRIMITIVEOPTIONS

显示“网格图元选项”对话框，此对话框用于设置图元网格对象的镶嵌默认值。

MESHREFINE

成倍增加选定网格对象或面中的面数。

MESHSMOOTHLESS

将网格对象的平滑度降低一级。

MESHSMOOTHMORE

将网格对象的平滑度提高一级。

MESHSPLIT

将一个网格面拆分为两个面。

MESHUNCREASE

删除选定网格面、边或顶点的锐化。

PARAMETERS

控制图形中使用的关联参数。

PARAMETERSCLOSE

关闭“参数管理器”选项板。

PDFADJUST

调整 PDF 参考底图的淡入度、对比度和单色设置。

PDFATTACH

将 PDF 文件作为参考底图插入当前图形中。

PDFCLIP

根据指定边界修剪选定 PDF 参考底图的显示。

PDFLAYERS

控制 PDF 参考底图中图层的显示。

-QUICKPUB

创建 DWF、DWFx 或 PDF 文件，并使用户可于逐张图纸上设置各个页面设置替代。

REVERSE

反转选定直线、多段线、样条曲线和螺旋线的顶点顺序。

SECTIONPLANEJOG

将折弯线段添加至截面对象。

SECTIONPLANESETTINGS

设置选定截面平面的显示选项。

SECTIONPLANETOBLOCK

将选定截面平面保存为二维或三维块。

SEEK

打开 Web 浏览器并显示 Autodesk Seek 主页。

SHAREWITHSEEK

将块或图形上载至 Autodesk Seek 网站。

TEXTEDIT

编辑标注约束、标注或文字对象。

ULAYERS

控制 DWF、DWFx、PDF 或 DGN 参考底图中图层的显示。

修改的命令

3DMOVE

在三维视图中，显示三维移动小控件以帮助在指定方向上按指定距离移动三维对象。

3DROTATE

在三维视图中，显示三维旋转小控件以协助绕基点旋转三维对象。

ADCENTER

管理和插入诸如块、外部参照和填充图案等内容。

ALIGN

在二维和三维空间中将对象与其他对象对齐。

ARCHIVE

将当前图纸集文件打包以便归档。

-ARCHIVE

将当前图纸集文件打包以便归档。

ATTSYNC

使用所指定块定义中新增和更改过的属性更新块参照。

AUTOPUBLISH

将图形自动发布为 DWF、DWFx 或 PDF 文件，发布至指定位置。

BATTMAN

管理选定块定义的属性。

CHAMFER

给对象加倒角。

COLOR

设置新对象的颜色。

CONVTOSOLID

将具有一定厚度的三维网格、多段线和圆转换为三维实体。

CONVTOSURFACE

将对象转换为三维曲面。

CUIEXPORT

将主 CUIx 文件中的自定义设置输出到企业或局部 CUIx 文件。

CUIIMPORT

将企业或局部 CUIx 文件中的自定义设置输入到主 CUIx 文件。

CUILOAD

加载 CUIx 文件。

CUIUNLOAD

卸载 CUIx 文件。

DGNADJUST

调整 DGN 参考底图的淡入度、对比度和单色设置。

-DGNADJUST

调整 DGN 参考底图的淡入度、对比度和单色设置。

DWFATTACH

将 DWF 或 DWFx 文件作为参考底图插入到当前图形中。

DWFFORMAT

将 PUBLISH、3DDWF、EXPORT、EXPORTDWF 和 EXPORTDWFX 命令的默认格式设置为 DFW 或 DWFx。

EATTEDIT

在块参照中编辑属性。

EDGESURF

在四条相邻的边或曲线之间创建网格。

ETRANSMIT

将一组文件打包以进行 Internet 传递。

-ETRANSMIT

将一组文件打包以进行 Internet 传递。

EXPLODE

将复合对象分解为其组件对象。

EXTERNALREFERENCES

打开“外部参照”选项板。

EXTRUDE

将二维对象或三维面的标注延伸到三维空间。

FILLET

给对象加圆角。

FLATSHOT

基于当前视图创建所有三维对象的二维表示。

IMAGEFRAME

控制是否显示和打印图像边框。

IMPRINT

压印三维实体或曲面上的二维几何图形，从而在平面上创建其他边。

INTERFERE

通过两组选定三维实体之间的干涉创建临时三维实体。

-INTERFERE

通过两组选定三维实体之间的干涉创建临时三维实体。

INTERSECT

通过重叠实体、曲面或面域创建三维实体、曲面或二维面域。

LIST

为选定对象显示特性数据。

MARKUP

打开标记集管理器。

NAVSWHEEL

显示包含视图导航工具集合的控制盘。

NAVVCUBE

控制 ViewCube 工具的可见性和显示特性。

OPEN

打开现有的图形文件。

OPENDWFMARKUP

打开包含标记的 DWF 或 DWFx 文件。

OPTIONS

自定义程序设置。

PRESSPULL

按住或拖动有边界区域。

PUBLISH

将图形发布为 DWF、DWFx 和 PDF 文件，或发布到绘图仪。

-PUBLISH

将图形发布为 DWF、DWFx 和 PDF 文件，或发布到绘图仪。

PURGE

删除图形中未使用的项目，例如块定义和图层。

QSAVE

使用“选项”对话框中指定的文件格式保存当前图形。

REFCLOSE

保存或放弃在位编辑参照（外部参照或块）时所做的更改。

REFEDIT

直接在当前图形中编辑块或外部参照。

REFSET

在位编辑参照（外部参照或块）时将对象添加到工作集中，或从工作集中删除对象。

REVSURF

通过绕轴旋转轮廓来创建网格。

RULESURF

创建用于表示两条直线或曲线之间的曲面的网格。

SAVE

用当前的文件名或指定名称保存图形。

SAVEAS

用新文件名保存当前图形的副本。

SECTION

使用平面和实体、曲面或网格的交集创建面域。

SECTIONPLANE

以通过三维对象创建剪切平面的方式创建截面对象。

SLICE

通过剖切或分割现有对象，创建新的三维实体和曲面。

SOLIDEDIT

编辑三维实体对象的面和边。

STLOUT

将实体存储到 ASCII 或二进制文件中。

SUBTRACT

通过减操作来合并选定的三维实体、曲面或二维面域。

TABSURF

从沿直线路径扫掠的直线或曲线创建网格。

THICKEN

以指定的厚度将曲面转换为三维实体。

TRANSPARENCY

控制图像的背景像素是否透明。

UNION

通过加操作来合并选定的三维实体、曲面或二维面域。

XCLIP

根据指定边界修剪选定外部参照或块参照的显示。

XEDGES

从三维实体、曲面、网格、面域或子对象的边创建线框几何图形。

XOPEN

在新窗口中打开选定的图形参照（外部参照）。

新的系统变量

AUTOPUBFORMAT

控制保存或关闭图形 (DWG) 文件时是否自动创建电子文件 (DWF/PDF)。

BACTIONBARMODE

指示块编辑器中是否显示动作栏或传统动作对象。

BCONSTATUSMODE

打开或关闭约束显示状态，基于约束级别控制对象着色。

BLOCKTESTWINDOW

指示某个测试块窗口是否为当前窗口。

BPTEXTHORIZONTAL

强制使编辑器中为动作参数和约束参数显示的文字以水平方式显示。

CCONSTRAINTFORM

控制是将注释性约束还是将动态约束应用于对象。

CONSTRAINTBARDISPLAY

手动应用约束或自动约束对象后显示其约束栏。

CONSTRAINTBARMODE

控制约束栏中几何约束的显示。

CONSTRAINTNAMEFORMAT

控制标注约束的文字格式。

CONSTRAINTRELAX

指示编辑对象时约束是处于强制实行状态还是释放状态。

CONSTRAINTSOLVEMODE

控制应用或编辑约束时的约束行为。

DEFAULTGIZMO

选择子对象过程中将三维移动小控件、三维旋转小控件或三维缩放小控件设置为默认小控件。

DIMCONSTRAINTICON

在标注约束的文字旁边显示锁定图标。

DIMTXTDIRECTION

指定标注文字的阅读方向。

DIVMESHBOXHEIGHT

为网格长方体沿 Z 轴的高度设置细分数目。

DIVMESHBOXLENGTH

为网格长方体沿 X 轴的长度设置细分数目。

DIVMESHBOXWIDTH

为网格长方体沿 Y 轴的宽度设置细分数目。

DIVMESHCONEAXIS

设置绕网格圆锥体底面周长的细分数目。

DIVMESHCONEBASE

设置网格圆锥体底面周长与圆心之间的细分数目。

DIVMESHCONEHEIGHT

设置网格圆锥体底面与顶点之间的细分数目。

DIVMESHCYLAXIS

设置绕网格圆柱体底面周长的细分数目。

DIVMESHCYLBASE

设置绕网格圆柱体底面周长的细分数目。

DIVMESHCYLHEIGHT

设置网格圆柱体的底面与顶面之间的细分数目。

DIVMESHPYRBASE

设置网格棱锥体底面圆心与其周长之间的半径细分数目。

DIVMESHPYRHEIGHT

设置网格棱锥体的底面与顶面之间的细分数目。

DIVMESHPYRLENGTH

设置沿网格棱锥体底面每个标注的细分数目。

DIVMESHSPHEREAXIS

设置绕网格球体轴端点的半径细分数目。

DIVMESHSPHEREHEIGHT

设置网格球体两个轴端点之间的细分数目。

DIVMESHTORUSPATH

设置由网格圆环体轮廓扫掠的路径的细分数目。

DIVMESHTORUSECTION

设置扫掠网格圆环体路径的轮廓中的细分数目。

DIVMESHWEDGEBASE

设置网格楔体的周长中点与三角形标注之间的细分数目。

DIVMESHWEDGEHEIGHT

设置网格楔体沿 Z 轴的高度细分数目。

DIVMESHWEDGELENGTH

设置网格楔体沿 X 轴的长度细分数目。

DIVMESHWEDGESLOPE

设置从楔体顶点到底面的边之间斜度的细分数目。

DIVMESHWEDGEWIDTH

设置网格楔体沿 Y 轴的宽度细分数目。

DYNCONSTRAINTDISPLAY

显示或隐藏动态约束。

FACETERDEVNORMAL

设置曲面法线与相邻网格面之间的最大角度。

FACTERDEVSURFACE

设置经转换的网格对象与实体或曲面的原始形状的相近程度。

FACTERGRIDRATIO

为转换为网格的实体和曲面而创建的网格细分设置最大宽高比。

FACTERMAXEDGELENGTH

为通过从实体和曲面转换创建的网格对象设置边的最大长度。

FACTERMAXGRID

为转换为网格的实体和曲面设置 U 栅格线和 V 栅格线的最大数目。

FACTERMESHTYPE

设置要创建的网格类型。

FACTERMINUGRID

为转换为网格的实体和曲面设置 U 栅格线的最小数目。

FACTERMINVGRID

为转换为网格的实体和曲面设置 V 栅格线的最小数目。

FACTERPRIMITIVEMODE

指定转换为网格的对象的平滑度设置是来自“网格镶嵌选项”对话框还是来自“网格图元选项”对话框。

FACTERSMOOTHLEV

设置转换为网格的对象的默认平滑度。

FRAME

为所有外部参照、图像和 DWF、DWFx、PDF 和 DGN 参考底图打开和关闭框架的显示。

GRIPSUBOBJMODE

设置最初选择时，激活边夹点、面夹点还是顶点夹点。

LARGEOBJECTSUPPORT

控制打开和保存图形时支持的最大对象大小限制。

MESHTYPE

控制通过 REVSURF、TABSURF、RULESURF 和 EDGESURF 命令创建的网格的类型。

MTEXTCOLUMN

为多行文字对象设置默认分栏设置。

PARAMETERCOPYMODE

控制再现受约束的几何图形时如何复制约束和参照变量。

PARAMETERSSTATUS

指示“参数管理器”选项板处于显示状态还是隐藏状态。

PDFFRAME

确定 PDF 参考底图边框是否可见。

PDFOSNAP

决定是否为附着在图形中的 PDF 参考底图中的几何图形激活对象捕捉。

RIBBONCONTEXTSELECT

控制单击或双击对象时功能区上下文选项卡的显示方式。

RIBBONCONTEXTSELLIM

选择集包括的对象多于指定数量时，不显示功能区上下文选项卡。

RIBBONSELECTMODE

决定调用功能区上下文选项卡并完成命令后预先选择集是否仍处于选中状态。

SMOOTHMESHCONVERT

设置是对转换为三维实体或曲面的网格对象进行平滑处理还是进行镶嵌，以及是否合并它们的面。

SMOOTHMESHGRID

设置底层网格镶嵌面栅格显示在三维网格对象中时的最大平滑度。

SMOOTHMESHMAXFACE

设置网格对象允许使用的最大面数。

SMOOTHMESHMAXLEV

设置网格对象的最大平滑度。

SUBOBJSELECTIONMODE

过滤执行 Ctrl+单击操作时将选定面、边还是顶点。

UOSNAP

决定是否为附加到图形中的 DWF、DWFx、PDF 和 DGN 参考底图中的几何图形激活对象捕捉。

VPROTATEASSOC

控制旋转视口时视口内的视图是否随视口一起旋转。

XDWGFADECTL

控制所有 DWG 外部参照对象的淡入度。

修改的系统变量

DBLCLKEDIT

控制绘图区域中的双击编辑操作。

DELOBJ

控制保留还是删除用于创建三维对象的几何图形。

DIMTAD

控制文字相对于尺寸线的垂直位置。

ENTERPRISEMENU

存储企业自定义文件名（如果已定义），其中包括文件名的路径。

IMAGEFRAME

控制是否显示和打印图像边框。

ISOLINES

指定对象上每个曲面的轮廓素线数目。

MBUTTONPAN

控制定点设备上的第三个按钮或滚轮的行为。

MENUNAME

存储自定义文件名，包括文件名的路径。

NAVVCUBESIZE

指定 ViewCube 工具的大小。

PUBLISHALLSHEETS

指定在“发布”对话框中是加载激活文档的内容还是加载所有打开文档的内容。

REFEDITNAME

显示正在编辑的参照名称。

XFADECTL

控制进行在位编辑的参照的淡入度百分比。

XREFNOTIFY

控制关于已更新外部参照或缺少外部参照的通知。


系统需求

命令和系统变量历史记录
产品删除
AutoCAD 2010 自述 >
系统需求
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

在安装 AutoCAD 2010 之前，请确保计算机满足对硬件和软件的最低需求。

安装 AutoCAD 2010 时，会自动检测 Windows 操作系统是 32 位版本还是 64 位版本。将安装适当的 AutoCAD 2010 版本。无法在 Windows 的 64 位版本上安装 AutoCAD 2010 的 32 位版本。

查看下表的以了解硬件和软件需求。

硬件和软件需求
硬件/软件 需求 注解

操作系统

32 位

  • Microsoft® Windows® Vista® Business SP1
  • Microsoft Windows Vista Enterprise SP1
  • Microsoft Windows Vista Home Premium SP1
  • Microsoft Windows Vista Ultimate SP1
  • Microsoft Windows XP Home SP2 或更高版本
  • Microsoft Windows XP Professional SP2 或更高版本

64 位

  • Microsoft Windows Vista Business SP1
  • Microsoft Windows Vista Enterprise SP1
  • Microsoft Windows Vista Home Premium SP1
  • Microsoft Windows Vista Ultimate SP1
  • Microsoft Windows XP Professional x64 Edition SP2 或更高版本

有关 Windows Vista 版本的详细信息，请参见 http://www.microsoft.com/windowsvista/versions

建议在使用与 AutoCAD 2010 语言的代码页面相匹配的用户界面语言的操作系统上安装 AutoCAD 2010 的非英语语言版本。代码页面为在不同语言中使用的字符集提供了支持。

Web 浏览器

Microsoft Internet Explorer® 7.0 或更高版本
处理器

32 位

Windows XP

Intel Pentium 4 或 AMD Athlon™ Dual Core，1.6 GHz 或更高，采用 SSE2 技术

Windows Vista

Intel Pentium 4 或 AMD Athlon Dual Core，3.0 GHz 或更高，采用 SSE2 技术

64 位

AMD Athlon 64，采用 SSE2 技术

AMD Opteron™，采用 SSE 技术

Intel Xeon，支持 Intel EM64T 并采用 SSE2 技术

Intel Pentium 4，支持 Intel EM64T 并采用 SSE2 技术
内存

2 GB RAM

显示器分辨率

1024 x 768 真彩色

  • 需要一个支持 Windows 的显示适配器。
  • 对于支持硬件加速的图形卡，必须安装 DirectX 9.0c 或更高版本。
  • 从“ACAD.msi”文件进行的安装并不安装 DirectX 9.0c 或更高版本。必须手动安装 DirectX 以配置硬件加速。
硬盘

32 位

安装需要使用 1 GB

64 位

安装需要使用 1.5 GB

定点设备

MS-Mouse 兼容

DVD/CD-ROM

从 DVD 或 CD-ROM 下载并安装

若要进行三维建模，还需满足以下要求

Intel Pentium 4 或 AMD Athlon 处理器，3.0 GHz 或更高，或者 Intel Dual Core 或 AMD Dual Core 处理器，2.0 GHz 或更高

2 GB RAM 或更大

2 GB 可用硬盘空间（不包括安装所需空间）

1280 x 1024 32 位彩色视频显示适配器（真彩色），具有 128 MB 或更大显存，且支持 Direct3D® 的工作站级图形卡

对三维使用的其他建议
硬件/软件 需求 注解
操作系统

32 位

Microsoft Windows Vista Enterprise

Microsoft Windows Vista Business

Microsoft Windows Vista Ultimate

Microsoft Windows Vista Home Premium

Microsoft Windows XP Professional Edition (SP2)

Microsoft Windows XP Home Edition (SP2)

64 位

Microsoft Windows Vista Enterprise

Microsoft Windows Vista Business

Microsoft Windows Vista Ultimate

Microsoft Windows Vista Home Premium

Microsoft Windows XP Professional Edition (SP2)

建议在使用与 AutoCAD 2010 语言的代码页面相匹配的用户界面语言的操作系统上安装 AutoCAD 2010 的非英语语言版本。代码页面为在不同语言中使用的字符集提供了支持。

安装 AutoCAD 2010 时，会自动检测 Microsoft Windows 操作系统是 32 位版本还是 64 位版本。将安装适当的 AutoCAD 2010 版本。无法在 Microsoft Windows 的 64 位版本上安装 AutoCAD 2010 的 32 位版本。

处理器

Intel Pentium 4 处理器或 AMD Athlon，2.2 GHz 或更高

或

AMD 双核处理器，1.6 GHz 或更高

内存

2 GB（或更高）

图形卡

1280 x 1024 32 位彩色视频显示适配器（真彩色），具有 128 MB 或更大显存，且支持 OpenGL 或 Direct3D 的工作站级图形卡。

对于 Microsoft Windows Vista，需要 1024 x 768 VGA（真彩色），具有 128 MB 或更大显存，且支持 Direct3D 的工作站级图形卡（最低要求）

  • 需要一个支持 Windows 的显示适配器。
  • 对于支持硬件加速的图形卡，必须安装 DirectX 9.0c 或更高版本。
  • 从“ACAD.msi”文件进行的安装并不安装 DirectX 9.0c 或更高版本。必须手动安装 DirectX 以配置硬件加速。

关于测试和认证的图形卡的详细信息，请访问 http://www.autodesk.com/autocad-graphicscard

硬盘

2 GB（除了所需的用于安装的 1GB 或更高）

注意默认情况下不再安装 Adobe Flash Player。如果操作系统上当前未安装 Flash 的适当版本，系统将显示一条消息请求用户从 Adobe 网站进行下载。如果无法访问 Internet，同样可以访问 AutoCAD 2010 产品介质上的 Flash 安装程序。


产品删除

系统需求
商标
AutoCAD 2010 自述 >
产品删除
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

卸载 AutoCAD 2010 的步骤 (Windows XP)

  1. 在“开始”菜单 (Windows) 上，依次单击“设置” [image] “控制面板” [image] “添加或删除程序”。
  2. 选择“AutoCAD 2010”。单击“更改/删除”。
  3. 在“安装向导维护模式”页面上，单击“卸载”。
  4. 在“卸载 AutoCAD 2010”页面上，单击“下一步”。
  5. 单击“完成”。

卸载 AutoCAD 2010 的步骤（Windows Vista）

  1. 在“开始”菜单 (Windows) 上，依次单击“设置” [image] “控制面板” [image] “卸载程序”。
  2. 选择“AutoCAD 2010”。单击“卸载/更改”。

    如果显示“用户帐户控制”对话框，请单击“继续”。

  3. 在“安装向导维护模式”页面上，单击“卸载”。
  4. 在“卸载 AutoCAD 2010”页面上，单击“下一步”。
  5. 单击“完成”。


商标

产品删除
附加信息
AutoCAD 2010 自述 >
商标
全部展开
展开所有已收拢的章节
全部收拢
收拢所有已展开的章节

© 2009 Autodesk, Inc. All Rights Reserved. Except as otherwise permitted by Autodesk, Inc., this publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, ADI, Alias, Alias (swirl design/logo), AliasStudio, Alias|Wavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Create>what's>Next> (design/logo), Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (design/logo), Design Web Format, Discreet, DWF, DWG, DWG (logo), DWG Extreme, DWG TrueConvert, DWG TrueView, DXF, Ecotect, Exposure, Extending the Design Team, Face Robot, FBX, Filmbox, Fire, Flame, Flint, FMDesktop, Freewheel, Frost, GDX Driver, Gmax, Green Building Studio, Heads-up Design, Heidi, HumanIK, IDEA Server, i-drop, ImageModeler, iMOUT, Incinerator, Inferno, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), Kynapse, Kynogon, LandXplorer, LocationLogic, Lustre, Matchmover, Maya, Mechanical Desktop, Moonbox, MotionBuilder, Movimento, Mudbox, NavisWorks, ObjectARX, ObjectDBX, Open Reality, Opticore, Opticore Opus, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, ProMaterials, RasterDWG, Reactor, RealDWG, Real-time Roto, REALVIZ, Recognize, Render Queue, Retimer,Reveal, Revit, Showcase, ShowMotion, SketchBook, Smoke, Softimage, Softimage|XSI (design/logo), SteeringWheels, Stitcher, Stone, StudioTools, Topobase, Toxik, TrustedDWG, ViewCube, Visual, Visual Construction, Visual Drainage, Visual Landscape, Visual Survey, Visual Toolbox, Visual LISP, Voice Reality, Volo, Vtour, Wire, Wiretap, WiretapCentral, XSI, and XSI (design/logo).

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Backburner,Multi-Master Editing, River, and Sparks.

The following are registered trademarks or trademarks of MoldflowCorp. in the USA and/or other countries: Moldflow, MPA, MPA (design/logo),Moldflow Plastics Advisers, MPI, MPI (design/logo), Moldflow Plastics Insight,MPX, MPX (design/logo), Moldflow Plastics Xpert.

All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.

Published by:

Autodesk, Inc.

111 Mclnnis Parkway

San Rafael, CA 94903, USA


附加信息

商标
图形卡驱动程序更新
AutoCAD 2010 自述 >
附加信息

微软拼音输入法 2003 与动作录制器

使用微软拼音输入法 2003 输入中文可能导致动作录制器崩溃。安装微软拼音输入法 2007 可解决此问题。请查看 Microsoft 网站 http://www.microsoft.com/china/windows/products/ime/MSPY2007.mspx 上是否提供微软拼音输入法 2007 独立版。

字体

使用 DTEXT 命令时，为了在三维模式中正确查看双字节字符，必须通过在“样式”对话框中选择字体来设置本地字体。要访问“样式”对话框，请在命令行中输入 style。

安装

如果为安装目录选择中文名称而非默认名称，可能会改变产品的某些功能。强烈建议不要在安装目录名称中使用中文字符。

为图形文件添加密码时的限制

如果为多个图形使用同一密码，则密码对话框只在打开第一个图形时显示。 建议为每个图形添加不同的密码。

移植自定义设置和命令别名

如果成功完成移植后在 AutoCAD 2009 中使用命令别名时出现问题，请执行以下简单操作：将 AutoCAD 旧安装版本和新安装版本中所有 PGP 文件中的全部 TAB 分隔符均替换为空格，然后再次运行移植自定义设置工具。
请将您对本页面的意见发送给我们


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！